aboutsummaryrefslogtreecommitdiff
path: root/net/openmpi/Makefile
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2008-01-29 16:08:45 +0000
committerBrooks Davis <brooks@FreeBSD.org>2008-01-29 16:08:45 +0000
commit0d10ec3c901bb401a4caafa5bd313337c919e43c (patch)
tree1b2938740119081b06d9df5303f4a3eb3e8d0559 /net/openmpi/Makefile
parent383b44fe29c3727135b264991bb48788017a4632 (diff)
downloadports-0d10ec3c901bb401a4caafa5bd313337c919e43c.tar.gz
ports-0d10ec3c901bb401a4caafa5bd313337c919e43c.zip
Notes
Diffstat (limited to 'net/openmpi/Makefile')
-rw-r--r--net/openmpi/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/net/openmpi/Makefile b/net/openmpi/Makefile
index 759ab3f36d35..f180c2a3a6c5 100644
--- a/net/openmpi/Makefile
+++ b/net/openmpi/Makefile
@@ -9,8 +9,7 @@
# - etc/*.sample support
PORTNAME= openmpi
-DISTVERSION= 1.2.2
-PORTREVISION= 1
+DISTVERSION= 1.2.5
CATEGORIES= net parallel
MASTER_SITES= http://www.open-mpi.org/software/ompi/v1.2/downloads/
@@ -29,7 +28,9 @@ MPIDIR?= ${MPIBASE}/${UNIQUENAME}
PLIST_SUB+= MPIBASE=${MPIBASE}
PLIST_SUB+= MPIDIR=${MPIDIR}
-CONFIGURE_ARGS+= --prefix=${PREFIX}/${MPIDIR} ${CONFIGURE_TARGET}
+CONFIGURE_ARGS+= --prefix=${PREFIX}/${MPIDIR} \
+ --mandir=${PREFIX}/${MPIDIR}/man \
+ ${CONFIGURE_TARGET}
USE_LDCONFIG= ${PREFIX}/${MPIDIR}/lib \
${PREFIX}/${MPIDIR}/lib/openmpi
@@ -57,6 +58,9 @@ PLIST_SUB+= TORQUE=""
PLIST_SUB+= TORQUE="@comment "
.endif
+post-install:
+ cd ${WRKSRC}/ompi/mpi && make install-man
+
#######################################################################
# The following targets are for the port maintainer. Use at your own #
# risk, no user-serviceable parts inside. #