aboutsummaryrefslogtreecommitdiff
path: root/net/openmpi
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2013-06-05 20:40:58 +0000
committerBrooks Davis <brooks@FreeBSD.org>2013-06-05 20:40:58 +0000
commitf1639637de0fd7a19e963024714d2322574772d9 (patch)
treec752699af1cb9df173c52ea03338d6ae9cda1010 /net/openmpi
parentb43f09fd40b09765fd27dd0eb43626ffe659b1a8 (diff)
downloadports-f1639637de0fd7a19e963024714d2322574772d9.tar.gz
ports-f1639637de0fd7a19e963024714d2322574772d9.zip
Notes
Diffstat (limited to 'net/openmpi')
-rw-r--r--net/openmpi/Makefile22
-rw-r--r--net/openmpi/files/patch-ompi_tools_wrappers_Makefile.in14
-rw-r--r--net/openmpi/files/patch-orte_tools_wrappers_Makefile.in14
-rw-r--r--net/openmpi/pkg-plist13
4 files changed, 38 insertions, 25 deletions
diff --git a/net/openmpi/Makefile b/net/openmpi/Makefile
index 0836a9ebcb43..836274b0772c 100644
--- a/net/openmpi/Makefile
+++ b/net/openmpi/Makefile
@@ -1,4 +1,3 @@
-# Created by: Brooks Davis <brooks@freebsd.org>
# $FreeBSD$
# TODO:
@@ -6,11 +5,11 @@
PORTNAME= openmpi
DISTVERSION= 1.6.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net parallel
MASTER_SITES= http://www.open-mpi.org/software/ompi/v1.6/downloads/
-MAINTAINER= brooks@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= A High Performance Message Passing Library
LIB_DEPENDS= execinfo:${PORTSDIR}/devel/libexecinfo \
@@ -41,34 +40,21 @@ USE_LDCONFIG= ${PREFIX}/${MPIDIR}/lib \
MANPREFIX= ${PREFIX}/${MPIDIR}
.include "${.CURDIR}/Makefile.man"
-OPTIONS_DEFINE= IPV6 SGE TORQUE
+OPTIONS_DEFINE= IPV6 TORQUE
-SGE_DESC= Enable SGE support
TORQUE_DESC= Enable Torque support
OPTIONS_DEFAULT= IPV6
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MSGE}
+.if ${PORT_OPTIONS:MIPV6}
CONFIGURE_ARGS+= --enable-ipv6
.else
CONFIGURE_ARGS+= --disable-ipv6
.endif
-.if ${PORT_OPTIONS:MSGE}
-SGE_BASE?= sge
-SGE_ROOT= ${LOCALBASE}/${SGE_BASE}
-SGE_ARCH= fbsd-${ARCH}
-RUN_DEPENDS+= ${SGE_ROOT}/bin/fbsd-${ARCH}/qrsh:${PORTSDIR}/sysutils/sge62
-CONFIGURE_ARGS+= --with-sge
-CONFIGURE_ENV+= SGE_ROOT=${SGE_ROOT}
-PLIST_FILES+= ${MPIDIR}/lib/openmpi/mca_ras_gridengine.la \
- ${MPIDIR}/lib/openmpi/mca_ras_gridengine.so \
- ${MPIDIR}/share/openmpi/help-ras-gridengine.txt
-.else
CONFIGURE_ARGS+= --without-sge
-.endif
.if ${PORT_OPTIONS:MTORQUE}
LIB_DEPENDS+= torque:${PORTSDIR}/sysutils/torque
diff --git a/net/openmpi/files/patch-ompi_tools_wrappers_Makefile.in b/net/openmpi/files/patch-ompi_tools_wrappers_Makefile.in
new file mode 100644
index 000000000000..5e600987c827
--- /dev/null
+++ b/net/openmpi/files/patch-ompi_tools_wrappers_Makefile.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- ompi/tools/wrappers/Makefile.in.orig
++++ ompi/tools/wrappers/Makefile.in
+@@ -1152,7 +1152,7 @@
+ top_srcdir = @top_srcdir@
+ man_pages = mpicc.1 mpic++.1 mpicxx.1 mpif77.1 mpif90.1
+ @OPAL_WANT_SCRIPT_WRAPPER_COMPILERS_TRUE@bin_SCRIPTS = ompi_wrapper_script
+-@OMPI_INSTALL_BINARIES_TRUE@@OPAL_WANT_SCRIPT_WRAPPER_COMPILERS_FALSE@pkgconfigdir = $(libdir)/pkgconfig
++@OMPI_INSTALL_BINARIES_TRUE@@OPAL_WANT_SCRIPT_WRAPPER_COMPILERS_FALSE@pkgconfigdir = libdata/pkgconfig
+ @OMPI_INSTALL_BINARIES_TRUE@@OPAL_WANT_SCRIPT_WRAPPER_COMPILERS_FALSE@pkgconfig_DATA = ompi.pc ompi-c.pc ompi-cxx.pc ompi-f77.pc ompi-f90.pc
+ @OMPI_INSTALL_BINARIES_TRUE@@OPAL_WANT_SCRIPT_WRAPPER_COMPILERS_FALSE@man_MANS = $(man_pages)
+ @OMPI_INSTALL_BINARIES_TRUE@@OPAL_WANT_SCRIPT_WRAPPER_COMPILERS_FALSE@dist_pkgdata_DATA = \
diff --git a/net/openmpi/files/patch-orte_tools_wrappers_Makefile.in b/net/openmpi/files/patch-orte_tools_wrappers_Makefile.in
new file mode 100644
index 000000000000..2e1ac31ea388
--- /dev/null
+++ b/net/openmpi/files/patch-orte_tools_wrappers_Makefile.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- orte/tools/wrappers/Makefile.in.orig
++++ orte/tools/wrappers/Makefile.in
+@@ -1151,7 +1151,7 @@
+ @ORTE_DISABLE_FULL_SUPPORT_FALSE@ ortecc-wrapper-data.txt \
+ @ORTE_DISABLE_FULL_SUPPORT_FALSE@ ortec++-wrapper-data.txt
+
+-@OMPI_INSTALL_BINARIES_TRUE@@OPAL_WANT_SCRIPT_WRAPPER_COMPILERS_FALSE@@ORTE_DISABLE_FULL_SUPPORT_FALSE@pkgconfigdir = $(libdir)/pkgconfig
++@OMPI_INSTALL_BINARIES_TRUE@@OPAL_WANT_SCRIPT_WRAPPER_COMPILERS_FALSE@@ORTE_DISABLE_FULL_SUPPORT_FALSE@pkgconfigdir = libdata/pkgconfig
+ @OMPI_INSTALL_BINARIES_TRUE@@OPAL_WANT_SCRIPT_WRAPPER_COMPILERS_FALSE@@ORTE_DISABLE_FULL_SUPPORT_FALSE@pkgconfig_DATA = orte.pc
+ all: all-am
+
diff --git a/net/openmpi/pkg-plist b/net/openmpi/pkg-plist
index 38ebf07b5a79..9dc934e98d7d 100644
--- a/net/openmpi/pkg-plist
+++ b/net/openmpi/pkg-plist
@@ -296,12 +296,12 @@
%%MPIDIR%%/lib/openmpi/mca_topo_unity.so
%%MPIDIR%%/lib/openmpi/mca_vprotocol_pessimist.la
%%MPIDIR%%/lib/openmpi/mca_vprotocol_pessimist.so
-%%MPIDIR%%/lib/pkgconfig/ompi-c.pc
-%%MPIDIR%%/lib/pkgconfig/ompi-cxx.pc
-%%MPIDIR%%/lib/pkgconfig/ompi-f77.pc
-%%MPIDIR%%/lib/pkgconfig/ompi-f90.pc
-%%MPIDIR%%/lib/pkgconfig/ompi.pc
-%%MPIDIR%%/lib/pkgconfig/orte.pc
+%%MPIDIR%%/libdata/pkgconfig/ompi-c.pc
+%%MPIDIR%%/libdata/pkgconfig/ompi-cxx.pc
+%%MPIDIR%%/libdata/pkgconfig/ompi-f77.pc
+%%MPIDIR%%/libdata/pkgconfig/ompi-f90.pc
+%%MPIDIR%%/libdata/pkgconfig/ompi.pc
+%%MPIDIR%%/libdata/pkgconfig/orte.pc
%%MPIDIR%%/share/openmpi/amca-param-sets/example.conf
%%MPIDIR%%/share/openmpi/help-coll-sync.txt
%%MPIDIR%%/share/openmpi/help-dash-host.txt
@@ -468,7 +468,6 @@
@dirrm %%MPIDIR%%/man/man3
@dirrm %%MPIDIR%%/man/man1
@dirrm %%MPIDIR%%/man
-@dirrm %%MPIDIR%%/lib/pkgconfig
@dirrm %%MPIDIR%%/lib/openmpi
@dirrm %%MPIDIR%%/lib
@dirrm %%MPIDIR%%/include/vampirtrace