aboutsummaryrefslogtreecommitdiff
path: root/net/openradius
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2006-02-04 00:38:34 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2006-02-04 00:38:34 +0000
commitf875469a41b3b12c9d3a38d27980362af0fd3ecf (patch)
treee49ac5c3283360038d1078d6129bb0c4976c3dfa /net/openradius
parentbad814637033752d85c5d40f93bc48903d601ee7 (diff)
downloadports-f875469a41b3b12c9d3a38d27980362af0fd3ecf.tar.gz
ports-f875469a41b3b12c9d3a38d27980362af0fd3ecf.zip
- Fix hardcoded /etc/rc.subr in rc script [1]
- Update rc script to use USE_RC_SUBR - Bump PORTREVISION - portlint(1) - Drop MAINTAINER [2] PR: 92465 [1] Reported by: Andrew Partan <asp@partan.com> [1] Requested by: Adam <jettea46@yahoo.com> (maintainer via email) [2]
Notes
Notes: svn path=/head/; revision=155170
Diffstat (limited to 'net/openradius')
-rw-r--r--net/openradius/Makefile14
-rw-r--r--net/openradius/files/openradius.in29
-rw-r--r--net/openradius/files/openradiusd.sh25
-rw-r--r--net/openradius/pkg-message3
-rw-r--r--net/openradius/pkg-plist1
5 files changed, 38 insertions, 34 deletions
diff --git a/net/openradius/Makefile b/net/openradius/Makefile
index 60a47897d508..b55828529c73 100644
--- a/net/openradius/Makefile
+++ b/net/openradius/Makefile
@@ -7,12 +7,12 @@
PORTNAME= openradius
PORTVERSION= 0.9.10
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= http://www.xs4all.nl/~evbergen/openradius/download/ \
http://www.mirrors.wiretapped.net/security/authentication/radius/openradius/
-MAINTAINER= jettea46@yahoo.com
+MAINTAINER= ports@FreeBSD.org
COMMENT= A RADIUS server with some actual documentation
LOGFILE?= /var/log/openradius.log
@@ -21,7 +21,10 @@ CONFLICTS= freeradius-0.* gnu-radius-1.* radiusd-cistron-1.*
CC?= gcc
CXX?= g++
+
USE_GMAKE= yes
+USE_RC_SUBR= openradius
+SUB_LIST= LOGFILE="${LOGFILE}"
OPTIONS= LDAP "With LDAP user database" off
@@ -35,10 +38,6 @@ SCRIPTS_ENV+= USE_LDAP=yes
PLIST_SUB+= LDAP="@comment "
.endif
-post-patch:
- @${SED} -e "s|%%PREFIX%%|${PREFIX}|g" -e "s|%%LOGFILE%%|${LOGFILE}|g" \
- < ${FILESDIR}/openradiusd.sh > ${WRKDIR}/openradiusd.sh
-
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
@@ -80,7 +79,8 @@ post-install:
${INSTALL} -m 0600 ${WRKSRC}/etc/legacy/${FILE} \
${PREFIX}/etc/${PORTNAME}/legacy/${FILE}.sample
.endfor
- @${INSTALL_SCRIPT} ${WRKDIR}/openradiusd.sh ${PREFIX}/etc/rc.d
+ @${ECHO_CMD}
@${CAT} ${PKGMESSAGE}
+ @${ECHO_CMD}
.include <bsd.port.post.mk>
diff --git a/net/openradius/files/openradius.in b/net/openradius/files/openradius.in
new file mode 100644
index 000000000000..bd049990a511
--- /dev/null
+++ b/net/openradius/files/openradius.in
@@ -0,0 +1,29 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# PROVIDE: openradius
+# REQUIRE: DAEMON
+# KEYWORD: FreeBSD
+#
+# Add the following line to /etc/rc.conf to enable openradius:
+#
+# openradius_enable (bool): Set to "YES" to enable openradius.
+# Default is "NO".
+# openradius_flags (flags); Set extra flags to openradius.
+# Default is "-o %%LOGFILE%%".
+#
+
+. %%RC_SUBR%%
+
+name="openradius"
+rcvar=`set_rcvar`
+
+load_rc_config ${name}
+
+: ${openradius_enable="NO"}
+: ${openradius_flags="-o %%LOGFILE%%"}
+
+command=%%PREFIX%%/sbin/radiusd
+
+run_rc_command "$1"
diff --git a/net/openradius/files/openradiusd.sh b/net/openradius/files/openradiusd.sh
deleted file mode 100644
index d4879ff992de..000000000000
--- a/net/openradius/files/openradiusd.sh
+++ /dev/null
@@ -1,25 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-#
-# PROVIDE: radiusd
-# REQUIRE: DAEMON
-# KEYWORD: FreeBSD
-#
-# Add the following line to /etc/rc.conf to enable radiusd:
-#
-# radiusd_enable="YES"
-#
-
-radiusd_enable=${radiusd_enable-"NO"}
-radiusd_flags=${radiusd_flags-"-o %%LOGFILE%%"}
-
-. /etc/rc.subr
-
-name=radiusd
-rcvar=`set_rcvar`
-
-command=%%PREFIX%%/sbin/${name}
-
-load_rc_config ${name}
-run_rc_command "$1"
diff --git a/net/openradius/pkg-message b/net/openradius/pkg-message
index 9c082e3a1b3c..f478c4bfda26 100644
--- a/net/openradius/pkg-message
+++ b/net/openradius/pkg-message
@@ -1,4 +1,5 @@
+To enable startup script, please add openradius_enable="YES"
+in your rc.conf.
Configuration sample files were installed, you will need to copy
these over to create real configuration files.
-
diff --git a/net/openradius/pkg-plist b/net/openradius/pkg-plist
index a6b7c45ddb93..4dd84830bd9e 100644
--- a/net/openradius/pkg-plist
+++ b/net/openradius/pkg-plist
@@ -47,7 +47,6 @@ bin/radclient
bin/radtest
sbin/radiusd
-etc/rc.d/openradiusd.sh
%%PORTDOCS%%%%DOCSDIR%%/async-iface-notes
%%PORTDOCS%%%%DOCSDIR%%/language.html