aboutsummaryrefslogtreecommitdiff
path: root/net/opentracker
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2010-11-07 01:58:23 +0000
committerOlli Hauer <ohauer@FreeBSD.org>2010-11-07 01:58:23 +0000
commitcec10ac84f7642830602c05b89dc48b3d5ebe0ce (patch)
treedba66680224b4b08863baac015ee53fe1feb400b /net/opentracker
parent6941b9740b2e3633c068915f7caa46ff7531eda7 (diff)
downloadports-cec10ac84f7642830602c05b89dc48b3d5ebe0ce.tar.gz
ports-cec10ac84f7642830602c05b89dc48b3d5ebe0ce.zip
- fix whitelist bug
Opentracker used to need 40 extra characters at the end of your whitelist/blacklist file otherwise the last info_hash won't be loaded. Thanks to Nerius Landys for the patch! PR: 151974 Submitted by: Chris Rees <utisoft _at_ gmail.com> (maintainer) Approved by: glarkin (mentor, implicit)
Notes
Notes: svn path=/head/; revision=264171
Diffstat (limited to 'net/opentracker')
-rw-r--r--net/opentracker/Makefile14
-rw-r--r--net/opentracker/distinfo1
-rw-r--r--net/opentracker/files/patch-ot_accesslist.c12
3 files changed, 21 insertions, 6 deletions
diff --git a/net/opentracker/Makefile b/net/opentracker/Makefile
index 243e8b981864..36197fe31991 100644
--- a/net/opentracker/Makefile
+++ b/net/opentracker/Makefile
@@ -7,6 +7,7 @@
PORTNAME= opentracker
PORTVERSION= 0.2010.05.30
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://www.bayofrum.net/dist/${PORTNAME}/ \
http://www.glenbarber.us/ports/net/${PORTNAME}/
@@ -16,7 +17,7 @@ COMMENT= A free lightweight bittorrent tracker using libowfat
BUILD_DEPENDS= ${LOCALBASE}/lib/libowfat.a:${PORTSDIR}/devel/libowfat
-USE_BZIP2= yes
+USE_BZIP2= yes
USE_RC_SUBR= ${PORTNAME}
OPTIONS= WANT_ACCESSLIST_BLACK "Enable client blacklisting" Off \
@@ -53,11 +54,14 @@ FEATURES+=-DWANT_RESTRICT_STATS
MAKE_ENV+=FEATURES="${FEATURES}"
+post-patch:
+ @${FIND} ${WRKSRC} -name "*.orig" -a -exec ${RM} -f {} \;
+
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
- ${MKDIR} ${PREFIX}/etc/${PORTNAME}
- ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.conf.sample \
- ${PREFIX}/etc/${PORTNAME}/${PORTNAME}.conf.sample
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${MKDIR} ${PREFIX}/etc/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.conf.sample \
+ ${PREFIX}/etc/${PORTNAME}/${PORTNAME}.conf.sample
post-install:
@if [ ! -f ${PREFIX}/etc/${PORTNAME}/${PORTNAME}.conf ]; then \
diff --git a/net/opentracker/distinfo b/net/opentracker/distinfo
index 85d7828607d0..6e9c95c24516 100644
--- a/net/opentracker/distinfo
+++ b/net/opentracker/distinfo
@@ -1,3 +1,2 @@
-MD5 (opentracker-0.2010.05.30.tar.bz2) = cf0836a3c54254ae98ce1037c55ea9fb
SHA256 (opentracker-0.2010.05.30.tar.bz2) = 53b111cafd101ead61fb2b26760935b66657e5eba9067e28115be325391ec0bc
SIZE (opentracker-0.2010.05.30.tar.bz2) = 48228
diff --git a/net/opentracker/files/patch-ot_accesslist.c b/net/opentracker/files/patch-ot_accesslist.c
new file mode 100644
index 000000000000..246499770a3b
--- /dev/null
+++ b/net/opentracker/files/patch-ot_accesslist.c
@@ -0,0 +1,12 @@
+--- ot_accesslist.c.orig 2010-11-04 17:34:00.000000000 -0700
++++ ot_accesslist.c 2010-11-04 17:51:33.000000000 -0700
+@@ -54,8 +54,7 @@
+ return;
+ }
+
+- /* No use to scan if there's not enough room for another full info_hash */
+- map_end = map + maplen - 40;
++ map_end = map + maplen;
+ read_offs = map;
+
+ /* We do ignore anything that is not of the form "^[:xdigit:]{40}[^:xdigit:].*" */