aboutsummaryrefslogtreecommitdiff
path: root/net/openvswitch
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2012-09-11 17:24:59 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2012-09-11 17:24:59 +0000
commit23b5323f9d02fb3717b20e01718847614b149b5f (patch)
treefe8dd60d5bb06ce0c852e111c3e15dadb7f6e26f /net/openvswitch
parent5d9badc424bf26e118a3b0be772787dde0cf4cb6 (diff)
downloadports-23b5323f9d02fb3717b20e01718847614b149b5f.tar.gz
ports-23b5323f9d02fb3717b20e01718847614b149b5f.zip
- Update to 1.7.1
- Add a regression-test target, but leave it commented out for now as it is failing - Fix build with clang PR: ports/171544 Submitted by: emaste (maintainer)
Notes
Notes: svn path=/head/; revision=304110
Diffstat (limited to 'net/openvswitch')
-rw-r--r--net/openvswitch/Makefile9
-rw-r--r--net/openvswitch/distinfo4
-rw-r--r--net/openvswitch/files/patch-bsd-netdev.diff4
-rw-r--r--net/openvswitch/files/threaded.diff15
4 files changed, 12 insertions, 20 deletions
diff --git a/net/openvswitch/Makefile b/net/openvswitch/Makefile
index 02e38a9a7f49..b371dd7b654b 100644
--- a/net/openvswitch/Makefile
+++ b/net/openvswitch/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= openvswitch
-PORTVERSION= 1.7.0
+PORTVERSION= 1.7.1
CATEGORIES= net
MASTER_SITES= http://openvswitch.org/releases/
@@ -46,8 +46,8 @@ CONFIGURE_ARGS+=--enable-threaded=yes
AUTOTOOLSFILES= aclocal.m4
post-patch:
- @${REINPLACE_CMD} -e 's|1.11.1|%%AUTOMAKE_APIVER%%|g' \
- -e 's|2.65|%%AUTOCONF_VERSION%%|g' \
+ @${REINPLACE_CMD} -e 's|1.11.3|%%AUTOMAKE_APIVER%%|g' \
+ -e 's|2.68|%%AUTOCONF_VERSION%%|g' \
${WRKSRC}/aclocal.m4
.if ${PORT_OPTIONS:MTHREADED}
@# We can't use EXTRA_PATCHES, since we need to apply this one
@@ -58,4 +58,7 @@ post-patch:
post-install:
${INSTALL_DATA} ${WRKSRC}/vswitchd/vswitch.ovsschema ${PREFIX}/share/openvswitch/
+#regression-test: build
+# @cd ${WRKSRC} && ${GMAKE} check
+
.include <bsd.port.post.mk>
diff --git a/net/openvswitch/distinfo b/net/openvswitch/distinfo
index 8c2d6b453f61..d3f678ceea1c 100644
--- a/net/openvswitch/distinfo
+++ b/net/openvswitch/distinfo
@@ -1,2 +1,2 @@
-SHA256 (openvswitch-1.7.0.tar.gz) = 8e3942cbce80048fb2ce8077be5d35bbe50bb12a1feba33d7c1db68ce711eb53
-SIZE (openvswitch-1.7.0.tar.gz) = 2154289
+SHA256 (openvswitch-1.7.1.tar.gz) = a31fdae8400e9a1af89bd9031c83de15d4ba6dc2fb3ff92e5bf772577fa1c882
+SIZE (openvswitch-1.7.1.tar.gz) = 2153423
diff --git a/net/openvswitch/files/patch-bsd-netdev.diff b/net/openvswitch/files/patch-bsd-netdev.diff
index f8ca7428a277..63c518863ddd 100644
--- a/net/openvswitch/files/patch-bsd-netdev.diff
+++ b/net/openvswitch/files/patch-bsd-netdev.diff
@@ -2468,7 +2468,7 @@ new file mode 100644
index 0000000..c145091
--- /dev/null
+++ lib/route-table-bsd.c
-@@ -0,0 +1,129 @@
+@@ -0,0 +1,131 @@
+/*
+ * Copyright (c) 2012 Ed Maste. All rights reserved.
+ *
@@ -2500,6 +2500,8 @@ index 0000000..c145091
+#include <string.h>
+#include <unistd.h>
+
++#include "vlog.h"
++
+VLOG_DEFINE_THIS_MODULE(route_table);
+
+static int pid;
diff --git a/net/openvswitch/files/threaded.diff b/net/openvswitch/files/threaded.diff
index 858f39494157..a3bd811ca151 100644
--- a/net/openvswitch/files/threaded.diff
+++ b/net/openvswitch/files/threaded.diff
@@ -453,7 +453,7 @@ index cade79e..509e2ef 100644
@@ -1003,7 +1209,12 @@ dp_netdev_port_input(struct dp_netdev *dp, struct dp_netdev_port *port,
return;
}
- flow_extract(packet, 0, 0, port->port_no, &key);
+ flow_extract(packet, 0, 0, odp_port_to_ofp_port(port->port_no), &key);
+#ifdef THREADED
+ pthread_mutex_lock(&dp->table_mutex);
+ flow = dp_netdev_lookup_flow_locked(dp, &key);
@@ -1205,19 +1205,6 @@ index 4b86c21..4fad796 100644
int netdev_drain(struct netdev *);
int netdev_send(struct netdev *, const struct ofpbuf *);
-diff --git lib/route-table-bsd.c lib/route-table-bsd.c
-index c145091..1c29071 100644
---- lib/route-table-bsd.c
-+++ lib/route-table-bsd.c
-@@ -29,6 +29,8 @@
- #include <string.h>
- #include <unistd.h>
-
-+#include "vlog.h"
-+
- VLOG_DEFINE_THIS_MODULE(route_table);
-
- static int pid;
diff --git lib/vlog.c lib/vlog.c
index 899072e..b6bd4ef 100644
--- lib/vlog.c