aboutsummaryrefslogtreecommitdiff
path: root/net/osrtspproxy
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2014-01-15 08:30:41 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2014-01-15 08:30:41 +0000
commit924bc73ab41a1b5d6e753c50dc8531a297886633 (patch)
tree98524eb7416c882ae2585f6b550fbf18f38f6b2e /net/osrtspproxy
parent1720395be1d9dcce5c50a07faf0f9c11b7c7d77b (diff)
downloadports-924bc73ab41a1b5d6e753c50dc8531a297886633.tar.gz
ports-924bc73ab41a1b5d6e753c50dc8531a297886633.zip
Notes
Diffstat (limited to 'net/osrtspproxy')
-rw-r--r--net/osrtspproxy/Makefile19
-rw-r--r--net/osrtspproxy/pkg-plist2
2 files changed, 15 insertions, 6 deletions
diff --git a/net/osrtspproxy/Makefile b/net/osrtspproxy/Makefile
index cf48a4c9528d..c3759b0362aa 100644
--- a/net/osrtspproxy/Makefile
+++ b/net/osrtspproxy/Makefile
@@ -11,11 +11,22 @@ DISTNAME= ${PORTNAME}_2_0
MAINTAINER= ports@FreeBSD.org
COMMENT= The RTSP Proxy Kit - A reference implementation of an RTSP proxy
-HAS_CONFIGURE= YES
+HAS_CONFIGURE= yes
+
+PLIST_FILES= sbin/rtspproxy etc/rc.d/rtspproxy.sh.sample
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ '/CC=/s|^|#| ; \
+ /CXX=/s|^|#| ; \
+ /LD=/s|^|#| ; \
+ s|-I/usr/local/include|| ; \
+ s|-L/usr/local/lib||' ${WRKSRC}/configure
-NO_STAGE= yes
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/rtspproxy/rtspproxy ${PREFIX}/sbin
- ${INSTALL_SCRIPT} ${FILESDIR}/rtspproxy.sh ${PREFIX}/etc/rc.d/rtspproxy.sh.sample
+ (cd ${WRKSRC}/rtspproxy && ${INSTALL_PROGRAM} rtspproxy \
+ ${STAGEDIR}${PREFIX}/sbin)
+ (cd ${FILESDIR} && ${INSTALL_SCRIPT} rtspproxy.sh \
+ ${STAGEDIR}${PREFIX}/etc/rc.d/rtspproxy.sh.sample)
.include <bsd.port.mk>
diff --git a/net/osrtspproxy/pkg-plist b/net/osrtspproxy/pkg-plist
deleted file mode 100644
index f12abdb7d56a..000000000000
--- a/net/osrtspproxy/pkg-plist
+++ /dev/null
@@ -1,2 +0,0 @@
-sbin/rtspproxy
-etc/rc.d/rtspproxy.sh.sample