aboutsummaryrefslogtreecommitdiff
path: root/net/owncloud-csync/Makefile
diff options
context:
space:
mode:
authorFelippe de Meirelles Motta <lippe@FreeBSD.org>2013-07-08 21:31:53 +0000
committerFelippe de Meirelles Motta <lippe@FreeBSD.org>2013-07-08 21:31:53 +0000
commitb0f033659ea81b502b3f1a62278ead49459667d7 (patch)
tree2aa530c58adf54b91bd2b276c1a2de7722f15ae3 /net/owncloud-csync/Makefile
parentda1e8cf6ab2ddd5f75c1957f4b015ac352f88029 (diff)
downloadports-b0f033659ea81b502b3f1a62278ead49459667d7.tar.gz
ports-b0f033659ea81b502b3f1a62278ead49459667d7.zip
Notes
Diffstat (limited to 'net/owncloud-csync/Makefile')
-rw-r--r--net/owncloud-csync/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/net/owncloud-csync/Makefile b/net/owncloud-csync/Makefile
new file mode 100644
index 000000000000..b5053bb60baa
--- /dev/null
+++ b/net/owncloud-csync/Makefile
@@ -0,0 +1,36 @@
+# Created by: arrowdodger <6yearold@gmail.com>
+# $FreeBSD$
+
+PORTNAME= owncloud-csync
+PORTVERSION= 0.70.7
+CATEGORIES= net kde
+MASTER_SITES= http://download.owncloud.com/download/
+DISTNAME= ocsync-${PORTVERSION}
+
+MAINTAINER= 6yearold@gmail.com
+COMMENT= A csync fork for Owncloud
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= iconv:${PORTSDIR}/converters/libiconv \
+ iniparser:${PORTSDIR}/devel/iniparser \
+ smbclient:${PORTSDIR}/net/samba-libsmbclient \
+ ssh:${PORTSDIR}/security/libssh \
+ neon:${PORTSDIR}/www/neon29
+
+USES= cmake:outsource
+USE_BZIP2= yes
+USE_PKGCONFIG= build
+USE_SQLITE= yes
+CMAKE_ARGS+= -DWITH_LOG4C=NO \
+ -DMAN_INSTALL_DIR=${MANPREFIX}/man
+
+MAN1= ocsync.1
+
+USE_LDCONFIG= yes
+MAKE_JOBS_SAFE= yes
+
+DOCSDIR= /usr/local/share/doc/ocsync
+ETCDIR= /usr/local/etc/ocsync
+
+.include <bsd.port.mk>