aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Amazon-SQS-Simple
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-12-12 13:33:32 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-12-12 13:33:32 +0000
commit62c9c4f90fa4f5ab4fb4bcb7922b3ede4a355d1e (patch)
tree1e8b547efd91180e51cdabc59abee973e0ac5dfc /net/p5-Amazon-SQS-Simple
parente2a0f5b5513c077db66a6b821e40fa894150a59e (diff)
downloadports-62c9c4f90fa4f5ab4fb4bcb7922b3ede4a355d1e.tar.gz
ports-62c9c4f90fa4f5ab4fb4bcb7922b3ede4a355d1e.zip
This module provides a Perlish interface to Amazon SQS.
WWW: http://search.cpan.org/~swhitaker/Amazon-SQS-Simple-0.5/ PR: ports/117720 Submitted by: Greg Larkin <glarkin at sourcehosting.net>
Notes
Notes: svn path=/head/; revision=203294
Diffstat (limited to 'net/p5-Amazon-SQS-Simple')
-rw-r--r--net/p5-Amazon-SQS-Simple/Makefile45
-rw-r--r--net/p5-Amazon-SQS-Simple/distinfo3
-rw-r--r--net/p5-Amazon-SQS-Simple/files/pkg-message.in20
-rw-r--r--net/p5-Amazon-SQS-Simple/pkg-descr3
-rw-r--r--net/p5-Amazon-SQS-Simple/pkg-plist11
5 files changed, 82 insertions, 0 deletions
diff --git a/net/p5-Amazon-SQS-Simple/Makefile b/net/p5-Amazon-SQS-Simple/Makefile
new file mode 100644
index 000000000000..af460572dceb
--- /dev/null
+++ b/net/p5-Amazon-SQS-Simple/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: p5-Amazon-SQS-Simple
+# Date created: 2007-10-31
+# Whom: Greg Larkin <glarkin@sourcehosting.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Amazon-SQS-Simple
+PORTVERSION= 0.5
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/S/SW/SWHITAKER
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= glarkin@sourcehosting.net
+COMMENT= OO API for accessing the Amazon Simple Queue Service
+
+RUN_DEPENDS= ${SITE_PERL}/XML/Simple.pm:${PORTSDIR}/textproc/p5-XML-Simple \
+ ${SITE_PERL}/Digest/HMAC_SHA1.pm:${PORTSDIR}/security/p5-Digest-HMAC \
+ ${SITE_PERL}/URI/Escape.pm:${PORTSDIR}/net/p5-URI \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
+BUILD_DEPENDS= ${SITE_PERL}/XML/Simple.pm:${PORTSDIR}/textproc/p5-XML-Simple \
+ ${SITE_PERL}/Digest/HMAC_SHA1.pm:${PORTSDIR}/security/p5-Digest-HMAC \
+ ${SITE_PERL}/URI/Escape.pm:${PORTSDIR}/net/p5-URI \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
+
+PERL_CONFIGURE= yes
+
+MAN3= Amazon::SQS::Simple::Message.3 \
+ Amazon::SQS::Simple::Queue.3 \
+ Amazon::SQS::Simple::Base.3 \
+ Amazon::SQS::Simple.3
+
+SUB_FILES= pkg-message
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500703
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/net/p5-Amazon-SQS-Simple/distinfo b/net/p5-Amazon-SQS-Simple/distinfo
new file mode 100644
index 000000000000..822b4879a024
--- /dev/null
+++ b/net/p5-Amazon-SQS-Simple/distinfo
@@ -0,0 +1,3 @@
+MD5 (Amazon-SQS-Simple-0.5.tar.gz) = 213d80ce0fda88f24f7e293076b5a44b
+SHA256 (Amazon-SQS-Simple-0.5.tar.gz) = c7ff78ae5f249e1f867a8780e9c7d5270277a0306f13a3c956872bbd1aef7626
+SIZE (Amazon-SQS-Simple-0.5.tar.gz) = 7589
diff --git a/net/p5-Amazon-SQS-Simple/files/pkg-message.in b/net/p5-Amazon-SQS-Simple/files/pkg-message.in
new file mode 100644
index 000000000000..8a2e68091a40
--- /dev/null
+++ b/net/p5-Amazon-SQS-Simple/files/pkg-message.in
@@ -0,0 +1,20 @@
+
+You need to do some things before you can use the Amazon Simple
+Queue Service:
+
+1) Visit http://aws.amazon.com/ to create an Amazon AWS account.
+
+2) Obtain your AWS public key and secret key to use with the SQS service.
+
+3) Use the Amazon AWS calculator to estimate your monthly cost:
+ http://calculator.s3.amazonaws.com/calc5.html?
+
+4) Visit the Amazon SQS Resource Center for information, tutorials and
+ sample code:
+ http://developer.amazonwebservices.com/connect/kbcategory.jspa?categoryID=8
+
+ DISCLAIMER: No one but you is responsible for paying Amazon to use
+ the SQS service. SQS does not have a free sandbox area,
+ so be aware how much money you are spending to use the
+ service.
+
diff --git a/net/p5-Amazon-SQS-Simple/pkg-descr b/net/p5-Amazon-SQS-Simple/pkg-descr
new file mode 100644
index 000000000000..e087b1559c2e
--- /dev/null
+++ b/net/p5-Amazon-SQS-Simple/pkg-descr
@@ -0,0 +1,3 @@
+This module provides a Perlish interface to Amazon SQS.
+
+WWW: http://search.cpan.org/~swhitaker/Amazon-SQS-Simple-0.5/
diff --git a/net/p5-Amazon-SQS-Simple/pkg-plist b/net/p5-Amazon-SQS-Simple/pkg-plist
new file mode 100644
index 000000000000..6a97b56c8cf4
--- /dev/null
+++ b/net/p5-Amazon-SQS-Simple/pkg-plist
@@ -0,0 +1,11 @@
+%%SITE_PERL%%/Amazon/SQS/Simple.pm
+%%SITE_PERL%%/Amazon/SQS/Simple/Base.pm
+%%SITE_PERL%%/Amazon/SQS/Simple/Message.pm
+%%SITE_PERL%%/Amazon/SQS/Simple/Queue.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Amazon/SQS/Simple/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Amazon/SQS/Simple
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Amazon/SQS
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Amazon
+@dirrm %%SITE_PERL%%/Amazon/SQS/Simple
+@dirrm %%SITE_PERL%%/Amazon/SQS
+@dirrm %%SITE_PERL%%/Amazon