aboutsummaryrefslogtreecommitdiff
path: root/net/p5-AnyEvent-Twitter-Stream/Makefile
diff options
context:
space:
mode:
authorSahil Tandon <sahil@FreeBSD.org>2010-04-20 22:11:37 +0000
committerSahil Tandon <sahil@FreeBSD.org>2010-04-20 22:11:37 +0000
commite9e62f19d7819f2ca73b867412868e37fc9cd1e2 (patch)
tree0dc43b74798e10d2d40c0cf52a299a51d1aa0e9d /net/p5-AnyEvent-Twitter-Stream/Makefile
parent996908f59c0a45bf81f0ea3f51a1ed60aca80fdf (diff)
downloadports-e9e62f19d7819f2ca73b867412868e37fc9cd1e2.tar.gz
ports-e9e62f19d7819f2ca73b867412868e37fc9cd1e2.zip
Notes
Diffstat (limited to 'net/p5-AnyEvent-Twitter-Stream/Makefile')
-rw-r--r--net/p5-AnyEvent-Twitter-Stream/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/net/p5-AnyEvent-Twitter-Stream/Makefile b/net/p5-AnyEvent-Twitter-Stream/Makefile
new file mode 100644
index 000000000000..7ad97e8f2d03
--- /dev/null
+++ b/net/p5-AnyEvent-Twitter-Stream/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: AnyEvent::Twitter::Stream
+# Date created: 2010-04-18
+# Whom: Sahil Tandon <sahil@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= AnyEvent-Twitter-Stream
+PORTVERSION= 0.13
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sahil@FreeBSD.org
+COMMENT= A perl module to receive Twitter streaming API in an event loop
+
+RUN_DEPENDS= p5-AnyEvent>=0:${PORTSDIR}/devel/p5-AnyEvent \
+ p5-AnyEvent-HTTP>=0:${PORTSDIR}/www/p5-AnyEvent-HTTP \
+ p5-JSON>=2.0:${PORTSDIR}/converters/p5-JSON \
+ p5-URI>=0:${PORTSDIR}/net/p5-URI
+
+PERL_CONFIGURE= 5.8.1+
+
+MAN3= AnyEvent::Twitter::Stream.3
+
+.include <bsd.port.mk>