aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Crypt-DH-GMP
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2010-02-28 03:25:51 +0000
committerWen Heping <wen@FreeBSD.org>2010-02-28 03:25:51 +0000
commitfc4f8bbf3bf4f4f3167e60f284902f969721e7c4 (patch)
tree61cf098bfbdabdfbfb11c5226d0f9729f1518d98 /net/p5-Crypt-DH-GMP
parenta71de603b3c0826ef9a73bcf2c5d309a332e98bc (diff)
downloadports-fc4f8bbf3bf4f4f3167e60f284902f969721e7c4.tar.gz
ports-fc4f8bbf3bf4f4f3167e60f284902f969721e7c4.zip
Crypt::DH::GMP is a (somewhat) portable replacement to Crypt::DH,
implemented mostly in C. Crypt::DH uses Math::BigInt, which is a very feature-full and fast interface to perform high-precision math. WWW: http://search.cpan.org/dist/Crypt-DH-GMP PR: ports/144344 Submitted by: Andrey Kostenko <andrey@kostenko.name> Feature safe: yes
Notes
Notes: svn path=/head/; revision=250413
Diffstat (limited to 'net/p5-Crypt-DH-GMP')
-rw-r--r--net/p5-Crypt-DH-GMP/Makefile23
-rw-r--r--net/p5-Crypt-DH-GMP/distinfo3
-rw-r--r--net/p5-Crypt-DH-GMP/pkg-descr7
-rw-r--r--net/p5-Crypt-DH-GMP/pkg-plist11
4 files changed, 44 insertions, 0 deletions
diff --git a/net/p5-Crypt-DH-GMP/Makefile b/net/p5-Crypt-DH-GMP/Makefile
new file mode 100644
index 000000000000..a1d83f0fcef8
--- /dev/null
+++ b/net/p5-Crypt-DH-GMP/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: Crypt-DH-GMP
+# Date created: 04 February 2010
+# Whom: andrey@kostenko.name
+#
+# $FreeBSD$
+
+PORTNAME= Crypt-DH-GMP
+PORTVERSION= 0.00006
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= andrey@kostenko.name
+COMMENT= Crypt::DH Using GMP Directly
+
+RUN_DEPENDS= libgmp>=0:${PORTSDIR}/math/libgmp4
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= YES
+MAN3= Crypt::DH::GMP.3 \
+ Crypt::DH::GMP::Compat.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Crypt-DH-GMP/distinfo b/net/p5-Crypt-DH-GMP/distinfo
new file mode 100644
index 000000000000..59424fac928e
--- /dev/null
+++ b/net/p5-Crypt-DH-GMP/distinfo
@@ -0,0 +1,3 @@
+MD5 (Crypt-DH-GMP-0.00006.tar.gz) = 515d10da337a72f3fb27a800f035986c
+SHA256 (Crypt-DH-GMP-0.00006.tar.gz) = bd7c6ed1d1d76e058650b1eb134007ed4df26a173b7a40502eb047bcc03a6583
+SIZE (Crypt-DH-GMP-0.00006.tar.gz) = 14987
diff --git a/net/p5-Crypt-DH-GMP/pkg-descr b/net/p5-Crypt-DH-GMP/pkg-descr
new file mode 100644
index 000000000000..91a90119849e
--- /dev/null
+++ b/net/p5-Crypt-DH-GMP/pkg-descr
@@ -0,0 +1,7 @@
+Crypt::DH::GMP is a (somewhat) portable replacement to Crypt::DH,
+implemented mostly in C.
+
+Crypt::DH uses Math::BigInt, which is a very feature-full and fast
+interface to perform high-precision math.
+
+WWW: http://search.cpan.org/dist/Crypt-DH-GMP
diff --git a/net/p5-Crypt-DH-GMP/pkg-plist b/net/p5-Crypt-DH-GMP/pkg-plist
new file mode 100644
index 000000000000..8649ff6d7b29
--- /dev/null
+++ b/net/p5-Crypt-DH-GMP/pkg-plist
@@ -0,0 +1,11 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/Crypt/DH/GMP.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Crypt/DH/GMP/Compat.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/DH/GMP/GMP.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/DH/GMP/GMP.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/DH/GMP/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/DH/GMP
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/DH
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Crypt/DH/GMP
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Crypt/DH
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Crypt