aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Google-SAML-Request
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-08-05 12:25:02 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-08-05 12:25:02 +0000
commit4eede91cb420df4535f1fc3c2a827696988cb8f7 (patch)
treebd2eb274645e8bf8d0f8c1ff2e0ff1e7fa7d3a9d /net/p5-Google-SAML-Request
parent46dc595cbb50693d9fc2e2a17fe594e5c4f762f4 (diff)
downloadports-4eede91cb420df4535f1fc3c2a827696988cb8f7.tar.gz
ports-4eede91cb420df4535f1fc3c2a827696988cb8f7.zip
Google::SAML::Request will parse (and, for the sake of completeness,
create) SAML requests as used by Google. Please note that Google::SAML::Request is by no means a full implementation of the SAML 2.0 standard. But if you want to talk to Google to authenticate users, you should be fine. WWW: http://search.cpan.org/dist/Google-SAML-Request/ PR: ports/137444 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Notes
Notes: svn path=/head/; revision=238987
Diffstat (limited to 'net/p5-Google-SAML-Request')
-rw-r--r--net/p5-Google-SAML-Request/Makefile27
-rw-r--r--net/p5-Google-SAML-Request/distinfo3
-rw-r--r--net/p5-Google-SAML-Request/pkg-descr7
-rw-r--r--net/p5-Google-SAML-Request/pkg-plist8
4 files changed, 45 insertions, 0 deletions
diff --git a/net/p5-Google-SAML-Request/Makefile b/net/p5-Google-SAML-Request/Makefile
new file mode 100644
index 000000000000..aad44114b34d
--- /dev/null
+++ b/net/p5-Google-SAML-Request/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-Google-SAML-Request
+# Date created: 2009-08-05
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Google-SAML-Request
+PORTVERSION= 0.02
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Create or parse Google\'s SAML requests
+
+RUN_DEPENDS= p5-Compress-Zlib>0:${PORTSDIR}/archivers/p5-Compress-Zlib \
+ p5-MIME-Base64>0:${PORTSDIR}/converters/p5-MIME-Base64 \
+ p5-TimeDate>0:${PORTSDIR}/devel/p5-TimeDate \
+ p5-URI>0:${PORTSDIR}/net/p5-URI \
+ p5-XML-Simple>0:${PORTSDIR}/textproc/p5-XML-Simple
+
+PERL_CONFIGURE= yes
+
+MAN3= Google::SAML::Request.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Google-SAML-Request/distinfo b/net/p5-Google-SAML-Request/distinfo
new file mode 100644
index 000000000000..26b59591d335
--- /dev/null
+++ b/net/p5-Google-SAML-Request/distinfo
@@ -0,0 +1,3 @@
+MD5 (Google-SAML-Request-0.02.tar.gz) = f99102e3ee749f5644ef09372674eb4c
+SHA256 (Google-SAML-Request-0.02.tar.gz) = d790024eef3d93f5c9d6a699464005785a675929168a8ce54a51ffd15ac494f1
+SIZE (Google-SAML-Request-0.02.tar.gz) = 12986
diff --git a/net/p5-Google-SAML-Request/pkg-descr b/net/p5-Google-SAML-Request/pkg-descr
new file mode 100644
index 000000000000..f1843d460899
--- /dev/null
+++ b/net/p5-Google-SAML-Request/pkg-descr
@@ -0,0 +1,7 @@
+Google::SAML::Request will parse (and, for the sake of completeness,
+create) SAML requests as used by Google. Please note that
+Google::SAML::Request is by no means a full implementation of the SAML
+2.0 standard. But if you want to talk to Google to authenticate users,
+you should be fine.
+
+WWW: http://search.cpan.org/dist/Google-SAML-Request/
diff --git a/net/p5-Google-SAML-Request/pkg-plist b/net/p5-Google-SAML-Request/pkg-plist
new file mode 100644
index 000000000000..77181ef032cf
--- /dev/null
+++ b/net/p5-Google-SAML-Request/pkg-plist
@@ -0,0 +1,8 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Google/SAML/Request/.packlist
+%%SITE_PERL%%/Google/SAML/Request.pm
+@dirrmtry %%SITE_PERL%%/Google/SAML
+@dirrmtry %%SITE_PERL%%/Google
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Google/SAML/Request
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Google/SAML
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Google