aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Growl-GNTP
diff options
context:
space:
mode:
authorHenrik Brix Andersen <brix@FreeBSD.org>2011-10-09 19:12:54 +0000
committerHenrik Brix Andersen <brix@FreeBSD.org>2011-10-09 19:12:54 +0000
commitb0e519d84ad45353daa869ec3f920951d448b510 (patch)
tree5f06a09de647b4b5624bc566d656357f382cc72b /net/p5-Growl-GNTP
parentf54bf967a3717f37720e216a1bbfbd5c27417bcb (diff)
downloadports-b0e519d84ad45353daa869ec3f920951d448b510.tar.gz
ports-b0e519d84ad45353daa869ec3f920951d448b510.zip
Perl implementation of the Growl GNTP Protocol (Client Part).
Notes
Notes: svn path=/head/; revision=283260
Diffstat (limited to 'net/p5-Growl-GNTP')
-rw-r--r--net/p5-Growl-GNTP/Makefile28
-rw-r--r--net/p5-Growl-GNTP/distinfo2
-rw-r--r--net/p5-Growl-GNTP/pkg-descr3
-rw-r--r--net/p5-Growl-GNTP/pkg-plist5
4 files changed, 38 insertions, 0 deletions
diff --git a/net/p5-Growl-GNTP/Makefile b/net/p5-Growl-GNTP/Makefile
new file mode 100644
index 000000000000..494211d7af2e
--- /dev/null
+++ b/net/p5-Growl-GNTP/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: Growl-GNTP
+# Date created: 09 Oct 2011
+# Whom: brix@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= Growl-GNTP
+PORTVERSION= 0.10
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= brix@FreeBSD.org
+COMMENT= Perl implementation of the Growl GNTP Protocol (Client Part)
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Data/UUID.pm:${PORTSDIR}/devel/p5-Data-UUID \
+ ${SITE_PERL}/Crypt/CBC.pm:${PORTSDIR}/security/p5-Crypt-CBC
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Growl::GNTP.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Growl-GNTP/distinfo b/net/p5-Growl-GNTP/distinfo
new file mode 100644
index 000000000000..c9f2837acaa4
--- /dev/null
+++ b/net/p5-Growl-GNTP/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Growl-GNTP-0.10.tar.gz) = 6bc73dbc4a70d7089daa807f4261b86373fe8ef0166977681a17c71522296505
+SIZE (Growl-GNTP-0.10.tar.gz) = 48718
diff --git a/net/p5-Growl-GNTP/pkg-descr b/net/p5-Growl-GNTP/pkg-descr
new file mode 100644
index 000000000000..ca39e2dae285
--- /dev/null
+++ b/net/p5-Growl-GNTP/pkg-descr
@@ -0,0 +1,3 @@
+Perl implementation of the Growl GNTP Protocol (Client Part).
+
+WWW: http://search.cpan.org/dist/Growl-GNTP
diff --git a/net/p5-Growl-GNTP/pkg-plist b/net/p5-Growl-GNTP/pkg-plist
new file mode 100644
index 000000000000..8744f3cbb96d
--- /dev/null
+++ b/net/p5-Growl-GNTP/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Growl/GNTP/.packlist
+%%SITE_PERL%%/Growl/GNTP.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Growl/GNTP
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Growl
+@dirrmtry %%SITE_PERL%%/Growl