aboutsummaryrefslogtreecommitdiff
path: root/net/p5-IO-Interface
diff options
context:
space:
mode:
authorJosef Karthauser <joe@FreeBSD.org>2001-04-28 15:16:33 +0000
committerJosef Karthauser <joe@FreeBSD.org>2001-04-28 15:16:33 +0000
commitcc63125ef5a5fc12e5dc68b10a6ab46f5707b6e9 (patch)
treefbe92ec6cbce1576fd6ccf02c773f2c2b2f908fa /net/p5-IO-Interface
parentc4e3d79cbccd46b52aff7abfa04afeca9094835f (diff)
downloadports-cc63125ef5a5fc12e5dc68b10a6ab46f5707b6e9.tar.gz
ports-cc63125ef5a5fc12e5dc68b10a6ab46f5707b6e9.zip
Notes
Diffstat (limited to 'net/p5-IO-Interface')
-rw-r--r--net/p5-IO-Interface/Makefile22
-rw-r--r--net/p5-IO-Interface/distinfo1
-rw-r--r--net/p5-IO-Interface/files/patch-OSIOCGIFCONF24
-rw-r--r--net/p5-IO-Interface/pkg-comment1
-rw-r--r--net/p5-IO-Interface/pkg-descr9
-rw-r--r--net/p5-IO-Interface/pkg-plist8
6 files changed, 65 insertions, 0 deletions
diff --git a/net/p5-IO-Interface/Makefile b/net/p5-IO-Interface/Makefile
new file mode 100644
index 000000000000..3c11093de961
--- /dev/null
+++ b/net/p5-IO-Interface/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: net/p5-IO-Interface
+# Date created: 26 April 2001
+# Whom: Anton Berezin <tobez@tobez.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= IO-Interface
+PORTVERSION= 0.94
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= IO
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@tobez.org
+
+PERL_CONFIGURE= yes
+
+MAN3= IO::Interface.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/net/p5-IO-Interface/distinfo b/net/p5-IO-Interface/distinfo
new file mode 100644
index 000000000000..36001a4dc38e
--- /dev/null
+++ b/net/p5-IO-Interface/distinfo
@@ -0,0 +1 @@
+MD5 (IO-Interface-0.94.tar.gz) = 3488c7120239b1f257728793f092d903
diff --git a/net/p5-IO-Interface/files/patch-OSIOCGIFCONF b/net/p5-IO-Interface/files/patch-OSIOCGIFCONF
new file mode 100644
index 000000000000..9c168ee1d8e7
--- /dev/null
+++ b/net/p5-IO-Interface/files/patch-OSIOCGIFCONF
@@ -0,0 +1,24 @@
+--- Interface.xs.orig Wed Apr 25 15:45:43 2001
++++ Interface.xs Wed Apr 25 15:47:13 2001
+@@ -13,6 +13,12 @@
+ #include <sys/sockio.h>
+ #endif
+
++#ifdef OSIOCGIFCONF
++#define MY_SIOCGIFCONF OSIOCGIFCONF
++#else
++#define MY_SIOCGIFCONF SIOCGIFCONF
++#endif
++
+ #ifdef PerlIO
+ typedef PerlIO * InputStream;
+ #else
+@@ -581,7 +587,7 @@
+ croak("Couldn't malloc buffer for ioctl: %s",strerror(errno));
+ ifc.ifc_len = len;
+ ifc.ifc_buf = buf;
+- if (ioctl(PerlIO_fileno(sock),SIOCGIFCONF,&ifc) < 0) {
++ if (ioctl(PerlIO_fileno(sock),MY_SIOCGIFCONF,&ifc) < 0) {
+ if (errno != EINVAL || lastlen != 0)
+ XSRETURN_EMPTY;
+ } else {
diff --git a/net/p5-IO-Interface/pkg-comment b/net/p5-IO-Interface/pkg-comment
new file mode 100644
index 000000000000..f66ee23f69b2
--- /dev/null
+++ b/net/p5-IO-Interface/pkg-comment
@@ -0,0 +1 @@
+Perl extension for access to network card configuration information
diff --git a/net/p5-IO-Interface/pkg-descr b/net/p5-IO-Interface/pkg-descr
new file mode 100644
index 000000000000..708b25eb9615
--- /dev/null
+++ b/net/p5-IO-Interface/pkg-descr
@@ -0,0 +1,9 @@
+IO::Interface adds object-methods to IO::Socket objects to allow
+them to get and set operational characteristics of network interface
+cards, such as IP addresses, net masks, and so forth. It is useful
+for identifying runtime characteristics of cards, such as broadcast
+addresses, and finding interfaces that satisfy certain criteria,
+such as the ability to multicast.
+
+-Anton
+<tobez@tobez.org>
diff --git a/net/p5-IO-Interface/pkg-plist b/net/p5-IO-Interface/pkg-plist
new file mode 100644
index 000000000000..57a092cf7714
--- /dev/null
+++ b/net/p5-IO-Interface/pkg-plist
@@ -0,0 +1,8 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/IO/Interface.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/IO/Interface/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/IO/Interface/Interface.bs
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/IO/Interface/Interface.so
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/IO/Interface/autosplit.ix
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/IO/Interface
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/IO 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/IO 2>/dev/null || true