aboutsummaryrefslogtreecommitdiff
path: root/net/p5-MaxMind-DB-Common
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-02-16 10:43:06 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-02-16 10:43:06 +0000
commit794559e08b9aa228f04717019aea6898861fab15 (patch)
tree4194b40c336c597e5658d45e591bf37110212b6e /net/p5-MaxMind-DB-Common
parent11eba141bbe175b37b92929a238836b63515c4ab (diff)
downloadports-794559e08b9aa228f04717019aea6898861fab15.tar.gz
ports-794559e08b9aa228f04717019aea6898861fab15.zip
- Add p5-MaxMind-DB-Common 0.031002
MaxMind::DB::Common provides code shared by the DB reader and writer modules. WWW: http://search.cpan.org/dist/MaxMind-DB-Common/
Notes
Notes: svn path=/head/; revision=344526
Diffstat (limited to 'net/p5-MaxMind-DB-Common')
-rw-r--r--net/p5-MaxMind-DB-Common/Makefile30
-rw-r--r--net/p5-MaxMind-DB-Common/distinfo2
-rw-r--r--net/p5-MaxMind-DB-Common/pkg-descr3
-rw-r--r--net/p5-MaxMind-DB-Common/pkg-plist18
4 files changed, 53 insertions, 0 deletions
diff --git a/net/p5-MaxMind-DB-Common/Makefile b/net/p5-MaxMind-DB-Common/Makefile
new file mode 100644
index 000000000000..824faf8124d5
--- /dev/null
+++ b/net/p5-MaxMind-DB-Common/Makefile
@@ -0,0 +1,30 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= MaxMind-DB-Common
+PORTVERSION= 0.031.002
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:DROLSKY
+PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-${PORTVERSION:R}${PORTVERSION:E}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Code shared by the DB reader and writer modules
+
+LICENSE= ART20
+
+BUILD_DEPENDS= p5-Data-Dumper-Concise>=0:${PORTSDIR}/devel/p5-Data-Dumper-Concise \
+ p5-DateTime>=0:${PORTSDIR}/devel/p5-DateTime \
+ p5-List-AllUtils>=0:${PORTSDIR}/devel/p5-List-AllUtils \
+ p5-Math-Int128>=0:${PORTSDIR}/math/p5-Math-Int128 \
+ p5-Moo>=0:${PORTSDIR}/devel/p5-Moo \
+ p5-MooX-StrictConstructor>=0:${PORTSDIR}/devel/p5-MooX-StrictConstructor \
+ p5-autodie>=0:${PORTSDIR}/devel/p5-autodie \
+ p5-namespace-autoclean>=0:${PORTSDIR}/devel/p5-namespace-autoclean
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+USE_PERL5= configure
+USES= perl5
+
+.include <bsd.port.mk>
diff --git a/net/p5-MaxMind-DB-Common/distinfo b/net/p5-MaxMind-DB-Common/distinfo
new file mode 100644
index 000000000000..5a94b750199f
--- /dev/null
+++ b/net/p5-MaxMind-DB-Common/distinfo
@@ -0,0 +1,2 @@
+SHA256 (MaxMind-DB-Common-0.031002.tar.gz) = d9b8543be78d792b8ba71e3057d805f5f0d2e3b8abcac090f060597ed37d32d2
+SIZE (MaxMind-DB-Common-0.031002.tar.gz) = 15140
diff --git a/net/p5-MaxMind-DB-Common/pkg-descr b/net/p5-MaxMind-DB-Common/pkg-descr
new file mode 100644
index 000000000000..3bc73e3c30f5
--- /dev/null
+++ b/net/p5-MaxMind-DB-Common/pkg-descr
@@ -0,0 +1,3 @@
+MaxMind::DB::Common provides code shared by the DB reader and writer modules.
+
+WWW: http://search.cpan.org/dist/MaxMind-DB-Common/
diff --git a/net/p5-MaxMind-DB-Common/pkg-plist b/net/p5-MaxMind-DB-Common/pkg-plist
new file mode 100644
index 000000000000..a20353ead1d6
--- /dev/null
+++ b/net/p5-MaxMind-DB-Common/pkg-plist
@@ -0,0 +1,18 @@
+%%SITE_PERL%%/MaxMind/DB/Common.pm
+%%SITE_PERL%%/MaxMind/DB/Metadata.pm
+%%SITE_PERL%%/MaxMind/DB/Role/Debugs.pm
+%%SITE_PERL%%/MaxMind/DB/Types.pm
+%%SITE_PERL%%/Test/MaxMind/DB/Common/Data.pm
+%%SITE_PERL%%/Test/MaxMind/DB/Common/Util.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/MaxMind/DB/Common/.packlist
+%%PERL5_MAN3%%/MaxMind::DB::Common.3.gz
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/MaxMind/DB/Common
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/MaxMind/DB
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/MaxMind
+@dirrm %%SITE_PERL%%/Test/MaxMind/DB/Common
+@dirrmtry %%SITE_PERL%%/Test/MaxMind/DB
+@dirrmtry %%SITE_PERL%%/Test/MaxMind
+@dirrmtry %%SITE_PERL%%/Test
+@dirrmtry %%SITE_PERL%%/MaxMind/DB/Role
+@dirrmtry %%SITE_PERL%%/MaxMind/DB
+@dirrmtry %%SITE_PERL%%/MaxMind