aboutsummaryrefslogtreecommitdiff
path: root/net/p5-MaxMind-DB-Reader-XS/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-10-16 20:03:29 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-10-16 20:03:29 +0000
commit05c9137e20020b2a0acddad0f8619ea0f263d318 (patch)
tree4d27e0a98738d92dea80321e61a2cc16daec28e8 /net/p5-MaxMind-DB-Reader-XS/Makefile
parent7229a2b3352413c5a10245bfdefef87083f53f5c (diff)
Notes
Diffstat (limited to 'net/p5-MaxMind-DB-Reader-XS/Makefile')
-rw-r--r--net/p5-MaxMind-DB-Reader-XS/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/net/p5-MaxMind-DB-Reader-XS/Makefile b/net/p5-MaxMind-DB-Reader-XS/Makefile
new file mode 100644
index 000000000000..8d10d0466306
--- /dev/null
+++ b/net/p5-MaxMind-DB-Reader-XS/Makefile
@@ -0,0 +1,37 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= MaxMind-DB-Reader-XS
+PORTVERSION= 1.000006
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:MAXMIND
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Fast XS implementation of MaxMind DB reader
+
+LICENSE= ART20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${RUN_DEPENDS}
+LIB_DEPENDS= libmaxminddb.so:net/libmaxminddb
+RUN_DEPENDS= p5-MaxMind-DB-Common>=0.040001:net/p5-MaxMind-DB-Common \
+ p5-MaxMind-DB-Reader>=1.000012:net/p5-MaxMind-DB-Reader \
+ p5-Moo>=0:devel/p5-Moo \
+ p5-namespace-autoclean>=0:devel/p5-namespace-autoclean
+TEST_DEPENDS= p5-Math-Int128>=0:math/p5-Math-Int128 \
+ p5-Module-Implementation>=0:devel/p5-Module-Implementation \
+ p5-Net-Works>=0.21:net/p5-Net-Works \
+ p5-Path-Class>=0.27:devel/p5-Path-Class \
+ p5-Test-Fatal>=0:devel/p5-Test-Fatal \
+ p5-Test-Number-Delta>=0:devel/p5-Test-Number-Delta \
+ p5-Test-Requires>=0:devel/p5-Test-Requires
+
+USES= perl5
+USE_PERL5= modbuild
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/MaxMind/DB/Reader/XS/XS.so
+
+.include <bsd.port.mk>