aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-Appliance-Phrasebook
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2010-05-05 12:29:16 +0000
committerAnton Berezin <tobez@FreeBSD.org>2010-05-05 12:29:16 +0000
commite1286d55cb63e4c375db594f87eeee0ed2f6336d (patch)
treee71e916c3d09219a087f6e771016f1e4530a34c2 /net/p5-Net-Appliance-Phrasebook
parent9647b747b62a5439dad436d94b7800d1a6843341 (diff)
downloadports-e1286d55cb63e4c375db594f87eeee0ed2f6336d.tar.gz
ports-e1286d55cb63e4c375db594f87eeee0ed2f6336d.zip
Add net/p5-Net-Appliance-Phrasebook 1.8, a Perl module that
implements a network appliance command-line phrasebook.
Notes
Notes: svn path=/head/; revision=253742
Diffstat (limited to 'net/p5-Net-Appliance-Phrasebook')
-rw-r--r--net/p5-Net-Appliance-Phrasebook/Makefile31
-rw-r--r--net/p5-Net-Appliance-Phrasebook/distinfo3
-rw-r--r--net/p5-Net-Appliance-Phrasebook/pkg-descr12
-rw-r--r--net/p5-Net-Appliance-Phrasebook/pkg-plist9
4 files changed, 55 insertions, 0 deletions
diff --git a/net/p5-Net-Appliance-Phrasebook/Makefile b/net/p5-Net-Appliance-Phrasebook/Makefile
new file mode 100644
index 000000000000..6e7315dc019a
--- /dev/null
+++ b/net/p5-Net-Appliance-Phrasebook/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: net/p5-Net-Appliance-Phrasebook
+# Date created: 05 May 2010
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-Appliance-Phrasebook
+PORTVERSION= 1.8
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Network appliance command-line phrasebook
+
+BUILD_DEPENDS= ${SITE_PERL}/YAML.pm:${PORTSDIR}/textproc/p5-YAML \
+ ${SITE_PERL}/Test/Pod/Coverage.pm:${PORTSDIR}/devel/p5-Test-Pod-Coverage \
+ ${SITE_PERL}/Data/Phrasebook.pm:${PORTSDIR}/textproc/p5-Data-Phrasebook \
+ ${SITE_PERL}/Test/Pod.pm:${PORTSDIR}/devel/p5-Test-Pod \
+ ${SITE_PERL}/Data/Phrasebook/Loader/YAML.pm:${PORTSDIR}/textproc/p5-Data-Phrasebook-Loader-YAML \
+ ${SITE_PERL}/Class/Data/Inheritable.pm:${PORTSDIR}/devel/p5-Class-Data-Inheritable \
+ ${SITE_PERL}/${PERL_ARCH}/List/MoreUtils.pm:${PORTSDIR}/lang/p5-List-MoreUtils
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::Appliance::Phrasebook.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-Appliance-Phrasebook/distinfo b/net/p5-Net-Appliance-Phrasebook/distinfo
new file mode 100644
index 000000000000..71edb9756323
--- /dev/null
+++ b/net/p5-Net-Appliance-Phrasebook/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-Appliance-Phrasebook-1.8.tar.gz) = 96f16381de24e1058eef0138c20c96df
+SHA256 (Net-Appliance-Phrasebook-1.8.tar.gz) = 2419cfc891ff4a12ee7faa7b7ce2c26c1c5d7aef8ac4d26dbd811b2829406be6
+SIZE (Net-Appliance-Phrasebook-1.8.tar.gz) = 19555
diff --git a/net/p5-Net-Appliance-Phrasebook/pkg-descr b/net/p5-Net-Appliance-Phrasebook/pkg-descr
new file mode 100644
index 000000000000..2fa1334d74d6
--- /dev/null
+++ b/net/p5-Net-Appliance-Phrasebook/pkg-descr
@@ -0,0 +1,12 @@
+If you use Perl to manage interactive sessions with with the
+command-line interfaces of networked appliances, then you might find
+this module useful.
+
+Net::Appliance::Phrasebook is a simple module that contains a number of
+dictionaries for the command-line interfaces of some popular network
+appliances.
+
+It also supports the use of custom phrasebooks, and of hiearchies of
+dictionaries within phrasebooks.
+
+WWW: http://search.cpan.org/dist/Net-Appliance-Phrasebook/
diff --git a/net/p5-Net-Appliance-Phrasebook/pkg-plist b/net/p5-Net-Appliance-Phrasebook/pkg-plist
new file mode 100644
index 000000000000..337546b3610b
--- /dev/null
+++ b/net/p5-Net-Appliance-Phrasebook/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/Net/Appliance/Phrasebook.pm
+%%SITE_PERL%%/Net/Appliance/Phrasebook/nas-pb.yml
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Appliance/Phrasebook/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Appliance/Phrasebook
+@dirrmtry %%SITE_PERL%%/Net/Appliance/Phrasebook
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Appliance
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+@dirrmtry %%SITE_PERL%%/Net/Appliance
+@dirrmtry %%SITE_PERL%%/Net