aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-DAV-Server
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2015-03-13 17:29:58 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2015-03-13 17:29:58 +0000
commit10f22ecd6d1808866406972dd09e2e107e41ceb2 (patch)
tree31d423e420103f6111ac7dcc29da77612438b7a3 /net/p5-Net-DAV-Server
parent42651c13cd4978964674808cab47a30c8726769b (diff)
Clean up the rest of the perl@ Makefiles a bit.
- Remove dependencies on modules distributed as part of perl core - Remove references to FreeBSD < 8 and perl < 5.16 - Ensure that DOCS and EXAMPLES options exist for ports installing PORTDOCS or PORTEXAMPLES - Reduce unnecessary inclusions of bsd.port.options.mk by using OPTIONS helpers and the like - Fix some cases where dependencies were only assigned to BUILD_DEPENDS - Fix a few of the cases where dependencies were only assigned to RUN_DEPENDS. This one happens in many, many ports. I only applied it in cases where it interfered with 'make test' but it should maybe be done more generally. - Mute ${MKDIR} in installation - Parethesize compound commands - In www/p5-URI-Fetch, remove the ZLIB option that wasn't used
Notes
Notes: svn path=/head/; revision=381221
Diffstat (limited to 'net/p5-Net-DAV-Server')
-rw-r--r--net/p5-Net-DAV-Server/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/net/p5-Net-DAV-Server/Makefile b/net/p5-Net-DAV-Server/Makefile
index 726fbedbb7c8..360eb7d7ddfb 100644
--- a/net/p5-Net-DAV-Server/Makefile
+++ b/net/p5-Net-DAV-Server/Makefile
@@ -12,7 +12,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:C/\.(.)$/\1/}
MAINTAINER= perl@FreeBSD.org
COMMENT= Provide a DAV Server
-RUN_DEPENDS= p5-DBD-SQLite>=0:${PORTSDIR}/databases/p5-DBD-SQLite \
+BUILD_DEPENDS= p5-DBD-SQLite>=0:${PORTSDIR}/databases/p5-DBD-SQLite \
p5-DBI>=0:${PORTSDIR}/databases/p5-DBI \
p5-Digest-SHA1>=0:${PORTSDIR}/security/p5-Digest-SHA1 \
p5-File-Find-Rule-Filesys-Virtual>=0:${PORTSDIR}/devel/p5-File-Find-Rule-Filesys-Virtual \
@@ -20,6 +20,7 @@ RUN_DEPENDS= p5-DBD-SQLite>=0:${PORTSDIR}/databases/p5-DBD-SQLite \
p5-URI>=0:${PORTSDIR}/net/p5-URI \
p5-XML-LibXML>=1.62000:${PORTSDIR}/textproc/p5-XML-LibXML \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5
USE_PERL5= modbuild