aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-DHCP
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2006-07-13 10:19:15 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2006-07-13 10:19:15 +0000
commite18b2a5b649b560245c69a33cb248e1ab84900bc (patch)
tree472fc85e30ae96ac89be1fff6b0a380a0ef4f12b /net/p5-Net-DHCP
parentb54e6c51b999ec42a0c86c956edb06e0e09059fe (diff)
downloadports-e18b2a5b649b560245c69a33cb248e1ab84900bc.tar.gz
ports-e18b2a5b649b560245c69a33cb248e1ab84900bc.zip
This module is a DHCP set of classes designed to handle basic DHCP
handling. It can be used to develop either client, server or relays. It is composed of 100% pure Perl. WWW: http://search.cpan.org/dist/Net-DHCP/ PR: ports/100188 Submitted by: Jin-Shan Tseng <tjs at cdpa.nsysu.edu.tw>
Notes
Notes: svn path=/head/; revision=167683
Diffstat (limited to 'net/p5-Net-DHCP')
-rw-r--r--net/p5-Net-DHCP/Makefile28
-rw-r--r--net/p5-Net-DHCP/distinfo3
-rw-r--r--net/p5-Net-DHCP/pkg-descr5
-rw-r--r--net/p5-Net-DHCP/pkg-plist7
4 files changed, 43 insertions, 0 deletions
diff --git a/net/p5-Net-DHCP/Makefile b/net/p5-Net-DHCP/Makefile
new file mode 100644
index 000000000000..072a4d185775
--- /dev/null
+++ b/net/p5-Net-DHCP/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-Net-DHCP
+# Date created: 2006-07-13
+# Whom: Jin-Shan Tseng <tjs@cdpa.nsysu.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-DHCP
+PORTVERSION= 0.66
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tjs@cdpa.nsysu.edu.tw
+COMMENT= A DHCP set of classes designed to handle basic DHCP handling
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::DHCP::Packet.3 Net::DHCP::Constants.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires perl 5.8.0 or later. Install lang/perl5.8 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/p5-Net-DHCP/distinfo b/net/p5-Net-DHCP/distinfo
new file mode 100644
index 000000000000..272247ad2891
--- /dev/null
+++ b/net/p5-Net-DHCP/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-DHCP-0.66.tar.gz) = 856b4c44714fd75a31f87929a0926752
+SHA256 (Net-DHCP-0.66.tar.gz) = 3431503497b575170ecda942e432093e2aa0cc934154cc403599b313a0d10dfa
+SIZE (Net-DHCP-0.66.tar.gz) = 21505
diff --git a/net/p5-Net-DHCP/pkg-descr b/net/p5-Net-DHCP/pkg-descr
new file mode 100644
index 000000000000..0ec455cf99f8
--- /dev/null
+++ b/net/p5-Net-DHCP/pkg-descr
@@ -0,0 +1,5 @@
+This module is a DHCP set of classes designed to handle basic DHCP
+handling. It can be used to develop either client, server or relays.
+It is composed of 100% pure Perl.
+
+WWW: http://search.cpan.org/dist/Net-DHCP/
diff --git a/net/p5-Net-DHCP/pkg-plist b/net/p5-Net-DHCP/pkg-plist
new file mode 100644
index 000000000000..16ecba1f07d8
--- /dev/null
+++ b/net/p5-Net-DHCP/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Net/DHCP/Packet.pm
+%%SITE_PERL%%/Net/DHCP/Constants.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/DHCP/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/DHCP
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+@dirrmtry %%SITE_PERL%%/Net/DHCP
+@dirrmtry %%SITE_PERL%%/Net