aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-Delicious
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2015-03-13 17:29:58 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2015-03-13 17:29:58 +0000
commit10f22ecd6d1808866406972dd09e2e107e41ceb2 (patch)
tree31d423e420103f6111ac7dcc29da77612438b7a3 /net/p5-Net-Delicious
parent42651c13cd4978964674808cab47a30c8726769b (diff)
downloadports-10f22ecd6d1808866406972dd09e2e107e41ceb2.tar.gz
ports-10f22ecd6d1808866406972dd09e2e107e41ceb2.zip
Clean up the rest of the perl@ Makefiles a bit.
- Remove dependencies on modules distributed as part of perl core - Remove references to FreeBSD < 8 and perl < 5.16 - Ensure that DOCS and EXAMPLES options exist for ports installing PORTDOCS or PORTEXAMPLES - Reduce unnecessary inclusions of bsd.port.options.mk by using OPTIONS helpers and the like - Fix some cases where dependencies were only assigned to BUILD_DEPENDS - Fix a few of the cases where dependencies were only assigned to RUN_DEPENDS. This one happens in many, many ports. I only applied it in cases where it interfered with 'make test' but it should maybe be done more generally. - Mute ${MKDIR} in installation - Parethesize compound commands - In www/p5-URI-Fetch, remove the ZLIB option that wasn't used
Notes
Notes: svn path=/head/; revision=381221
Diffstat (limited to 'net/p5-Net-Delicious')
-rw-r--r--net/p5-Net-Delicious/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/net/p5-Net-Delicious/Makefile b/net/p5-Net-Delicious/Makefile
index f505cd23c95d..f7d4a22cd8f2 100644
--- a/net/p5-Net-Delicious/Makefile
+++ b/net/p5-Net-Delicious/Makefile
@@ -13,14 +13,14 @@ MAINTAINER= perl@FreeBSD.org
COMMENT= OOP for managing posts on del.icio.us
RUN_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
- p5-YAML>=0.35:${PORTSDIR}/textproc/p5-YAML \
- p5-URI>=0:${PORTSDIR}/net/p5-URI \
- p5-Log-Dispatch>=2:${PORTSDIR}/devel/p5-Log-Dispatch \
- p5-XML-Simple>=2:${PORTSDIR}/textproc/p5-XML-Simple \
+ p5-Config-Simple>=2:${PORTSDIR}/devel/p5-Config-Simple \
+ p5-Crypt-SSLeay>=0:${PORTSDIR}/security/p5-Crypt-SSLeay \
p5-IO-stringy>=2.1:${PORTSDIR}/devel/p5-IO-stringy \
+ p5-Log-Dispatch>=2:${PORTSDIR}/devel/p5-Log-Dispatch \
+ p5-URI>=0:${PORTSDIR}/net/p5-URI \
p5-TimeDate>=2.27:${PORTSDIR}/devel/p5-TimeDate \
- p5-Config-Simple>=2:${PORTSDIR}/devel/p5-Config-Simple \
- p5-Crypt-SSLeay>=0:${PORTSDIR}/security/p5-Crypt-SSLeay
+ p5-XML-Simple>=2:${PORTSDIR}/textproc/p5-XML-Simple \
+ p5-YAML>=0.35:${PORTSDIR}/textproc/p5-YAML
BUILD_DEPENDS:= ${RUN_DEPENDS}
USES= perl5