aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-EPP
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2014-11-26 13:08:24 +0000
committerMathieu Arnold <mat@FreeBSD.org>2014-11-26 13:08:24 +0000
commiteee58d187e2c55fca6f53b9e482d33cf5346fe81 (patch)
tree0d350fe6ad6a2fe3222d838f3c72856c78cd449f /net/p5-Net-EPP
parent3f1df82a16a1e89db9a69b36ade7342f34095ab4 (diff)
downloadports-eee58d187e2c55fca6f53b9e482d33cf5346fe81.tar.gz
ports-eee58d187e2c55fca6f53b9e482d33cf5346fe81.zip
Change the way Perl modules are installed, update the default Perl to 5.18.
Before, we had: site_perl : lib/perl5/site_perl/5.18 site_perl/perl_arch : lib/perl5/site_perl/5.18/mach perl_man3 : lib/perl5/5.18/man/man3 Now we have: site_perl : lib/perl5/site_perl site_arch : lib/perl5/site_perl/mach/5.18 perl_man3 : lib/perl5/site_perl/man/man3 Modules without any .so will be installed at the same place regardless of the Perl version, minimizing the upgrade when the major Perl version is changed. It uses a version dependent directory for modules with compiled bits. As PERL_ARCH is no longer needed in plists, it has been removed from PLIST_SUB. The USE_PERL5=fixpacklist keyword is removed, the .packlist file is now always removed, as is perllocal.pod. The old site_perl and site_perl/arch directories have been kept in the default Perl @INC for all Perl ports, and will be phased out as these old Perl versions expire. PR: 194969 Differential Revision: https://reviews.freebsd.org/D1019 Exp-run by: antoine Reviewed by: perl@ Approved by: portmgr
Notes
Notes: svn path=/head/; revision=373448
Diffstat (limited to 'net/p5-Net-EPP')
-rw-r--r--net/p5-Net-EPP/Makefile1
-rw-r--r--net/p5-Net-EPP/pkg-plist15
2 files changed, 1 insertions, 15 deletions
diff --git a/net/p5-Net-EPP/Makefile b/net/p5-Net-EPP/Makefile
index 70c4656d64d7..7b85a556c875 100644
--- a/net/p5-Net-EPP/Makefile
+++ b/net/p5-Net-EPP/Makefile
@@ -3,6 +3,7 @@
PORTNAME= Net-EPP
PORTVERSION= 0.19
+PORTREVISION= 1
CATEGORIES= net perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
diff --git a/net/p5-Net-EPP/pkg-plist b/net/p5-Net-EPP/pkg-plist
index 402e98ce764f..5d901c375f3d 100644
--- a/net/p5-Net-EPP/pkg-plist
+++ b/net/p5-Net-EPP/pkg-plist
@@ -39,7 +39,6 @@
%%SITE_PERL%%/Net/EPP/Protocol.pm
%%SITE_PERL%%/Net/EPP/ResponseCodes.pm
%%SITE_PERL%%/Net/EPP/Simple.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/EPP/.packlist
%%PERL5_MAN3%%/Net::EPP.3.gz
%%PERL5_MAN3%%/Net::EPP::Client.3.gz
%%PERL5_MAN3%%/Net::EPP::Frame.3.gz
@@ -81,17 +80,3 @@
%%PERL5_MAN3%%/Net::EPP::Frame::Command::Transfer::Domain.3.gz
%%PERL5_MAN3%%/Net::EPP::Frame::Command::Transfer::Contact.3.gz
%%PERL5_MAN3%%/Net::EPP::Frame::Command::Poll::Ack.3.gz
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/EPP
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
-@dirrm %%SITE_PERL%%/Net/EPP/Frame/Command/Update
-@dirrm %%SITE_PERL%%/Net/EPP/Frame/Command/Transfer
-@dirrm %%SITE_PERL%%/Net/EPP/Frame/Command/Renew
-@dirrm %%SITE_PERL%%/Net/EPP/Frame/Command/Poll
-@dirrm %%SITE_PERL%%/Net/EPP/Frame/Command/Info
-@dirrm %%SITE_PERL%%/Net/EPP/Frame/Command/Delete
-@dirrm %%SITE_PERL%%/Net/EPP/Frame/Command/Create
-@dirrm %%SITE_PERL%%/Net/EPP/Frame/Command/Check
-@dirrm %%SITE_PERL%%/Net/EPP/Frame/Command
-@dirrm %%SITE_PERL%%/Net/EPP/Frame
-@dirrmtry %%SITE_PERL%%/Net/EPP
-@dirrmtry %%SITE_PERL%%/Net