aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-Google-Calendar
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2006-05-16 09:12:53 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2006-05-16 09:12:53 +0000
commit69bfed8004c776fc56899c3fda321f148af2d16c (patch)
treea379a5640a28901a79383082c5e9956cbf95d261 /net/p5-Net-Google-Calendar
parentf4895cc9b0979947b4a649150ed4c24528d7c58c (diff)
downloadports-69bfed8004c776fc56899c3fda321f148af2d16c.tar.gz
ports-69bfed8004c776fc56899c3fda321f148af2d16c.zip
Add p5-Net-Google-Calendar: Programmatic access to Google's Calendar API
PR: ports/97284 Submitted by: Yi-Hsuan Hsin <mhsin@mhsin.org> Approved by: krion (mentor)
Notes
Notes: svn path=/head/; revision=162545
Diffstat (limited to 'net/p5-Net-Google-Calendar')
-rw-r--r--net/p5-Net-Google-Calendar/Makefile28
-rw-r--r--net/p5-Net-Google-Calendar/distinfo3
-rw-r--r--net/p5-Net-Google-Calendar/pkg-descr4
-rw-r--r--net/p5-Net-Google-Calendar/pkg-plist6
4 files changed, 41 insertions, 0 deletions
diff --git a/net/p5-Net-Google-Calendar/Makefile b/net/p5-Net-Google-Calendar/Makefile
new file mode 100644
index 000000000000..766473c66e2e
--- /dev/null
+++ b/net/p5-Net-Google-Calendar/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-Net-Google-Calendar
+# Date created: 2006-05-15
+# Whom: Yi-Hsuan Hsin <mhsin@mhsin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-Google-Calendar
+DISTVERSION= 0.1_devel
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= mhsin@mhsin.org
+COMMENT= Programmatic access to Google's Calendar API
+
+BUILD_DEPENDS= p5-XML-Atom>=0:${PORTSDIR}/textproc/p5-XML-Atom \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
+ p5-DateTime>=0:${PORTSDIR}/devel/p5-DateTime
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= Net::Google::Calendar.3 Net::Google::Calendar::Entry.3 \
+ Net::Google::Calendar::Person.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-Google-Calendar/distinfo b/net/p5-Net-Google-Calendar/distinfo
new file mode 100644
index 000000000000..ef59f90d1a2c
--- /dev/null
+++ b/net/p5-Net-Google-Calendar/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-Google-Calendar-0.1_devel.tar.gz) = 1fe3eef4ececd1461b1c6758abecf56c
+SHA256 (Net-Google-Calendar-0.1_devel.tar.gz) = 6d47cda4abc908569fc3315fee384581561605d5c5140ed57311339d402d20ce
+SIZE (Net-Google-Calendar-0.1_devel.tar.gz) = 4897
diff --git a/net/p5-Net-Google-Calendar/pkg-descr b/net/p5-Net-Google-Calendar/pkg-descr
new file mode 100644
index 000000000000..f3bb78f4d6b8
--- /dev/null
+++ b/net/p5-Net-Google-Calendar/pkg-descr
@@ -0,0 +1,4 @@
+Provides programmatic access to Google's Calendar API
+
+Author: Simon Wistow <simon@thegestalt.org>
+WWW: http://search.cpan.org/dist/Net-Google-Calendar/
diff --git a/net/p5-Net-Google-Calendar/pkg-plist b/net/p5-Net-Google-Calendar/pkg-plist
new file mode 100644
index 000000000000..93561c67b79d
--- /dev/null
+++ b/net/p5-Net-Google-Calendar/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/Net/Google/Calendar.pm
+%%SITE_PERL%%/Net/Google/Calendar/Entry.pm
+%%SITE_PERL%%/Net/Google/Calendar/Person.pm
+@dirrm %%SITE_PERL%%/Net/Google/Calendar
+@dirrm %%SITE_PERL%%/Net/Google
+@dirrmtry %%SITE_PERL%%/Net