aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-Google-DataAPI
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2010-03-29 04:13:12 +0000
committerWen Heping <wen@FreeBSD.org>2010-03-29 04:13:12 +0000
commit639f9b5ea4a8b2e2b7ad2c54de99599676b8040e (patch)
tree99016800c00336b27a84fb0b0a88ff34a851079a /net/p5-Net-Google-DataAPI
parent7b1fe863daa82f4dd7301dacd053fec208e8626f (diff)
downloadports-639f9b5ea4a8b2e2b7ad2c54de99599676b8040e.tar.gz
ports-639f9b5ea4a8b2e2b7ad2c54de99599676b8040e.zip
Net::Google::DataAPI is base implementations for modules to negotiate
with Google Data APIs. WWW: http://search.cpan.org/~danjou/Net-Google-DataAPI/ PR: ports/145150 Submitted by: Gunter Wambaugh <gunter@six-two.net>
Notes
Notes: svn path=/head/; revision=251672
Diffstat (limited to 'net/p5-Net-Google-DataAPI')
-rw-r--r--net/p5-Net-Google-DataAPI/Makefile44
-rw-r--r--net/p5-Net-Google-DataAPI/distinfo3
-rw-r--r--net/p5-Net-Google-DataAPI/pkg-descr4
-rw-r--r--net/p5-Net-Google-DataAPI/pkg-plist20
4 files changed, 71 insertions, 0 deletions
diff --git a/net/p5-Net-Google-DataAPI/Makefile b/net/p5-Net-Google-DataAPI/Makefile
new file mode 100644
index 000000000000..61bde7db207a
--- /dev/null
+++ b/net/p5-Net-Google-DataAPI/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: p5-Net-Google-DataAPI
+# Date created: 23 March 2010
+# Whom: Gunter Wambaugh <gunter@six-two.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-Google-DataAPI
+PORTVERSION= 0.17
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gunter@six-two.net
+COMMENT= Base implementations for modules to negotiate with Google Data APIs
+
+BUILD_DEPENDS= ${SITE_PERL}/XML/Atom.pm:${PORTSDIR}/textproc/p5-XML-Atom \
+ ${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1 \
+ ${SITE_PERL}/Any/Moose.pm:${PORTSDIR}/devel/p5-Any-Moose \
+ ${SITE_PERL}/Net/Google/AuthSub.pm:${PORTSDIR}/net/p5-Net-Google-AuthSub \
+ ${SITE_PERL}/${PERL_ARCH}/Crypt/SSLeay.pm:${PORTSDIR}/security/p5-Crypt-SSLeay \
+ ${SITE_PERL}/Net/OAuth.pm:${PORTSDIR}/net/p5-Net-OAuth \
+ ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI \
+ ${SITE_PERL}/Lingua/EN/Inflect/Number.pm:${PORTSDIR}/textproc/p5-Lingua-EN-Inflect-Number \
+ ${SITE_PERL}/namespace/autoclean.pm:${PORTSDIR}/devel/p5-namespace-autoclean \
+ ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
+ ${SITE_PERL}/Test/Warn.pm:${PORTSDIR}/devel/p5-Test-Warn \
+ ${SITE_PERL}/Test/MockModule.pm:${PORTSDIR}/devel/p5-Test-MockModule \
+ ${SITE_PERL}/Test/MockObject.pm:${PORTSDIR}/devel/p5-Test-MockObject \
+ ${SITE_PERL}/UNIVERSAL/isa.pm:${PORTSDIR}/devel/p5-UNIVERSAL-isa \
+ ${SITE_PERL}/UNIVERSAL/can.pm:${PORTSDIR}/devel/p5-UNIVERSAL-can
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::Google::DataAPI.3 \
+ Net::Google::DataAPI::Auth::ClientLogin::Multiple.3 \
+ Net::Google::DataAPI::Auth::OAuth.3 \
+ Net::Google::DataAPI::Role::Entry.3 \
+ Net::Google::DataAPI::Role::HasContent.3 \
+ Net::Google::DataAPI::Role::Service.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-Google-DataAPI/distinfo b/net/p5-Net-Google-DataAPI/distinfo
new file mode 100644
index 000000000000..d322d5fd4527
--- /dev/null
+++ b/net/p5-Net-Google-DataAPI/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-Google-DataAPI-0.17.tar.gz) = 589f4f1f62dc1f4cd49a5fac22e984a9
+SHA256 (Net-Google-DataAPI-0.17.tar.gz) = 4b78ea172e586c016e119a48e0f0e952243f7565859a63c8aaeba7a06c170bba
+SIZE (Net-Google-DataAPI-0.17.tar.gz) = 44630
diff --git a/net/p5-Net-Google-DataAPI/pkg-descr b/net/p5-Net-Google-DataAPI/pkg-descr
new file mode 100644
index 000000000000..95e6f58a8b47
--- /dev/null
+++ b/net/p5-Net-Google-DataAPI/pkg-descr
@@ -0,0 +1,4 @@
+Net::Google::DataAPI is base implementations for modules to negotiate
+with Google Data APIs.
+
+WWW: http://search.cpan.org/~danjou/Net-Google-DataAPI/
diff --git a/net/p5-Net-Google-DataAPI/pkg-plist b/net/p5-Net-Google-DataAPI/pkg-plist
new file mode 100644
index 000000000000..01e780dbd4a9
--- /dev/null
+++ b/net/p5-Net-Google-DataAPI/pkg-plist
@@ -0,0 +1,20 @@
+%%SITE_PERL%%/Net/Google/DataAPI.pm
+%%SITE_PERL%%/Net/Google/DataAPI/Auth/AuthSub.pm
+%%SITE_PERL%%/Net/Google/DataAPI/Auth/ClientLogin/Multiple.pm
+%%SITE_PERL%%/Net/Google/DataAPI/Auth/Null.pm
+%%SITE_PERL%%/Net/Google/DataAPI/Auth/OAuth.pm
+%%SITE_PERL%%/Net/Google/DataAPI/Role/Auth.pm
+%%SITE_PERL%%/Net/Google/DataAPI/Role/Entry.pm
+%%SITE_PERL%%/Net/Google/DataAPI/Role/HasContent.pm
+%%SITE_PERL%%/Net/Google/DataAPI/Role/Service.pm
+%%SITE_PERL%%/Net/Google/DataAPI/Types.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Google/DataAPI/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Google/DataAPI
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Google
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+@dirrmtry %%SITE_PERL%%/Net/Google/DataAPI/Role
+@dirrmtry %%SITE_PERL%%/Net/Google/DataAPI/Auth/ClientLogin
+@dirrmtry %%SITE_PERL%%/Net/Google/DataAPI/Auth
+@dirrmtry %%SITE_PERL%%/Net/Google/DataAPI
+@dirrmtry %%SITE_PERL%%/Net/Google
+@dirrmtry %%SITE_PERL%%/Net