aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-Google-DataAPI
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-05-18 09:24:49 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-05-18 09:24:49 +0000
commited557114e539f75fbf309a9f67bf107ca1408380 (patch)
treed11b7813770455049c5d033f210c5353e930b842 /net/p5-Net-Google-DataAPI
parente37088965dd19af48ffbc2ed411260ff800b8bcc (diff)
downloadports-ed557114e539f75fbf309a9f67bf107ca1408380.tar.gz
ports-ed557114e539f75fbf309a9f67bf107ca1408380.zip
- Update to 0.2801
- Add BUILD_DEPENDS Changes: http://search.cpan.org/dist/Net-Google-DataAPI/Changes PR: ports/167437 Submitted by: sunpoet (myself) Approved by: maintainer (timeout, 18 days)
Notes
Notes: svn path=/head/; revision=296893
Diffstat (limited to 'net/p5-Net-Google-DataAPI')
-rw-r--r--net/p5-Net-Google-DataAPI/Makefile15
-rw-r--r--net/p5-Net-Google-DataAPI/distinfo4
-rw-r--r--net/p5-Net-Google-DataAPI/pkg-plist1
3 files changed, 13 insertions, 7 deletions
diff --git a/net/p5-Net-Google-DataAPI/Makefile b/net/p5-Net-Google-DataAPI/Makefile
index 1e17fc1bccb9..217c556414c7 100644
--- a/net/p5-Net-Google-DataAPI/Makefile
+++ b/net/p5-Net-Google-DataAPI/Makefile
@@ -6,29 +6,33 @@
#
PORTNAME= Net-Google-DataAPI
-PORTVERSION= 0.24
+PORTVERSION= 0.28.01
CATEGORIES= net perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-${PORTVERSION:R}${PORTVERSION:E}
MAINTAINER= gunter@six-two.net
COMMENT= Base implementations for modules to negotiate with Google Data APIs
-RUN_DEPENDS= p5-Any-Moose>=0.04:${PORTSDIR}/devel/p5-Any-Moose \
- p5-Crypt-SSLeay>=0:${PORTSDIR}/security/p5-Crypt-SSLeay \
+BUILD_DEPENDS= p5-Any-Moose>=0.04:${PORTSDIR}/devel/p5-Any-Moose \
p5-Digest-SHA1>=0:${PORTSDIR}/security/p5-Digest-SHA1 \
+ p5-LWP-Protocol-https>=0:${PORTSDIR}/www/p5-LWP-Protocol-https \
p5-Lingua-EN-Inflect-Number>=0:${PORTSDIR}/textproc/p5-Lingua-EN-Inflect-Number \
p5-Mouse>=0.51:${PORTSDIR}/devel/p5-Mouse \
p5-Net-Google-AuthSub>=0.5:${PORTSDIR}/net/p5-Net-Google-AuthSub \
p5-Net-OAuth>=0:${PORTSDIR}/net/p5-Net-OAuth \
+ p5-Net-OAuth2>=0.07:${PORTSDIR}/net/p5-Net-OAuth2 \
p5-Text-Glob>=0:${PORTSDIR}/textproc/p5-Text-Glob \
p5-URI>=0:${PORTSDIR}/net/p5-URI \
p5-XML-Atom>=0:${PORTSDIR}/textproc/p5-XML-Atom \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
p5-namespace-autoclean>=0:${PORTSDIR}/devel/p5-namespace-autoclean
-TEST_DEPENDS= p5-Test-MockModule>=0:${PORTSDIR}/devel/p5-Test-MockModule \
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+TEST_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception \
+ p5-Test-MockModule>=0:${PORTSDIR}/devel/p5-Test-MockModule \
p5-Test-MockObject>=0:${PORTSDIR}/devel/p5-Test-MockObject \
- p5-Test-Simple>=0:${PORTSDIR}/devel/p5-Test-Simple \
p5-Test-Warn>=0:${PORTSDIR}/devel/p5-Test-Warn
PERL_CONFIGURE= yes
@@ -36,6 +40,7 @@ PERL_CONFIGURE= yes
MAN3= Net::Google::DataAPI.3 \
Net::Google::DataAPI::Auth::ClientLogin::Multiple.3 \
Net::Google::DataAPI::Auth::OAuth.3 \
+ Net::Google::DataAPI::Auth::OAuth2.3 \
Net::Google::DataAPI::Role::Entry.3 \
Net::Google::DataAPI::Role::HasContent.3 \
Net::Google::DataAPI::Role::Service.3
diff --git a/net/p5-Net-Google-DataAPI/distinfo b/net/p5-Net-Google-DataAPI/distinfo
index b687d1d3dbf3..555af6d5569f 100644
--- a/net/p5-Net-Google-DataAPI/distinfo
+++ b/net/p5-Net-Google-DataAPI/distinfo
@@ -1,2 +1,2 @@
-SHA256 (Net-Google-DataAPI-0.24.tar.gz) = 85fe0fa3ba6762afe7fa50450f2f087702bb41b200e4e4d42413373ce831c4d0
-SIZE (Net-Google-DataAPI-0.24.tar.gz) = 49307
+SHA256 (Net-Google-DataAPI-0.2801.tar.gz) = db030d7f980590f0e974aef1f89e61ac1c21bb461699a12e9c34f6c1f15b0432
+SIZE (Net-Google-DataAPI-0.2801.tar.gz) = 41452
diff --git a/net/p5-Net-Google-DataAPI/pkg-plist b/net/p5-Net-Google-DataAPI/pkg-plist
index 01e780dbd4a9..c53d5b26c223 100644
--- a/net/p5-Net-Google-DataAPI/pkg-plist
+++ b/net/p5-Net-Google-DataAPI/pkg-plist
@@ -3,6 +3,7 @@
%%SITE_PERL%%/Net/Google/DataAPI/Auth/ClientLogin/Multiple.pm
%%SITE_PERL%%/Net/Google/DataAPI/Auth/Null.pm
%%SITE_PERL%%/Net/Google/DataAPI/Auth/OAuth.pm
+%%SITE_PERL%%/Net/Google/DataAPI/Auth/OAuth2.pm
%%SITE_PERL%%/Net/Google/DataAPI/Role/Auth.pm
%%SITE_PERL%%/Net/Google/DataAPI/Role/Entry.pm
%%SITE_PERL%%/Net/Google/DataAPI/Role/HasContent.pm