aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-Google-PicasaWeb
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-11-18 19:24:53 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-11-18 19:24:53 +0000
commit736da92a7b29cad8843da805e3d7c0b1af06f990 (patch)
treeb4475389881ca67c6ecc2d8821ed984d1331d937 /net/p5-Net-Google-PicasaWeb
parentcf344d7e27a963a4015ebb1b7a11e43f1cdca850 (diff)
downloadports-736da92a7b29cad8843da805e3d7c0b1af06f990.tar.gz
ports-736da92a7b29cad8843da805e3d7c0b1af06f990.zip
- Add p5-Net-Google-PicasaWeb 0.11
- While I'm here: - Add LICENSE - Fix *_DEPENDS - Convert to new Perl framework - Support STAGEDIR - Sort PLIST Net::Google::PicasaWeb - use Google's Picasa Web API This is both a library and a set of simple scripts for reading information about a Google PicasaWeb account. WWW: http://search.cpan.org/dist/Net-Google-PicasaWeb/ PR: ports/180314 Submitted by: Anes Mukhametov <anes@anes.su>
Notes
Notes: svn path=/head/; revision=334248
Diffstat (limited to 'net/p5-Net-Google-PicasaWeb')
-rw-r--r--net/p5-Net-Google-PicasaWeb/Makefile31
-rw-r--r--net/p5-Net-Google-PicasaWeb/distinfo2
-rw-r--r--net/p5-Net-Google-PicasaWeb/pkg-descr6
-rw-r--r--net/p5-Net-Google-PicasaWeb/pkg-plist29
4 files changed, 68 insertions, 0 deletions
diff --git a/net/p5-Net-Google-PicasaWeb/Makefile b/net/p5-Net-Google-PicasaWeb/Makefile
new file mode 100644
index 000000000000..429ffcd02499
--- /dev/null
+++ b/net/p5-Net-Google-PicasaWeb/Makefile
@@ -0,0 +1,31 @@
+# Created by: Anes Mukhametov <anes@anes.su>
+# $FreeBSD$
+
+PORTNAME= Net-Google-PicasaWeb
+PORTVERSION= 0.11
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= anes@anes.su
+COMMENT= Use Google Picasa Web API
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-IO-Prompt>=0:${PORTSDIR}/devel/p5-IO-Prompt \
+ p5-Moose>=0:${PORTSDIR}/devel/p5-Moose \
+ p5-MooseX-Role-Matcher>=0:${PORTSDIR}/devel/p5-MooseX-Role-Matcher \
+ p5-Net-Google-AuthSub>=0:${PORTSDIR}/net/p5-Net-Google-AuthSub \
+ p5-URI>=0:${PORTSDIR}/net/p5-URI \
+ p5-XML-Twig>=3.30:${PORTSDIR}/textproc/p5-XML-Twig \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+TEST_DEPENDS= p5-Test-Able>=0.09:${PORTSDIR}/devel/p5-Test-Able \
+ p5-Test-Able-Runner>=1.000:${PORTSDIR}/devel/p5-Test-Able-Runner \
+ p5-Test-Mock-LWP>=0:${PORTSDIR}/devel/p5-Test-Mock-LWP
+
+USE_PERL5= configure
+USES= perl5
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-Google-PicasaWeb/distinfo b/net/p5-Net-Google-PicasaWeb/distinfo
new file mode 100644
index 000000000000..2136d85092e6
--- /dev/null
+++ b/net/p5-Net-Google-PicasaWeb/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Net-Google-PicasaWeb-0.11.tar.gz) = 8a06582d7f6447df49d56009e35eba47140a19ac94de5ec0415a870dbdde80d6
+SIZE (Net-Google-PicasaWeb-0.11.tar.gz) = 34104
diff --git a/net/p5-Net-Google-PicasaWeb/pkg-descr b/net/p5-Net-Google-PicasaWeb/pkg-descr
new file mode 100644
index 000000000000..7e038edeb73c
--- /dev/null
+++ b/net/p5-Net-Google-PicasaWeb/pkg-descr
@@ -0,0 +1,6 @@
+Net::Google::PicasaWeb - use Google's Picasa Web API
+
+This is both a library and a set of simple scripts for
+reading information about a Google PicasaWeb account.
+
+WWW: http://search.cpan.org/dist/Net-Google-PicasaWeb/
diff --git a/net/p5-Net-Google-PicasaWeb/pkg-plist b/net/p5-Net-Google-PicasaWeb/pkg-plist
new file mode 100644
index 000000000000..8863ec9d0417
--- /dev/null
+++ b/net/p5-Net-Google-PicasaWeb/pkg-plist
@@ -0,0 +1,29 @@
+bin/picasa
+bin/picasa-get
+bin/picasa-list
+%%SITE_PERL%%/Net/Google/PicasaWeb.pm
+%%SITE_PERL%%/Net/Google/PicasaWeb/Album.pm
+%%SITE_PERL%%/Net/Google/PicasaWeb/Base.pm
+%%SITE_PERL%%/Net/Google/PicasaWeb/Comment.pm
+%%SITE_PERL%%/Net/Google/PicasaWeb/Feed.pm
+%%SITE_PERL%%/Net/Google/PicasaWeb/Media.pm
+%%SITE_PERL%%/Net/Google/PicasaWeb/MediaEntry.pm
+%%SITE_PERL%%/Net/Google/PicasaWeb/MediaFeed.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Google/PicasaWeb/.packlist
+%%PERL5_MAN3%%/Net::Google::PicasaWeb.3.gz
+%%PERL5_MAN3%%/Net::Google::PicasaWeb::Album.3.gz
+%%PERL5_MAN3%%/Net::Google::PicasaWeb::Base.3.gz
+%%PERL5_MAN3%%/Net::Google::PicasaWeb::Comment.3.gz
+%%PERL5_MAN3%%/Net::Google::PicasaWeb::Feed.3.gz
+%%PERL5_MAN3%%/Net::Google::PicasaWeb::Media.3.gz
+%%PERL5_MAN3%%/Net::Google::PicasaWeb::MediaEntry.3.gz
+%%PERL5_MAN3%%/Net::Google::PicasaWeb::MediaFeed.3.gz
+man/man1/picasa.1.gz
+man/man1/picasa-get.1.gz
+man/man1/picasa-list.1.gz
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Google/PicasaWeb
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Google
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+@dirrmtry %%SITE_PERL%%/Net/Google/PicasaWeb
+@dirrmtry %%SITE_PERL%%/Net/Google
+@dirrmtry %%SITE_PERL%%/Net