aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-Google
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2002-06-04 09:04:39 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2002-06-04 09:04:39 +0000
commit6c8cf57f0cb4eb2da7ed79d6e7f9d4bf33ad3c7e (patch)
tree6b1da74c64c68eeb6a94c520fbb300f8f10509ce /net/p5-Net-Google
parentd224c161d93b5a344aab39644027db1402c68555 (diff)
downloadports-6c8cf57f0cb4eb2da7ed79d6e7f9d4bf33ad3c7e.tar.gz
ports-6c8cf57f0cb4eb2da7ed79d6e7f9d4bf33ad3c7e.zip
Add p5-Net-Google 0.5,
simple OOP-ish interface to the Google SOAP API.
Notes
Notes: svn path=/head/; revision=60581
Diffstat (limited to 'net/p5-Net-Google')
-rw-r--r--net/p5-Net-Google/Makefile26
-rw-r--r--net/p5-Net-Google/distinfo1
-rw-r--r--net/p5-Net-Google/pkg-comment1
-rw-r--r--net/p5-Net-Google/pkg-descr1
-rw-r--r--net/p5-Net-Google/pkg-plist12
5 files changed, 41 insertions, 0 deletions
diff --git a/net/p5-Net-Google/Makefile b/net/p5-Net-Google/Makefile
new file mode 100644
index 000000000000..609893fa3a8f
--- /dev/null
+++ b/net/p5-Net-Google/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: Net-Google
+# Date created: 04 June 2002
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-Google
+PORTVERSION= 0.5
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/SOAP/Lite.pm:${PORTSDIR}/net/p5-SOAP-Lite
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::Google.3 Net::Google::Cache.3 Net::Google::Response.3 \
+ Net::Google::Search.3 Net::Google::Spelling.3
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-Google/distinfo b/net/p5-Net-Google/distinfo
new file mode 100644
index 000000000000..c3ed59cb9a47
--- /dev/null
+++ b/net/p5-Net-Google/distinfo
@@ -0,0 +1 @@
+MD5 (Net-Google-0.5.tar.gz) = 9761c8b8c94074e436d390cba7795fad
diff --git a/net/p5-Net-Google/pkg-comment b/net/p5-Net-Google/pkg-comment
new file mode 100644
index 000000000000..a67065585b63
--- /dev/null
+++ b/net/p5-Net-Google/pkg-comment
@@ -0,0 +1 @@
+simple OOP-ish interface to the Google SOAP API
diff --git a/net/p5-Net-Google/pkg-descr b/net/p5-Net-Google/pkg-descr
new file mode 100644
index 000000000000..b7223cd82e0b
--- /dev/null
+++ b/net/p5-Net-Google/pkg-descr
@@ -0,0 +1 @@
+Provides a simple OOP-ish interface to the Google SOAP API
diff --git a/net/p5-Net-Google/pkg-plist b/net/p5-Net-Google/pkg-plist
new file mode 100644
index 000000000000..6ab138c20972
--- /dev/null
+++ b/net/p5-Net-Google/pkg-plist
@@ -0,0 +1,12 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/Google/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/Net/Google.pm
+lib/perl5/site_perl/%%PERL_VER%%/Net/Google/Cache.pm
+lib/perl5/site_perl/%%PERL_VER%%/Net/Google/Response.pm
+lib/perl5/site_perl/%%PERL_VER%%/Net/Google/Search.pm
+lib/perl5/site_perl/%%PERL_VER%%/Net/Google/Services/GoogleSearch.wsdl
+lib/perl5/site_perl/%%PERL_VER%%/Net/Google/Spelling.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Net/Google/Services
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Net/Google
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/Google
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Net 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net 2>/dev/null || true