aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-LDAP-LDAPhash
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-02-17 11:12:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-02-17 11:12:05 +0000
commit6a95046265a026627ebd5a4eaffe608ae9600e26 (patch)
treeed3b65fc17651f8cdfebeaa0f3f4e50284b47353 /net/p5-Net-LDAP-LDAPhash
parent3eb4da4107d823b966061bfc4b0fd8ff500caef2 (diff)
downloadports-6a95046265a026627ebd5a4eaffe608ae9600e26.tar.gz
ports-6a95046265a026627ebd5a4eaffe608ae9600e26.zip
This takes from a search and turns it into a hash.
The returned has is in the following format. {DN}{ldap}{attribute}[array of values for this attribute] The reason for the {ldap} is to allow for other values and the like to be tagged onto a hash for a DN that are unrelated to LDAP. This function does not make any attempt to check if the search succedded or not. WWW: http://search.cpan.org/dist/Net-LDAP-LDAPhash/ PR: ports/120589 Submitted by: Zane C, Bowers <vvelox at vvelox.net>
Notes
Notes: svn path=/head/; revision=207456
Diffstat (limited to 'net/p5-Net-LDAP-LDAPhash')
-rw-r--r--net/p5-Net-LDAP-LDAPhash/Makefile21
-rw-r--r--net/p5-Net-LDAP-LDAPhash/distinfo3
-rw-r--r--net/p5-Net-LDAP-LDAPhash/pkg-descr13
-rw-r--r--net/p5-Net-LDAP-LDAPhash/pkg-plist7
4 files changed, 44 insertions, 0 deletions
diff --git a/net/p5-Net-LDAP-LDAPhash/Makefile b/net/p5-Net-LDAP-LDAPhash/Makefile
new file mode 100644
index 000000000000..9e38be6c3535
--- /dev/null
+++ b/net/p5-Net-LDAP-LDAPhash/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: p5-Net-LDAP-LDAPhash
+# Date created: 2008-02-13
+# Whom: Zane C, Bowers <vvelox@vvelox.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-LDAP-LDAPhash
+PORTVERSION= 1.0.1
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= vvelox@vvelox.net
+COMMENT= Make a hash out or the return from a search using Net::LDAP::Search
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::LDAP::LDAPhash.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-LDAP-LDAPhash/distinfo b/net/p5-Net-LDAP-LDAPhash/distinfo
new file mode 100644
index 000000000000..224af4d0f3ca
--- /dev/null
+++ b/net/p5-Net-LDAP-LDAPhash/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-LDAP-LDAPhash-1.0.1.tar.gz) = e63c52fe9df4cfdb00b64c84af18a472
+SHA256 (Net-LDAP-LDAPhash-1.0.1.tar.gz) = 17e93b33f0e87635ee7712c3290f73fe086401ee3aba8a6405edb74a19f0283e
+SIZE (Net-LDAP-LDAPhash-1.0.1.tar.gz) = 3333
diff --git a/net/p5-Net-LDAP-LDAPhash/pkg-descr b/net/p5-Net-LDAP-LDAPhash/pkg-descr
new file mode 100644
index 000000000000..3625a2e070f7
--- /dev/null
+++ b/net/p5-Net-LDAP-LDAPhash/pkg-descr
@@ -0,0 +1,13 @@
+This takes from a search and turns it into a hash.
+
+The returned has is in the following format.
+
+{DN}{ldap}{attribute}[array of values for this attribute]
+
+The reason for the {ldap} is to allow for other values and
+the like to be tagged onto a hash for a DN that are unrelated to LDAP.
+
+This function does not make any attempt to check if the search succedded
+or not.
+
+WWW: http://search.cpan.org/dist/Net-LDAP-LDAPhash/
diff --git a/net/p5-Net-LDAP-LDAPhash/pkg-plist b/net/p5-Net-LDAP-LDAPhash/pkg-plist
new file mode 100644
index 000000000000..97dc233e7aae
--- /dev/null
+++ b/net/p5-Net-LDAP-LDAPhash/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Net/LDAP/LDAPhash.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/LDAP/LDAPhash/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/LDAP/LDAPhash
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/LDAP
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+@dirrmtry %%SITE_PERL%%/Net/LDAP
+@dirrmtry %%SITE_PERL%%/Net