aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-OAuth2
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-04-30 03:11:26 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-04-30 03:11:26 +0000
commit51281a245013598b677cb850f2c4eaa59fb5edf1 (patch)
tree76d54fcd75041eea76b857ce52372962070929d6 /net/p5-Net-OAuth2
parent516ddfa29c54c2d8547731a109b49ee89c19d4fb (diff)
downloadports-51281a245013598b677cb850f2c4eaa59fb5edf1.tar.gz
ports-51281a245013598b677cb850f2c4eaa59fb5edf1.zip
Notes
Diffstat (limited to 'net/p5-Net-OAuth2')
-rw-r--r--net/p5-Net-OAuth2/Makefile36
-rw-r--r--net/p5-Net-OAuth2/distinfo2
-rw-r--r--net/p5-Net-OAuth2/pkg-descr3
-rw-r--r--net/p5-Net-OAuth2/pkg-plist9
4 files changed, 50 insertions, 0 deletions
diff --git a/net/p5-Net-OAuth2/Makefile b/net/p5-Net-OAuth2/Makefile
new file mode 100644
index 000000000000..865df1293f2c
--- /dev/null
+++ b/net/p5-Net-OAuth2/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: p5-Net-OAuth2
+# Date created: 2012-04-30
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-OAuth2
+PORTVERSION= 0.07
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= OAuth 2.0 for Perl
+
+BUILD_DEPENDS= p5-Class-Accessor>=0.31:${PORTSDIR}/devel/p5-Class-Accessor \
+ p5-JSON>=0:${PORTSDIR}/converters/p5-JSON \
+ p5-URI>=0:${PORTSDIR}/net/p5-URI \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+TEST_DEPENDS= p5-Test-Mock-LWP-Dispatch>=0:${PORTSDIR}/devel/p5-Test-Mock-LWP-Dispatch \
+ p5-Test-NoWarnings>=0:${PORTSDIR}/devel/p5-Test-NoWarnings \
+ p5-Test-Pod>=1.22:${PORTSDIR}/devel/p5-Test-Pod \
+ p5-YAML>=0:${PORTSDIR}/textproc/p5-YAML
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::OAuth2.3 \
+ Net::OAuth2::AccessToken.3 \
+ Net::OAuth2::Client.3 \
+ Net::OAuth2::Profile::Base.3 \
+ Net::OAuth2::Profile::WebServer.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-OAuth2/distinfo b/net/p5-Net-OAuth2/distinfo
new file mode 100644
index 000000000000..3837b93f954a
--- /dev/null
+++ b/net/p5-Net-OAuth2/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Net-OAuth2-0.07.tar.gz) = c2e1e9c8c7e2145f84642815bc740f7d284e34dca6624dc507edfa3070d0c2f1
+SIZE (Net-OAuth2-0.07.tar.gz) = 8369
diff --git a/net/p5-Net-OAuth2/pkg-descr b/net/p5-Net-OAuth2/pkg-descr
new file mode 100644
index 000000000000..fb786b51e0ed
--- /dev/null
+++ b/net/p5-Net-OAuth2/pkg-descr
@@ -0,0 +1,3 @@
+Net::OAuth2 provides OAuth 2.0 for Perl.
+
+WWW: http://search.cpan.org/dist/Net-OAuth2/
diff --git a/net/p5-Net-OAuth2/pkg-plist b/net/p5-Net-OAuth2/pkg-plist
new file mode 100644
index 000000000000..f4ed5ffd7ce2
--- /dev/null
+++ b/net/p5-Net-OAuth2/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/Net/OAuth2.pm
+%%SITE_PERL%%/Net/OAuth2/AccessToken.pm
+%%SITE_PERL%%/Net/OAuth2/Client.pm
+%%SITE_PERL%%/Net/OAuth2/Profile/Base.pm
+%%SITE_PERL%%/Net/OAuth2/Profile/WebServer.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/OAuth2/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/OAuth2
+@dirrmtry %%SITE_PERL%%/Net/OAuth2/Profile
+@dirrmtry %%SITE_PERL%%/Net/OAuth2