aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-OAuth
diff options
context:
space:
mode:
authorSahil Tandon <sahil@FreeBSD.org>2012-02-23 02:13:37 +0000
committerSahil Tandon <sahil@FreeBSD.org>2012-02-23 02:13:37 +0000
commitc041fc07013da69a7bd2f8e141811317ff4f65aa (patch)
tree40b50cb0ecd3d9056fd844a934eeb4b7ebbb5d6a /net/p5-Net-OAuth
parent3e5a6323ce9961194ae446a3df01c675ba087caf (diff)
downloadports-c041fc07013da69a7bd2f8e141811317ff4f65aa.tar.gz
ports-c041fc07013da69a7bd2f8e141811317ff4f65aa.zip
- Update to 0.28
Notes
Notes: svn path=/head/; revision=292098
Diffstat (limited to 'net/p5-Net-OAuth')
-rw-r--r--net/p5-Net-OAuth/Makefile6
-rw-r--r--net/p5-Net-OAuth/distinfo4
-rw-r--r--net/p5-Net-OAuth/pkg-plist3
3 files changed, 9 insertions, 4 deletions
diff --git a/net/p5-Net-OAuth/Makefile b/net/p5-Net-OAuth/Makefile
index b46cc87058e9..fb0c92b8c51e 100644
--- a/net/p5-Net-OAuth/Makefile
+++ b/net/p5-Net-OAuth/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= Net-OAuth
-PORTVERSION= 0.27
-PORTREVISION= 1
+PORTVERSION= 0.28
CATEGORIES= net perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -25,8 +24,10 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_MODBUILD= yes
MAN3= Net::OAuth.3 \
+ Net::OAuth::AccessToken.3 \
Net::OAuth::AccessTokenRequest.3 \
Net::OAuth::AccessTokenResponse.3 \
+ Net::OAuth::Client.3 \
Net::OAuth::ConsumerRequest.3 \
Net::OAuth::Message.3 \
Net::OAuth::ProtectedResourceRequest.3 \
@@ -35,6 +36,7 @@ MAN3= Net::OAuth.3 \
Net::OAuth::RequestTokenResponse.3 \
Net::OAuth::Response.3 \
Net::OAuth::SignatureMethod::HMAC_SHA1.3 \
+ Net::OAuth::SignatureMethod::HMAC_SHA256.3 \
Net::OAuth::SignatureMethod::PLAINTEXT.3 \
Net::OAuth::SignatureMethod::RSA_SHA1.3 \
Net::OAuth::UserAuthRequest.3 \
diff --git a/net/p5-Net-OAuth/distinfo b/net/p5-Net-OAuth/distinfo
index b19ae078c77f..c90bc106dd06 100644
--- a/net/p5-Net-OAuth/distinfo
+++ b/net/p5-Net-OAuth/distinfo
@@ -1,2 +1,2 @@
-SHA256 (Net-OAuth-0.27.tar.gz) = eab8d43c12b5891f9ec1f70f5aa1783a017eb68a36b16732d50bfe13e08000e4
-SIZE (Net-OAuth-0.27.tar.gz) = 39113
+SHA256 (Net-OAuth-0.28.tar.gz) = 7bfc319da0ac578e00962f35a350cf51110a3a313016d1fdc30722028a22904c
+SIZE (Net-OAuth-0.28.tar.gz) = 29063
diff --git a/net/p5-Net-OAuth/pkg-plist b/net/p5-Net-OAuth/pkg-plist
index 82497b1aa42f..4bc8eaf2fb8a 100644
--- a/net/p5-Net-OAuth/pkg-plist
+++ b/net/p5-Net-OAuth/pkg-plist
@@ -1,6 +1,8 @@
%%SITE_PERL%%/Net/OAuth.pm
+%%SITE_PERL%%/Net/OAuth/AccessToken.pm
%%SITE_PERL%%/Net/OAuth/AccessTokenRequest.pm
%%SITE_PERL%%/Net/OAuth/AccessTokenResponse.pm
+%%SITE_PERL%%/Net/OAuth/Client.pm
%%SITE_PERL%%/Net/OAuth/ConsumerRequest.pm
%%SITE_PERL%%/Net/OAuth/Message.pm
%%SITE_PERL%%/Net/OAuth/ProtectedResourceRequest.pm
@@ -9,6 +11,7 @@
%%SITE_PERL%%/Net/OAuth/RequestTokenResponse.pm
%%SITE_PERL%%/Net/OAuth/Response.pm
%%SITE_PERL%%/Net/OAuth/SignatureMethod/HMAC_SHA1.pm
+%%SITE_PERL%%/Net/OAuth/SignatureMethod/HMAC_SHA256.pm
%%SITE_PERL%%/Net/OAuth/SignatureMethod/PLAINTEXT.pm
%%SITE_PERL%%/Net/OAuth/SignatureMethod/RSA_SHA1.pm
%%SITE_PERL%%/Net/OAuth/UserAuthRequest.pm