aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-Ping-External
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-03-10 16:35:24 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-03-10 16:35:24 +0000
commit9c0586294fea292acc9415e26e02c8e02a26ba3a (patch)
treea64e5f1b62f529af35333a42d2bbc9096dc5b40a /net/p5-Net-Ping-External
parent6a5b943ba085c86fe389d42f495d79a4a1e4fac9 (diff)
downloadports-9c0586294fea292acc9415e26e02c8e02a26ba3a.tar.gz
ports-9c0586294fea292acc9415e26e02c8e02a26ba3a.zip
Notes
Diffstat (limited to 'net/p5-Net-Ping-External')
-rw-r--r--net/p5-Net-Ping-External/Makefile22
-rw-r--r--net/p5-Net-Ping-External/distinfo2
-rw-r--r--net/p5-Net-Ping-External/pkg-descr12
-rw-r--r--net/p5-Net-Ping-External/pkg-plist7
4 files changed, 43 insertions, 0 deletions
diff --git a/net/p5-Net-Ping-External/Makefile b/net/p5-Net-Ping-External/Makefile
new file mode 100644
index 000000000000..52ed47d70beb
--- /dev/null
+++ b/net/p5-Net-Ping-External/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-Net-Ping-External
+# Date created: March 5th 2004
+# Whom: Douglas Thrift <douglas@douglasthrift.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-Ping-External
+PORTVERSION= 0.11
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= douglas@douglasthrift.net
+COMMENT= Perl cross-platform interface to ICMP "ping" utilities
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::Ping::External.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-Ping-External/distinfo b/net/p5-Net-Ping-External/distinfo
new file mode 100644
index 000000000000..458d94cd0033
--- /dev/null
+++ b/net/p5-Net-Ping-External/distinfo
@@ -0,0 +1,2 @@
+MD5 (Net-Ping-External-0.11.tar.gz) = de9fd436c6749e1a2330eae4aae856fb
+SIZE (Net-Ping-External-0.11.tar.gz) = 6377
diff --git a/net/p5-Net-Ping-External/pkg-descr b/net/p5-Net-Ping-External/pkg-descr
new file mode 100644
index 000000000000..dac919016bb7
--- /dev/null
+++ b/net/p5-Net-Ping-External/pkg-descr
@@ -0,0 +1,12 @@
+Net::Ping::External is a module which interfaces with the "ping"
+command on many systems. It presently provides a single function,
+ping(), that takes in a hostname and (optionally) a timeout and
+returns true if the host is alive, and false otherwise. Unless you
+have the ability (and willingness) to run your scripts as the
+superuser on your system, this module will probably provide more
+accurate results than Net::Ping will.
+
+WWW: http://search.cpan.org/dist/Net-Ping-External/
+
+- Douglas Thrift
+douglas@douglasthrift.net
diff --git a/net/p5-Net-Ping-External/pkg-plist b/net/p5-Net-Ping-External/pkg-plist
new file mode 100644
index 000000000000..70ef9a15c95c
--- /dev/null
+++ b/net/p5-Net-Ping-External/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Net/Ping/External.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Ping/External/.packlist
+@unexec rmdir %D/%%SITE_PERL%%/Net/Ping 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Net 2>/dev/null || true
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Ping/External
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Ping 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net 2>/dev/null || true