aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-RabbitFoot
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-08-07 13:34:49 +0000
committerJohn Marino <marino@FreeBSD.org>2014-08-07 13:34:49 +0000
commit68c3f4e0bcd7d2c4dbf70af64f8b9b202facdf14 (patch)
treeed423e57375d0e8a8e825c17fec9012c36261ddd /net/p5-Net-RabbitFoot
parentc0395d57f7dfa51fdb766d85754d18e4b54cdc51 (diff)
downloadports-68c3f4e0bcd7d2c4dbf70af64f8b9b202facdf14.tar.gz
ports-68c3f4e0bcd7d2c4dbf70af64f8b9b202facdf14.zip
Add new port net/p5-Net-RabbitFoot
PR: 191713 Submitted by: Bill Brinzer ================================================================ Net::RabbitFoot is an AMQP(Advanced Message Queuing Protocol) client library, that is intended to allow you to interact with AMQP-compliant message brokers/servers such as RabbitMQ in an asynchronous fashion.
Notes
Notes: svn path=/head/; revision=364271
Diffstat (limited to 'net/p5-Net-RabbitFoot')
-rw-r--r--net/p5-Net-RabbitFoot/Makefile33
-rw-r--r--net/p5-Net-RabbitFoot/distinfo2
-rw-r--r--net/p5-Net-RabbitFoot/pkg-descr16
-rw-r--r--net/p5-Net-RabbitFoot/pkg-plist23
4 files changed, 74 insertions, 0 deletions
diff --git a/net/p5-Net-RabbitFoot/Makefile b/net/p5-Net-RabbitFoot/Makefile
new file mode 100644
index 000000000000..cf2e3a9a15f4
--- /dev/null
+++ b/net/p5-Net-RabbitFoot/Makefile
@@ -0,0 +1,33 @@
+# $FreeBSD$
+
+PORTNAME= Net-RabbitFoot
+PORTVERSION= 1.03
+CATEGORIES= net devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:IKUTA
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= bill.brinzer@gmail.com
+COMMENT= Synchronous interface to AnyEvent::RabbitMQ
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-AnyEvent-RabbitMQ>=0:${PORTSDIR}/net/p5-AnyEvent-RabbitMQ \
+ p5-Config-Any>=0:${PORTSDIR}/devel/p5-Config-Any \
+ p5-Coro>=0:${PORTSDIR}/devel/p5-Coro \
+ p5-JSON-XS>=0:${PORTSDIR}/converters/p5-JSON-XS \
+ p5-List-MoreUtils>=0:${PORTSDIR}/lang/p5-List-MoreUtils \
+ p5-Moose>=0:${PORTSDIR}/devel/p5-Moose \
+ p5-MooseX-App-Cmd>=0:${PORTSDIR}/devel/p5-MooseX-App-Cmd \
+ p5-MooseX-AttributeHelpers>=0:${PORTSDIR}/devel/p5-MooseX-AttributeHelpers \
+ p5-MooseX-ConfigFromFile>=0:${PORTSDIR}/devel/p5-MooseX-ConfigFromFile
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+TEST_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception
+
+NO_ARCH= yes
+
+USES= perl5
+USE_PERL5= configure
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-RabbitFoot/distinfo b/net/p5-Net-RabbitFoot/distinfo
new file mode 100644
index 000000000000..7e65b0131057
--- /dev/null
+++ b/net/p5-Net-RabbitFoot/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Net-RabbitFoot-1.03.tar.gz) = 0544b1914e7847b32b60a643abc6f0b1fdc6d4a816afd84bcd3eee0c28b001ac
+SIZE (Net-RabbitFoot-1.03.tar.gz) = 58368
diff --git a/net/p5-Net-RabbitFoot/pkg-descr b/net/p5-Net-RabbitFoot/pkg-descr
new file mode 100644
index 000000000000..b88729a49188
--- /dev/null
+++ b/net/p5-Net-RabbitFoot/pkg-descr
@@ -0,0 +1,16 @@
+Net::RabbitFoot is an AMQP(Advanced Message Queuing Protocol) client library,
+that is intended to allow you to interact with AMQP-compliant message
+brokers/servers such as RabbitMQ in an asynchronous fashion.
+
+You can use Net::RabbitFoot to -
+
+ * Declare and delete exchanges
+ * Declare, delete, bind and unbind queues
+ * Set QoS
+ * Publish, consume, get, ack, recover and reject messages
+ * Select, commit and rollback transactions
+
+Net::RabbitFoot is known to work with RabbitMQ versions 2.4.0 and version 0-8
+of the AMQP specification.
+
+WWW: http://search.cpan.org/dist/Net-RabbitFoot/
diff --git a/net/p5-Net-RabbitFoot/pkg-plist b/net/p5-Net-RabbitFoot/pkg-plist
new file mode 100644
index 000000000000..8cab874b22fb
--- /dev/null
+++ b/net/p5-Net-RabbitFoot/pkg-plist
@@ -0,0 +1,23 @@
+bin/rabbit_foot
+%%PERL5_MAN3%%/Net::RabbitFoot.3.gz
+%%SITE_PERL%%/Net/RabbitFoot.pm
+%%SITE_PERL%%/Net/RabbitFoot/Channel.pm
+%%SITE_PERL%%/Net/RabbitFoot/Cmd.pm
+%%SITE_PERL%%/Net/RabbitFoot/Cmd/Command/bind_queue.pm
+%%SITE_PERL%%/Net/RabbitFoot/Cmd/Command/declare_exchange.pm
+%%SITE_PERL%%/Net/RabbitFoot/Cmd/Command/declare_queue.pm
+%%SITE_PERL%%/Net/RabbitFoot/Cmd/Command/delete_exchange.pm
+%%SITE_PERL%%/Net/RabbitFoot/Cmd/Command/delete_queue.pm
+%%SITE_PERL%%/Net/RabbitFoot/Cmd/Command/purge_queue.pm
+%%SITE_PERL%%/Net/RabbitFoot/Cmd/Command/unbind_queue.pm
+%%SITE_PERL%%/Net/RabbitFoot/Cmd/Role/Command.pm
+%%SITE_PERL%%/Net/RabbitFoot/Cmd/Role/Config.pm
+%%SITE_PERL%%/auto/share/dist/Net-RabbitFoot/fixed_amqp0-8.xml
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/RabbitFoot/.packlist
+@dirrmtry %%SITE_PERL%%/Net/RabbitFoot/Cmd/Command
+@dirrmtry %%SITE_PERL%%/Net/RabbitFoot/Cmd/Role
+@dirrmtry %%SITE_PERL%%/Net/RabbitFoot/Cmd
+@dirrmtry %%SITE_PERL%%/Net/RabbitFoot
+@dirrmtry %%SITE_PERL%%/auto/share/dist/Net-RabbitFoot
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/RabbitFoot
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net