aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-Radius
diff options
context:
space:
mode:
authorKelly Yancey <kbyanc@FreeBSD.org>2002-03-21 19:07:46 +0000
committerKelly Yancey <kbyanc@FreeBSD.org>2002-03-21 19:07:46 +0000
commitb2ebebbc74316fd2458539dd97a713ffe9e97e46 (patch)
tree59e49728e3925336446b1c8663b32bd0532ed742 /net/p5-Net-Radius
parent117701e45dcf000aaf3b684ba9ce0a203276870b (diff)
downloadports-b2ebebbc74316fd2458539dd97a713ffe9e97e46.tar.gz
ports-b2ebebbc74316fd2458539dd97a713ffe9e97e46.zip
Add p5-Net-Radius: A perl module to manipulate RADIUS packets
Notes
Notes: svn path=/head/; revision=56425
Diffstat (limited to 'net/p5-Net-Radius')
-rw-r--r--net/p5-Net-Radius/Makefile27
-rw-r--r--net/p5-Net-Radius/distinfo1
-rw-r--r--net/p5-Net-Radius/pkg-comment1
-rw-r--r--net/p5-Net-Radius/pkg-descr12
-rw-r--r--net/p5-Net-Radius/pkg-plist8
5 files changed, 49 insertions, 0 deletions
diff --git a/net/p5-Net-Radius/Makefile b/net/p5-Net-Radius/Makefile
new file mode 100644
index 000000000000..8429becfc811
--- /dev/null
+++ b/net/p5-Net-Radius/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-Net-Radius
+# Date created: 20 Mar 2002
+# Whom: Kelly Yancey <kbyanc@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-Radius
+PORTVERSION= 1.43
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kbyanc@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+MAN3= Net::Radius::Dictionary.3 Net::Radius::Packet.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+post-extract:
+ find ${WRKDIR} -type f | xargs perl -pi -e "s:\r::g"
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-Radius/distinfo b/net/p5-Net-Radius/distinfo
new file mode 100644
index 000000000000..1a844f034c17
--- /dev/null
+++ b/net/p5-Net-Radius/distinfo
@@ -0,0 +1 @@
+MD5 (Net-Radius-1.43.tar.gz) = 716b56daf51cda0ca0d3f184ae8d3f24
diff --git a/net/p5-Net-Radius/pkg-comment b/net/p5-Net-Radius/pkg-comment
new file mode 100644
index 000000000000..1fc9eda7a727
--- /dev/null
+++ b/net/p5-Net-Radius/pkg-comment
@@ -0,0 +1 @@
+A perl module to manipulate RADIUS packets
diff --git a/net/p5-Net-Radius/pkg-descr b/net/p5-Net-Radius/pkg-descr
new file mode 100644
index 000000000000..d45d3f51dc86
--- /dev/null
+++ b/net/p5-Net-Radius/pkg-descr
@@ -0,0 +1,12 @@
+The modules included here provide an interface to the RADIUS
+protocol. It consists of the following modules:
+
+Net::Radius::Packet - Deals with RADIUS packets
+Net::Radius::Dictionary - Deals with RADIUS dictionaries
+
+This module is essentially the original RADIUS-1.0 distribution by
+Christopher Masto plus a number of changes and fixes by Luis Munoz and
+Ian Smith.
+
+ -Kelly
+ kbyanc@posi.net
diff --git a/net/p5-Net-Radius/pkg-plist b/net/p5-Net-Radius/pkg-plist
new file mode 100644
index 000000000000..3ffb5da26ba6
--- /dev/null
+++ b/net/p5-Net-Radius/pkg-plist
@@ -0,0 +1,8 @@
+lib/perl5/site_perl/%%PERL_VER%%/Net/Radius/Dictionary.pm
+lib/perl5/site_perl/%%PERL_VER%%/Net/Radius/Packet.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/Radius/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Net/Radius
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/Radius
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Net 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net 2>/dev/null || true
+