aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-SPDY
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-08-17 19:38:30 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-08-17 19:38:30 +0000
commit4f98e75a7d6eefcdfafc68e16c051c52fc8f48e2 (patch)
tree06187ffe64abd0daa571450a89f6f58eb731bcac /net/p5-Net-SPDY
parentebd71b456c6b0cc29ad84e5063839afa1339a30a (diff)
downloadports-4f98e75a7d6eefcdfafc68e16c051c52fc8f48e2.tar.gz
ports-4f98e75a7d6eefcdfafc68e16c051c52fc8f48e2.zip
- Add p5-Net-SPDY 0.1_5
Net::SPDY distribution contains implementation of SPDY protocol. You probably want to use Net::SPDY::Session to implement SPDY clients and servers. WWW: http://search.cpan.org/dist/Net-SPDY/
Notes
Notes: svn path=/head/; revision=365231
Diffstat (limited to 'net/p5-Net-SPDY')
-rw-r--r--net/p5-Net-SPDY/Makefile27
-rw-r--r--net/p5-Net-SPDY/distinfo2
-rw-r--r--net/p5-Net-SPDY/pkg-descr4
-rw-r--r--net/p5-Net-SPDY/pkg-plist14
4 files changed, 47 insertions, 0 deletions
diff --git a/net/p5-Net-SPDY/Makefile b/net/p5-Net-SPDY/Makefile
new file mode 100644
index 000000000000..b0630b11d8dd
--- /dev/null
+++ b/net/p5-Net-SPDY/Makefile
@@ -0,0 +1,27 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Net-SPDY
+PORTVERSION= 0.1
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:LKUNDRAK
+PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-${PORTVERSION}_5
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= SPDY protocol client and server implementation
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-IO-Socket-SSL>=0:${PORTSDIR}/security/p5-IO-Socket-SSL \
+ p5-URI>=0:${PORTSDIR}/net/p5-URI
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+TEST_DEPENDS= p5-Test-Deep>=0:${PORTSDIR}/devel/p5-Test-Deep \
+ p5-Test-Pod>=0:${PORTSDIR}/devel/p5-Test-Pod
+
+USE_PERL5= modbuild
+USES= perl5
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-SPDY/distinfo b/net/p5-Net-SPDY/distinfo
new file mode 100644
index 000000000000..6a8e6d9b4502
--- /dev/null
+++ b/net/p5-Net-SPDY/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Net-SPDY-0.1_5.tar.gz) = e084c25f0231cb8227951bfb10614d0ed4dbc55cc2250f697ba4bb72eeabe1ed
+SIZE (Net-SPDY-0.1_5.tar.gz) = 19351
diff --git a/net/p5-Net-SPDY/pkg-descr b/net/p5-Net-SPDY/pkg-descr
new file mode 100644
index 000000000000..191a08f4060d
--- /dev/null
+++ b/net/p5-Net-SPDY/pkg-descr
@@ -0,0 +1,4 @@
+Net::SPDY distribution contains implementation of SPDY protocol. You probably
+want to use Net::SPDY::Session to implement SPDY clients and servers.
+
+WWW: http://search.cpan.org/dist/Net-SPDY/
diff --git a/net/p5-Net-SPDY/pkg-plist b/net/p5-Net-SPDY/pkg-plist
new file mode 100644
index 000000000000..0dbfa9eaf078
--- /dev/null
+++ b/net/p5-Net-SPDY/pkg-plist
@@ -0,0 +1,14 @@
+bin/spdy-client.pl
+bin/spdy-server.pl
+%%SITE_PERL%%/Net/SPDY.pod
+%%SITE_PERL%%/Net/SPDY/Compressor.pm
+%%SITE_PERL%%/Net/SPDY/Framer.pm
+%%SITE_PERL%%/Net/SPDY/Session.pm
+%%PERL5_MAN3%%/Net::SPDY.3.gz
+%%PERL5_MAN3%%/Net::SPDY::Compressor.3.gz
+%%PERL5_MAN3%%/Net::SPDY::Framer.3.gz
+%%PERL5_MAN3%%/Net::SPDY::Session.3.gz
+man/man1/spdy-client.pl.1.gz
+man/man1/spdy-server.pl.1.gz
+@dirrm %%SITE_PERL%%/Net/SPDY
+@dirrmtry %%SITE_PERL%%/Net