aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-STOMP-Client
diff options
context:
space:
mode:
authorTom Judge <tj@FreeBSD.org>2013-02-04 14:50:30 +0000
committerTom Judge <tj@FreeBSD.org>2013-02-04 14:50:30 +0000
commit02a9955c442cc252c31fb063a31d5954c10fba67 (patch)
tree6d95d53a5bcf2fedd550a0222294f3c6cae387d2 /net/p5-Net-STOMP-Client
parent38186e4055362c68bd3ebd2faba6c039df3be834 (diff)
downloadports-02a9955c442cc252c31fb063a31d5954c10fba67.tar.gz
ports-02a9955c442cc252c31fb063a31d5954c10fba67.zip
Update to 2.0.
Changes: * Major code refactoring, see README.2.x for more information. * Cleanup code to please Perl::Critic. * Removed support for blocking I/O, only non-blocking I/O is supported. * Now using the No::Worries and Params::Validate modules from CPAN. * Added STOMP 1.2 support. * Added the queue_message() and send_message() methods for convenience. * Added optional authentication support via Authen::Credential.
Notes
Notes: svn path=/head/; revision=311625
Diffstat (limited to 'net/p5-Net-STOMP-Client')
-rw-r--r--net/p5-Net-STOMP-Client/Makefile16
-rw-r--r--net/p5-Net-STOMP-Client/distinfo4
-rw-r--r--net/p5-Net-STOMP-Client/pkg-plist8
3 files changed, 16 insertions, 12 deletions
diff --git a/net/p5-Net-STOMP-Client/Makefile b/net/p5-Net-STOMP-Client/Makefile
index c5cef4eb0f6c..6221d9c7aa6a 100644
--- a/net/p5-Net-STOMP-Client/Makefile
+++ b/net/p5-Net-STOMP-Client/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= Net-STOMP-Client
-PORTVERSION= 1.8
+PORTVERSION= 2.0
CATEGORIES= net perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -9,20 +9,24 @@ PKGNAMEPREFIX= p5-
MAINTAINER= tj@FreeBSD.org
COMMENT= Streaming Text Orientated Messaging Protocol Client
+BUILD_DEPENDS= p5-No-Worries>=0:${PORTSDIR}/devel/p5-No-Worries \
+ p5-Params-Validate>=0:${PORTSDIR}/devel/p5-Params-Validate
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
PERL_CONFIGURE= yes
MAN3= Net::STOMP::Client.3 \
+ Net::STOMP::Client::Auth.3 \
Net::STOMP::Client::Connection.3 \
- Net::STOMP::Client::Debug.3 \
- Net::STOMP::Client::Error.3 \
Net::STOMP::Client::Frame.3 \
+ Net::STOMP::Client::HeartBeat.3 \
Net::STOMP::Client::IO.3 \
- Net::STOMP::Client::OO.3 \
Net::STOMP::Client::Peer.3 \
- Net::STOMP::Client::Protocol.3 \
- Net::STOMP::Client::Tutorial.3
+ Net::STOMP::Client::Receipt.3 \
+ Net::STOMP::Client::Tutorial.3 \
+ Net::STOMP::Client::Version.3
.include <bsd.port.mk>
diff --git a/net/p5-Net-STOMP-Client/distinfo b/net/p5-Net-STOMP-Client/distinfo
index cd76c8d3713f..8c9fec2e2f15 100644
--- a/net/p5-Net-STOMP-Client/distinfo
+++ b/net/p5-Net-STOMP-Client/distinfo
@@ -1,2 +1,2 @@
-SHA256 (Net-STOMP-Client-1.8.tar.gz) = 77f079523df519f8b2eb8f3105984d34f134e7bbe6a76fdceb5e0c2fb1ca9b14
-SIZE (Net-STOMP-Client-1.8.tar.gz) = 39354
+SHA256 (Net-STOMP-Client-2.0.tar.gz) = 666b687269414c6b0b0bc864d14028fc751dc9d950674d383f00cec5bd3cac19
+SIZE (Net-STOMP-Client-2.0.tar.gz) = 40958
diff --git a/net/p5-Net-STOMP-Client/pkg-plist b/net/p5-Net-STOMP-Client/pkg-plist
index e6665fdf0ab1..08d53fd108b8 100644
--- a/net/p5-Net-STOMP-Client/pkg-plist
+++ b/net/p5-Net-STOMP-Client/pkg-plist
@@ -1,13 +1,13 @@
%%SITE_PERL%%/Net/STOMP/Client.pm
+%%SITE_PERL%%/Net/STOMP/Client/Auth.pm
%%SITE_PERL%%/Net/STOMP/Client/Connection.pm
-%%SITE_PERL%%/Net/STOMP/Client/Debug.pm
-%%SITE_PERL%%/Net/STOMP/Client/Error.pm
%%SITE_PERL%%/Net/STOMP/Client/Frame.pm
+%%SITE_PERL%%/Net/STOMP/Client/HeartBeat.pm
%%SITE_PERL%%/Net/STOMP/Client/IO.pm
-%%SITE_PERL%%/Net/STOMP/Client/OO.pm
%%SITE_PERL%%/Net/STOMP/Client/Peer.pm
-%%SITE_PERL%%/Net/STOMP/Client/Protocol.pm
+%%SITE_PERL%%/Net/STOMP/Client/Receipt.pm
%%SITE_PERL%%/Net/STOMP/Client/Tutorial.pod
+%%SITE_PERL%%/Net/STOMP/Client/Version.pm
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/STOMP/Client/.packlist
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/STOMP/Client
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/STOMP