aboutsummaryrefslogtreecommitdiff
path: root/net/p5-POE-Component-Client-Ping
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-12-13 12:20:18 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-12-13 12:20:18 +0000
commit22105a2897ab4af01dfa98dbd97852dd7a93d286 (patch)
tree33e95bb6c0d38d6a7d208b7b727fd5474949ed26 /net/p5-POE-Component-Client-Ping
parentf26dbde6d1d17e54a07ab3b556ede8d5eb980822 (diff)
downloadports-22105a2897ab4af01dfa98dbd97852dd7a93d286.tar.gz
ports-22105a2897ab4af01dfa98dbd97852dd7a93d286.zip
add p5-POE-Component-Client-Ping
POE component for non-blocking/concurrent ICMP ping PR: 32781 Submitted by: Sergey Skvortsov <skv@protey.ru>
Notes
Notes: svn path=/head/; revision=51486
Diffstat (limited to 'net/p5-POE-Component-Client-Ping')
-rw-r--r--net/p5-POE-Component-Client-Ping/Makefile27
-rw-r--r--net/p5-POE-Component-Client-Ping/distinfo1
-rw-r--r--net/p5-POE-Component-Client-Ping/pkg-comment1
-rw-r--r--net/p5-POE-Component-Client-Ping/pkg-descr8
-rw-r--r--net/p5-POE-Component-Client-Ping/pkg-plist9
5 files changed, 46 insertions, 0 deletions
diff --git a/net/p5-POE-Component-Client-Ping/Makefile b/net/p5-POE-Component-Client-Ping/Makefile
new file mode 100644
index 000000000000..a7f7ad90c8fd
--- /dev/null
+++ b/net/p5-POE-Component-Client-Ping/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: POE-Component-Client-Ping
+# Date created: 10 Dec 2001
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= POE-Component-Client-Ping
+PORTVERSION= 0.95
+CATEGORIES= devel perl5 net
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN} \
+ http://poe.perl.org/poedown/
+MASTER_SITE_SUBDIR= POE
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@protey.ru
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/POE.pm:${PORTSDIR}/devel/p5-POE \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= POE::Component::Client::Ping.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-POE-Component-Client-Ping/distinfo b/net/p5-POE-Component-Client-Ping/distinfo
new file mode 100644
index 000000000000..2bcb129a3cad
--- /dev/null
+++ b/net/p5-POE-Component-Client-Ping/distinfo
@@ -0,0 +1 @@
+MD5 (POE-Component-Client-Ping-0.95.tar.gz) = f4fbbcd7aa6789fc237ccd70c334b468
diff --git a/net/p5-POE-Component-Client-Ping/pkg-comment b/net/p5-POE-Component-Client-Ping/pkg-comment
new file mode 100644
index 000000000000..6052ea27986b
--- /dev/null
+++ b/net/p5-POE-Component-Client-Ping/pkg-comment
@@ -0,0 +1 @@
+POE component for non-blocking/concurrent ICMP ping
diff --git a/net/p5-POE-Component-Client-Ping/pkg-descr b/net/p5-POE-Component-Client-Ping/pkg-descr
new file mode 100644
index 000000000000..998abd88c7be
--- /dev/null
+++ b/net/p5-POE-Component-Client-Ping/pkg-descr
@@ -0,0 +1,8 @@
+POE::Component::Client::Ping is non-blocking ICMP ping client session.
+It lets several other sessions ping through it in parallel, and it
+lets them continue doing other things while they wait for responses.
+
+WWW: http://search.cpan.org/search?dist=POE-Component-Client-Ping
+
+-- Sergey Skvortsov
+skv@protey.ru
diff --git a/net/p5-POE-Component-Client-Ping/pkg-plist b/net/p5-POE-Component-Client-Ping/pkg-plist
new file mode 100644
index 000000000000..28382d2073f1
--- /dev/null
+++ b/net/p5-POE-Component-Client-Ping/pkg-plist
@@ -0,0 +1,9 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/POE/Component/Client/Ping/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/POE/Component/Client/Ping.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/POE/Component/Client/Ping
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/POE/Component/Client 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/POE/Component 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/POE 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/POE/Component/Client 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/POE/Component 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/POE 2>/dev/null || true