aboutsummaryrefslogtreecommitdiff
path: root/net/p5-POE-Component-Client-Twitter
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2008-04-14 00:26:21 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2008-04-14 00:26:21 +0000
commitaa3c7864e12813a31571eecb2b7fe86be8ec5083 (patch)
tree720d6431c0762e527955b661b39ea2b22978c72c /net/p5-POE-Component-Client-Twitter
parent22e5d827b5524afd1b4c9522e851f4816db7c4ab (diff)
downloadports-aa3c7864e12813a31571eecb2b7fe86be8ec5083.tar.gz
ports-aa3c7864e12813a31571eecb2b7fe86be8ec5083.zip
POE::Component::Client::Twitter is a POE component for Twitter API.
WWW: http://search.cpan.org/dist/POE-Component-Client-Twitter/ PR: ports/122716 Submitted by: Masahiro Teramoto <markun at onohara.to>
Notes
Notes: svn path=/head/; revision=211200
Diffstat (limited to 'net/p5-POE-Component-Client-Twitter')
-rw-r--r--net/p5-POE-Component-Client-Twitter/Makefile29
-rw-r--r--net/p5-POE-Component-Client-Twitter/distinfo3
-rw-r--r--net/p5-POE-Component-Client-Twitter/pkg-descr3
-rw-r--r--net/p5-POE-Component-Client-Twitter/pkg-plist10
4 files changed, 45 insertions, 0 deletions
diff --git a/net/p5-POE-Component-Client-Twitter/Makefile b/net/p5-POE-Component-Client-Twitter/Makefile
new file mode 100644
index 000000000000..7d164581c1f6
--- /dev/null
+++ b/net/p5-POE-Component-Client-Twitter/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: p5-POE-Component-Client-Twitter
+# Date created: 2008-04-13
+# Whom: Masahiro Teramoto <markun@onohara.to>
+#
+# $FreeBSD$
+#
+
+PORTNAME= POE-Component-Client-Twitter
+PORTVERSION= 0.01
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= markun@onohara.to
+COMMENT= POE chat component for twitter.com
+
+BUILD_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
+ p5-JSON-Any>=0:${PORTSDIR}/converters/p5-JSON-Any \
+ p5-POE>=0:${PORTSDIR}/devel/p5-POE \
+ p5-POE-Component-Client-HTTP>=0:${PORTSDIR}/www/p5-POE-Component-Client-HTTP \
+ p5-URI>=0:${PORTSDIR}/net/p5-URI \
+ p5-Module-Install>=0:${PORTSDIR}/devel/p5-Module-Install
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= POE::Component::Client::Twitter.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-POE-Component-Client-Twitter/distinfo b/net/p5-POE-Component-Client-Twitter/distinfo
new file mode 100644
index 000000000000..36bd8d4c7da0
--- /dev/null
+++ b/net/p5-POE-Component-Client-Twitter/distinfo
@@ -0,0 +1,3 @@
+MD5 (POE-Component-Client-Twitter-0.01.tar.gz) = 8340152a6f9d05b2d6263eda60dee863
+SHA256 (POE-Component-Client-Twitter-0.01.tar.gz) = 224095e81a44563fe5ca4bc6a210609190006179f662d8c15a130532840581cd
+SIZE (POE-Component-Client-Twitter-0.01.tar.gz) = 4522
diff --git a/net/p5-POE-Component-Client-Twitter/pkg-descr b/net/p5-POE-Component-Client-Twitter/pkg-descr
new file mode 100644
index 000000000000..3dd2d16cfcd1
--- /dev/null
+++ b/net/p5-POE-Component-Client-Twitter/pkg-descr
@@ -0,0 +1,3 @@
+POE::Component::Client::Twitter is a POE component for Twitter API.
+
+WWW: http://search.cpan.org/dist/POE-Component-Client-Twitter/
diff --git a/net/p5-POE-Component-Client-Twitter/pkg-plist b/net/p5-POE-Component-Client-Twitter/pkg-plist
new file mode 100644
index 000000000000..5bf969777013
--- /dev/null
+++ b/net/p5-POE-Component-Client-Twitter/pkg-plist
@@ -0,0 +1,10 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/Client/Twitter/.packlist
+%%SITE_PERL%%/POE/Component/Client/Twitter.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/Client/Twitter
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/Client
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE
+@dirrmtry %%SITE_PERL%%/POE/Component/Client
+@dirrmtry %%SITE_PERL%%/POE/Component
+@dirrmtry %%SITE_PERL%%/POE