aboutsummaryrefslogtreecommitdiff
path: root/net/p5-POE-Component-ControlPort/Makefile
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2006-04-25 16:26:37 +0000
committerErwin Lansing <erwin@FreeBSD.org>2006-04-25 16:26:37 +0000
commit0c5d328635f50d626ce1de6fa63c6bfe58e6d6ba (patch)
treeb491a2941c327fee743f02726bc7a8b97eda7bfb /net/p5-POE-Component-ControlPort/Makefile
parentf5581f9e51c1461444ce7f5ccd8fbdb9f411ac8b (diff)
downloadports-0c5d328635f50d626ce1de6fa63c6bfe58e6d6ba.tar.gz
ports-0c5d328635f50d626ce1de6fa63c6bfe58e6d6ba.zip
Notes
Diffstat (limited to 'net/p5-POE-Component-ControlPort/Makefile')
-rw-r--r--net/p5-POE-Component-ControlPort/Makefile15
1 files changed, 12 insertions, 3 deletions
diff --git a/net/p5-POE-Component-ControlPort/Makefile b/net/p5-POE-Component-ControlPort/Makefile
index ac3938bd881a..49af4117b5a2 100644
--- a/net/p5-POE-Component-ControlPort/Makefile
+++ b/net/p5-POE-Component-ControlPort/Makefile
@@ -15,10 +15,11 @@ PKGNAMEPREFIX= p5-
MAINTAINER= hideo@lastamericanempire.com
COMMENT= Network control port for POE applications
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Params/Validate.pm:${PORTSDIR}/devel/p5-Params-Validate \
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Params/Validate.pm:${PORTSDIR}/devel/p5-Params-Validate \
${SITE_PERL}/${PERL_ARCH}/Authen/Libwrap.pm:${PORTSDIR}/security/p5-Authen-Libwrap \
${SITE_PERL}/POE.pm:${PORTSDIR}/devel/p5-POE
-RUN_DEPENDS= ${BUILD_DEPENDS}
+BUILD_DEPENDS= ${RUN_DEPENDS}
+BUILD_DEPENDS+= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
PERL_CONFIGURE= yes
@@ -29,16 +30,24 @@ MAN3= POE::Component::ControlPort.3 \
.include <bsd.port.pre.mk>
post-extract:
- @${PERL} -0pi -e 's/my \$$prompt.+(my \$$ret = )(?-s).+/$${1}0;/so' ${WRKSRC}/Makefile.PL
+ @${PERL} -pi -e 's/my \$$ret =.*/my \$$ret = 0;/' ${WRKSRC}/Makefile.PL
.if ${PERL_LEVEL} < 500600
+RUN_DEPENDS+= ${SITE_PERL}/XSLoader.pm:${PORTSDIR}/devel/p5-XSLoader \
+ ${SITE_PERL}/${PERL_ARCH}/File/Spec.pm:${PORTSDIR}/devel/p5-PathTools
+
post-patch:
@${PERL} -pi -e 's/^our (\W\w+);/use vars q($$1);/o;' \
-e 's/^our\s+(\W\w+)(?!;)/use vars q($$1); $$1/o;' \
-e 'undef $$_ if /^\s*(no|use) warnings/o;' \
+ ${WRKSRC}/VERSION \
+ ${WRKSRC}/t/*.t \
${WRKSRC}/lib/POE/Component/ControlPort.pm \
${WRKSRC}/lib/POE/Component/ControlPort/DefaultCommands.pm \
${WRKSRC}/lib/POE/Component/ControlPort/Command.pm
+
+post-configure:
+ ${PERL} -pi -e 's/-I\S+PERL\S+ //g if m{PERL_DL_NONLAZY}' ${WRKSRC}/Makefile
.endif
.include <bsd.port.post.mk>