aboutsummaryrefslogtreecommitdiff
path: root/net/p5-POE-Component-Generic
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-10-02 01:05:33 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-10-02 01:05:33 +0000
commit8075311d778ce48942ebf79a790b22b9fc1575df (patch)
tree3ec48b248095c78589250832a33b718d8d4861df /net/p5-POE-Component-Generic
parent1060cd5ded72502154139070e468638f93e66f59 (diff)
downloadports-8075311d778ce48942ebf79a790b22b9fc1575df.tar.gz
ports-8075311d778ce48942ebf79a790b22b9fc1575df.zip
Add p5-POE-Component-Generic 0.09.05, provides non-blocking access to a
blocking object. PR: ports/102676 Submitted by: Jin-Shan Tseng <tjs at cdpa.nsysu.edu.tw>
Notes
Notes: svn path=/head/; revision=174274
Diffstat (limited to 'net/p5-POE-Component-Generic')
-rw-r--r--net/p5-POE-Component-Generic/Makefile36
-rw-r--r--net/p5-POE-Component-Generic/distinfo3
-rw-r--r--net/p5-POE-Component-Generic/pkg-descr20
-rw-r--r--net/p5-POE-Component-Generic/pkg-plist13
4 files changed, 72 insertions, 0 deletions
diff --git a/net/p5-POE-Component-Generic/Makefile b/net/p5-POE-Component-Generic/Makefile
new file mode 100644
index 000000000000..dda6240f5826
--- /dev/null
+++ b/net/p5-POE-Component-Generic/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: p5-POE-Component-Generic
+# Date created: 2006-08-30
+# Whom: Jin-Shan Tseng <tjs@cdpa.nsysu.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= POE-Component-Generic
+PORTVERSION= 0.09.05
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= POE
+PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-0.0905
+
+MAINTAINER= tjs@cdpa.nsysu.edu.tw
+COMMENT= Provides non-blocking access to a blocking object
+
+RUN_DEPENDS= p5-POE>=0.31:${PORTSDIR}/devel/p5-POE \
+ ${SITE_PERL}/Devel/Symdump.pm:${PORTSDIR}/devel/p5-Devel-Symdump
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= POE::Component::Generic.3 \
+ POE::Component::Generic::Child.3 \
+ POE::Component::Generic::Net::SSH2.3 \
+ POE::Component::Generic::Object.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500702
+IGNORE= requires perl 5.7.2 or later. Install lang/perl5.8 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/p5-POE-Component-Generic/distinfo b/net/p5-POE-Component-Generic/distinfo
new file mode 100644
index 000000000000..296f05303be6
--- /dev/null
+++ b/net/p5-POE-Component-Generic/distinfo
@@ -0,0 +1,3 @@
+MD5 (POE-Component-Generic-0.0905.tar.gz) = 810aa2b7cac002b41891c942fbadd274
+SHA256 (POE-Component-Generic-0.0905.tar.gz) = ec71ac91ddce82ed2f6b1ade4628a89b1c7c6119cba1b728cf50d734cd1f1919
+SIZE (POE-Component-Generic-0.0905.tar.gz) = 31603
diff --git a/net/p5-POE-Component-Generic/pkg-descr b/net/p5-POE-Component-Generic/pkg-descr
new file mode 100644
index 000000000000..43ca62e5d1a5
--- /dev/null
+++ b/net/p5-POE-Component-Generic/pkg-descr
@@ -0,0 +1,20 @@
+POE::Component::Generic is a POE component that provides a
+non-blocking wrapper around any object. It works by forking
+a child process with POE::Wheel::Run and creating the object
+in the child process. Method calls are then serialised and
+sent via STDIN to the child to be handled. Return values are
+posted back to your session via STDOUT. This means that all
+method arguments and return values must survive serialisation.
+If you need to pass coderefs, use "callbacks", "postbacks" or
+"factories".
+
+Method calls are wrapped in eval in the child process so that
+errors may be propagated back to your session. See "OUTPUT".
+
+Output to STDERR in the child, that is from your object, is
+shown only if debug or verbose is set.
+
+STDOUT in the child, that is from your object, is redirected
+to STDERR and will be shown in the same circomstances.
+
+WWW: http://search.cpan.org/dist/POE-Component-Generic/
diff --git a/net/p5-POE-Component-Generic/pkg-plist b/net/p5-POE-Component-Generic/pkg-plist
new file mode 100644
index 000000000000..259a6867ba76
--- /dev/null
+++ b/net/p5-POE-Component-Generic/pkg-plist
@@ -0,0 +1,13 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/POE/Component/Generic/Object.pm
+%%SITE_PERL%%/POE/Component/Generic/Net/SSH2.pm
+%%SITE_PERL%%/POE/Component/Generic/Child.pm
+%%SITE_PERL%%/POE/Component/Generic.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/Generic/.packlist
+@dirrmtry %%SITE_PERL%%/POE/Component/Generic/Net
+@dirrmtry %%SITE_PERL%%/POE/Component/Generic
+@dirrmtry %%SITE_PERL%%/POE/Component
+@dirrmtry %%SITE_PERL%%/POE
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/Generic
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE