aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Rose-URI/Makefile
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2010-11-18 14:02:45 +0000
committerWen Heping <wen@FreeBSD.org>2010-11-18 14:02:45 +0000
commite64dd5e30215e6490c497ebf3c05ee19f62b5893 (patch)
treeb4ea885a827c38fab5c22f1eadf044385325dd9a /net/p5-Rose-URI/Makefile
parent2c89497bf3ca2a91cf5ecff023171ea9078ff4b7 (diff)
downloadports-e64dd5e30215e6490c497ebf3c05ee19f62b5893.tar.gz
ports-e64dd5e30215e6490c497ebf3c05ee19f62b5893.zip
Notes
Diffstat (limited to 'net/p5-Rose-URI/Makefile')
-rw-r--r--net/p5-Rose-URI/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/net/p5-Rose-URI/Makefile b/net/p5-Rose-URI/Makefile
new file mode 100644
index 000000000000..a320b36cd515
--- /dev/null
+++ b/net/p5-Rose-URI/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Rose-URI
+# Date created: 18 Nov, 2010
+# Whom: Wen Heping <wen@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Rose-URI
+PORTVERSION= 1.00
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= Easy and efficient manipulation of URI components
+
+RUN_DEPENDS= p5-Rose-Object>=0.854:${PORTSDIR}/devel/p5-Rose-Object \
+ p5-URI>0:${PORTSDIR}/net/p5-URI
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Rose::URI.3
+
+.include <bsd.port.mk>