aboutsummaryrefslogtreecommitdiff
path: root/net/p5-SOAP-Amazon-S3
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2007-05-01 09:34:29 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2007-05-01 09:34:29 +0000
commitcd6fc604f54a782ded351f9032df18bac7368cf6 (patch)
tree3a020850a47feb9cee98344960f74e7787642e7a /net/p5-SOAP-Amazon-S3
parent42491ef131a0f9550b997365de3bdfc655a5dad9 (diff)
downloadports-cd6fc604f54a782ded351f9032df18bac7368cf6.tar.gz
ports-cd6fc604f54a782ded351f9032df18bac7368cf6.zip
Notes
Diffstat (limited to 'net/p5-SOAP-Amazon-S3')
-rw-r--r--net/p5-SOAP-Amazon-S3/Makefile27
-rw-r--r--net/p5-SOAP-Amazon-S3/distinfo3
-rw-r--r--net/p5-SOAP-Amazon-S3/pkg-descr3
-rw-r--r--net/p5-SOAP-Amazon-S3/pkg-plist8
4 files changed, 41 insertions, 0 deletions
diff --git a/net/p5-SOAP-Amazon-S3/Makefile b/net/p5-SOAP-Amazon-S3/Makefile
new file mode 100644
index 000000000000..969ddf61653f
--- /dev/null
+++ b/net/p5-SOAP-Amazon-S3/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-SOAP-Amazon-S3
+# Date created: 2007-04-30
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= SOAP-Amazon-S3
+PORTVERSION= 0.023
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= SOAP
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= A module for interfacing with Amazon S3 through SOAP
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Time/Piece.pm:${PORTSDIR}/devel/p5-Time-Piece \
+ ${SITE_PERL}/Digest/HMAC_SHA1.pm:${PORTSDIR}/security/p5-Digest-HMAC \
+ ${SITE_PERL}/SOAP/MySOAP.pm:${PORTSDIR}/net/p5-SOAP-MySOAP \
+ ${SITE_PERL}/XML/MyXML.pm:${PORTSDIR}/textproc/p5-XML-MyXML
+
+PERL_CONFIGURE= yes
+
+MAN3= SOAP::Amazon::S3.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-SOAP-Amazon-S3/distinfo b/net/p5-SOAP-Amazon-S3/distinfo
new file mode 100644
index 000000000000..e5e72920a4bd
--- /dev/null
+++ b/net/p5-SOAP-Amazon-S3/distinfo
@@ -0,0 +1,3 @@
+MD5 (SOAP-Amazon-S3-0.023.tar.gz) = afb693f5968ee47c512394a4f26d4439
+SHA256 (SOAP-Amazon-S3-0.023.tar.gz) = 335462d8216981f984283c4b33b4892a8fabbe831d078a99ec126b69380c6b93
+SIZE (SOAP-Amazon-S3-0.023.tar.gz) = 5529
diff --git a/net/p5-SOAP-Amazon-S3/pkg-descr b/net/p5-SOAP-Amazon-S3/pkg-descr
new file mode 100644
index 000000000000..c1320f91ca77
--- /dev/null
+++ b/net/p5-SOAP-Amazon-S3/pkg-descr
@@ -0,0 +1,3 @@
+An object-oriented interface to handle your Amazon S3 storage.
+
+WWW: http://search.cpan.org/dist/SOAP-Amazon-S3/
diff --git a/net/p5-SOAP-Amazon-S3/pkg-plist b/net/p5-SOAP-Amazon-S3/pkg-plist
new file mode 100644
index 000000000000..c90422ddd48d
--- /dev/null
+++ b/net/p5-SOAP-Amazon-S3/pkg-plist
@@ -0,0 +1,8 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/SOAP/Amazon/S3/.packlist
+%%SITE_PERL%%/SOAP/Amazon/S3.pm
+@dirrmtry %%SITE_PERL%%/SOAP/Amazon
+@dirrmtry %%SITE_PERL%%/SOAP
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/SOAP/Amazon/S3
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/SOAP/Amazon
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/SOAP