aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Socket
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2008-05-30 14:12:29 +0000
committerRenato Botelho <garga@FreeBSD.org>2008-05-30 14:12:29 +0000
commite7b7ea1f160a939fce7998e04557f46c2d0e0f53 (patch)
treeb7dd7302a56ea976e7c1e0b6f76ce0aba6be2dd7 /net/p5-Socket
parent6004ca53c56d54e168ba5193df4c172e78569d16 (diff)
downloadports-e7b7ea1f160a939fce7998e04557f46c2d0e0f53.tar.gz
ports-e7b7ea1f160a939fce7998e04557f46c2d0e0f53.zip
This module is just a translation of the C socket.h file. Unlike the old
mechanism of requiring a translated socket.ph file, this uses the h2xs program (see the Perl source distribution) and your native C compiler. This means that it has a far more likely chance of getting the numbers right. This includes all of the commonly used pound-defines like AF_INET, SOCK_STREAM, etc. WWW: http://search.cpan.org/dist/Socket/ PR: ports/124132 Submitted by: BluePex Security Solutions <freebsd-ports at bluepex.com>
Notes
Notes: svn path=/head/; revision=213939
Diffstat (limited to 'net/p5-Socket')
-rw-r--r--net/p5-Socket/Makefile24
-rw-r--r--net/p5-Socket/distinfo3
-rw-r--r--net/p5-Socket/pkg-descr7
-rw-r--r--net/p5-Socket/pkg-plist7
4 files changed, 41 insertions, 0 deletions
diff --git a/net/p5-Socket/Makefile b/net/p5-Socket/Makefile
new file mode 100644
index 000000000000..b03d51241ebb
--- /dev/null
+++ b/net/p5-Socket/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-Socket
+# Date created: 2008-05-30
+# Whom: BluePex Security Solutions <freebsd-ports@bluepex.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Socket
+PORTVERSION= 1.5
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= freebsd-ports@bluepex.com
+COMMENT= Load the C socket.h defines and structure manipulators
+
+PERL_CONFIGURE= yes
+
+MAN3= Socket.3
+
+post-patch:
+ @${REINPLACE_CMD} -e '/MAN3PODS/d' ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.mk>
diff --git a/net/p5-Socket/distinfo b/net/p5-Socket/distinfo
new file mode 100644
index 000000000000..99b528cb51ff
--- /dev/null
+++ b/net/p5-Socket/distinfo
@@ -0,0 +1,3 @@
+MD5 (Socket-1.5.tar.gz) = 5cc739b14a329140f7995e99b91a4e8d
+SHA256 (Socket-1.5.tar.gz) = a64659d8b719dd253414cede1a221f736323db6a70a071c6d066bd5b8034e6a6
+SIZE (Socket-1.5.tar.gz) = 5193
diff --git a/net/p5-Socket/pkg-descr b/net/p5-Socket/pkg-descr
new file mode 100644
index 000000000000..1eb38e83398c
--- /dev/null
+++ b/net/p5-Socket/pkg-descr
@@ -0,0 +1,7 @@
+This module is just a translation of the C socket.h file. Unlike the old
+mechanism of requiring a translated socket.ph file, this uses the h2xs program
+(see the Perl source distribution) and your native C compiler. This means
+that it has a far more likely chance of getting the numbers right. This includes
+all of the commonly used pound-defines like AF_INET, SOCK_STREAM, etc.
+
+WWW: http://search.cpan.org/dist/Socket/
diff --git a/net/p5-Socket/pkg-plist b/net/p5-Socket/pkg-plist
new file mode 100644
index 000000000000..de0daab112c0
--- /dev/null
+++ b/net/p5-Socket/pkg-plist
@@ -0,0 +1,7 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/Socket.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Socket/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Socket/Socket.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Socket/Socket.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Socket/autosplit.ix
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Socket