aboutsummaryrefslogtreecommitdiff
path: root/net/p5-URI-Nested
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2016-01-06 07:43:27 +0000
committerMartin Wilke <miwi@FreeBSD.org>2016-01-06 07:43:27 +0000
commit3640664cbaa311444e0edacf4f6c648c63e2f5e7 (patch)
tree1a7c4949fef139798141aeccf97eaadf57254ebf /net/p5-URI-Nested
parent9d0b9278e2be13888dc0e97023dc8bc17a2f1e30 (diff)
downloadports-3640664cbaa311444e0edacf4f6c648c63e2f5e7.tar.gz
ports-3640664cbaa311444e0edacf4f6c648c63e2f5e7.zip
This library implements a Perl interface for nested URIs -- that is, URIs that
contain other URIs. The basic format is: {prefix}:{uri} Some examples: * `jdbc:oracle:scott/tiger@//myhost:1521/myservicename` * `db:postgres://db.example.com/template1` WWW: http://search.cpan.org/dist/URI-Nested/ PR: 205945 Submitted by: Henrik Hodne <henrik@hodne.io>
Notes
Notes: svn path=/head/; revision=405338
Diffstat (limited to 'net/p5-URI-Nested')
-rw-r--r--net/p5-URI-Nested/Makefile22
-rw-r--r--net/p5-URI-Nested/distinfo2
-rw-r--r--net/p5-URI-Nested/pkg-descr12
-rw-r--r--net/p5-URI-Nested/pkg-plist2
4 files changed, 38 insertions, 0 deletions
diff --git a/net/p5-URI-Nested/Makefile b/net/p5-URI-Nested/Makefile
new file mode 100644
index 000000000000..9e322df0fcb3
--- /dev/null
+++ b/net/p5-URI-Nested/Makefile
@@ -0,0 +1,22 @@
+# Created by: Henrik Hodne <henrik@hodne.io>
+# $FreeBSD$
+
+PORTNAME= URI-Nested
+PORTVERSION= 0.10
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= henrik@hodne.io
+COMMENT= Perl5 interface for nested URIs
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-URI>=1.40:${PORTSDIR}/net/p5-URI
+
+NO_ARCH= yes
+USES= perl5
+USE_PERL5= modbuild
+
+.include <bsd.port.mk>
diff --git a/net/p5-URI-Nested/distinfo b/net/p5-URI-Nested/distinfo
new file mode 100644
index 000000000000..5df97e43c990
--- /dev/null
+++ b/net/p5-URI-Nested/distinfo
@@ -0,0 +1,2 @@
+SHA256 (URI-Nested-0.10.tar.gz) = e1971339a65fbac63ab87142d4b59d3d259d51417753c77cb58ea31a8233efaf
+SIZE (URI-Nested-0.10.tar.gz) = 6170
diff --git a/net/p5-URI-Nested/pkg-descr b/net/p5-URI-Nested/pkg-descr
new file mode 100644
index 000000000000..0f1946642f66
--- /dev/null
+++ b/net/p5-URI-Nested/pkg-descr
@@ -0,0 +1,12 @@
+This library implements a Perl interface for nested URIs -- that is, URIs that
+contain other URIs. The basic format is:
+
+{prefix}:{uri}
+
+Some examples:
+
+* `jdbc:oracle:scott/tiger@//myhost:1521/myservicename`
+* `db:postgres://db.example.com/template1`
+
+
+WWW: http://search.cpan.org/dist/URI-Nested/
diff --git a/net/p5-URI-Nested/pkg-plist b/net/p5-URI-Nested/pkg-plist
new file mode 100644
index 000000000000..c122fe036b13
--- /dev/null
+++ b/net/p5-URI-Nested/pkg-plist
@@ -0,0 +1,2 @@
+%%SITE_PERL%%/URI/Nested.pm
+%%PERL5_MAN3%%/URI::Nested.3.gz