aboutsummaryrefslogtreecommitdiff
path: root/net/p5-XML-Compile-SOAP-AnyEvent
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2011-01-12 11:08:36 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2011-01-12 11:08:36 +0000
commit6deb005c461839eb7ab942d3026c2c6330bc7d05 (patch)
treee1dd6dcfeda39ea0df219ba6c1d76bc1e2588f6b /net/p5-XML-Compile-SOAP-AnyEvent
parent401a5ebf987d385ee453343877f7ffb4531e2f7c (diff)
downloadports-6deb005c461839eb7ab942d3026c2c6330bc7d05.tar.gz
ports-6deb005c461839eb7ab942d3026c2c6330bc7d05.zip
Add p5-XML-Compile-SOAP-AnyEvent 0.01, exchange XML via AnyEvent::HTTP.
Feature safe: yes
Notes
Notes: svn path=/head/; revision=267697
Diffstat (limited to 'net/p5-XML-Compile-SOAP-AnyEvent')
-rw-r--r--net/p5-XML-Compile-SOAP-AnyEvent/Makefile29
-rw-r--r--net/p5-XML-Compile-SOAP-AnyEvent/distinfo2
-rw-r--r--net/p5-XML-Compile-SOAP-AnyEvent/pkg-descr8
-rw-r--r--net/p5-XML-Compile-SOAP-AnyEvent/pkg-plist10
4 files changed, 49 insertions, 0 deletions
diff --git a/net/p5-XML-Compile-SOAP-AnyEvent/Makefile b/net/p5-XML-Compile-SOAP-AnyEvent/Makefile
new file mode 100644
index 000000000000..4cbecbe43d3f
--- /dev/null
+++ b/net/p5-XML-Compile-SOAP-AnyEvent/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: XML-Compile-SOAP-AnyEvent
+# Date created: 12 Jan 2011
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-Compile-SOAP-AnyEvent
+PORTVERSION= 0.01
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Exchange XML via AnyEvent::HTTP
+
+BUILD_DEPENDS= p5-XML-Compile-SOAP>=2.18:${PORTSDIR}/net/p5-XML-Compile-SOAP \
+ p5-AnyEvent-HTTP>=1.46:${PORTSDIR}/www/p5-AnyEvent-HTTP \
+ p5-Log-Report>=0.28:${PORTSDIR}/devel/p5-Log-Report
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+PERL_CONFIGURE= yes
+
+MAN3= XML::Compile::Transfer::SOAPHTTP_AnyEvent.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-XML-Compile-SOAP-AnyEvent/distinfo b/net/p5-XML-Compile-SOAP-AnyEvent/distinfo
new file mode 100644
index 000000000000..980ed38f6568
--- /dev/null
+++ b/net/p5-XML-Compile-SOAP-AnyEvent/distinfo
@@ -0,0 +1,2 @@
+SHA256 (XML-Compile-SOAP-AnyEvent-0.01.tar.gz) = 3af566053bc91e6e0e024e8cefb662a92a13b1ca4f0b1e908dcbe2cccd34226e
+SIZE (XML-Compile-SOAP-AnyEvent-0.01.tar.gz) = 6140
diff --git a/net/p5-XML-Compile-SOAP-AnyEvent/pkg-descr b/net/p5-XML-Compile-SOAP-AnyEvent/pkg-descr
new file mode 100644
index 000000000000..bbe2604feab2
--- /dev/null
+++ b/net/p5-XML-Compile-SOAP-AnyEvent/pkg-descr
@@ -0,0 +1,8 @@
+This module handles the exchange of (XML) messages, according to the
+rules of SOAP (any version). The module does not known how to parse or
+compose XML, but only worries about the HTTP aspects.
+
+In contrairy to XML::Compile::Transport::SOAPHTTP, this implementation
+can be used in various event-driven environments, via AnyEvent::HTTP.
+
+WWW: http://search.cpan.org/dist/XML-Compile-SOAP-AnyEvent/
diff --git a/net/p5-XML-Compile-SOAP-AnyEvent/pkg-plist b/net/p5-XML-Compile-SOAP-AnyEvent/pkg-plist
new file mode 100644
index 000000000000..290bab926786
--- /dev/null
+++ b/net/p5-XML-Compile-SOAP-AnyEvent/pkg-plist
@@ -0,0 +1,10 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Compile/SOAP/AnyEvent/.packlist
+%%SITE_PERL%%/XML/Compile/Transfer/SOAPHTTP_AnyEvent.pm
+%%SITE_PERL%%/XML/Compile/Transfer/SOAPHTTP_AnyEvent.pod
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Compile/SOAP/AnyEvent
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Compile/SOAP
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Compile
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML
+@dirrmtry %%SITE_PERL%%/XML/Compile/Transfer
+@dirrmtry %%SITE_PERL%%/XML/Compile
+@dirrmtry %%SITE_PERL%%/XML