aboutsummaryrefslogtreecommitdiff
path: root/net/p5-XML-Compile-SOAP
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-01-12 16:40:22 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-01-12 16:40:22 +0000
commit74ad3aafd557fa13db8e23925f5f5b28a48cdfc4 (patch)
treec30c4b311c5f90697d9564fcf3486d404627b9a1 /net/p5-XML-Compile-SOAP
parent4e0dbaaa24e8321bb82996ca171c155935c9f339 (diff)
downloadports-74ad3aafd557fa13db8e23925f5f5b28a48cdfc4.tar.gz
ports-74ad3aafd557fa13db8e23925f5f5b28a48cdfc4.zip
Notes
Diffstat (limited to 'net/p5-XML-Compile-SOAP')
-rw-r--r--net/p5-XML-Compile-SOAP/Makefile36
-rw-r--r--net/p5-XML-Compile-SOAP/distinfo3
-rw-r--r--net/p5-XML-Compile-SOAP/pkg-descr16
-rw-r--r--net/p5-XML-Compile-SOAP/pkg-plist55
4 files changed, 110 insertions, 0 deletions
diff --git a/net/p5-XML-Compile-SOAP/Makefile b/net/p5-XML-Compile-SOAP/Makefile
new file mode 100644
index 000000000000..f6a8def50360
--- /dev/null
+++ b/net/p5-XML-Compile-SOAP/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: p5-XML-Compile-SOAP
+# Date created: 2008-01-07
+# Whom: Jin-Shan Tseng <tjs@cdpa.nsysu.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-Compile-SOAP
+PORTVERSION= 0.65
+CATEGORIES= net
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tjs@cdpa.nsysu.edu.tw
+COMMENT= Base-class for SOAP implementations
+
+RUN_DEPENDS= p5-XML-Compile>=0.61:${PORTSDIR}/textproc/p5-XML-Compile \
+ p5-Log-Report>=0.11:${PORTSDIR}/devel/p5-Log-Report \
+ ${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes
+BUILD_DEPENDS= p5-XML-Compile>=0.61:${PORTSDIR}/textproc/p5-XML-Compile \
+ p5-Log-Report>=0.11:${PORTSDIR}/devel/p5-Log-Report \
+ ${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes
+
+PERL_CONFIGURE= yes
+
+MAN3= XML::Compile::SOAP.3 \
+ XML::Compile::SOAP11.3 XML::Compile::SOAP11::Client.3 \
+ XML::Compile::SOAP11::Server.3 XML::Compile::SOAP12.3 \
+ XML::Compile::SOAP12::Client.3 XML::Compile::SOAP12::Server.3 \
+ XML::Compile::SOAP::Client.3 XML::Compile::SOAP::Encoding.3 \
+ XML::Compile::SOAP::Server.3 XML::Compile::SOAP::Tester.3 \
+ XML::Compile::SOAP::Util.3 XML::Compile::Transport.3 \
+ XML::Compile::Transport::SOAPHTTP.3 XML::Compile::WSDL11.3 \
+ XML::Compile::WSDL11::Operation.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-XML-Compile-SOAP/distinfo b/net/p5-XML-Compile-SOAP/distinfo
new file mode 100644
index 000000000000..c93f1beb7be1
--- /dev/null
+++ b/net/p5-XML-Compile-SOAP/distinfo
@@ -0,0 +1,3 @@
+MD5 (XML-Compile-SOAP-0.65.tar.gz) = 8d7dd026204003994a7a11913d9ea155
+SHA256 (XML-Compile-SOAP-0.65.tar.gz) = cf383521dceb25eef144018e759c2a07d729279c2f928646a6dda2e3bd51eced
+SIZE (XML-Compile-SOAP-0.65.tar.gz) = 85322
diff --git a/net/p5-XML-Compile-SOAP/pkg-descr b/net/p5-XML-Compile-SOAP/pkg-descr
new file mode 100644
index 000000000000..2852f8f922ca
--- /dev/null
+++ b/net/p5-XML-Compile-SOAP/pkg-descr
@@ -0,0 +1,16 @@
+This module handles the SOAP protocol. The first implementation is SOAP1.1
+(http://www.w3.org/TR/2000/NOTE-SOAP-20000508/), which is still most often
+used. The SOAP1.2 definition (http://www.w3.org/TR/soap12/) is quite
+different; this module tries to define a sufficiently abstract interface to
+hide the protocol differences.
+
+Be aware that there are three kinds of SOAP:
+
+1. Document style (literal) SOAP, where there is a WSDL file which explicitly
+types all out-going and incoming messages. Very easy to use.
+2. RPC style SOAP literal. The WSDL file is not explicit about the content of
+the messages, but all messages must be schema defined types.
+3. RPC style SOAP encoded. The sent data is nowhere described formally. The data
+is transported in some ad-hoc way.
+
+WWW: http://search.cpan.org/dist/XML-Compile-SOAP/
diff --git a/net/p5-XML-Compile-SOAP/pkg-plist b/net/p5-XML-Compile-SOAP/pkg-plist
new file mode 100644
index 000000000000..9e54e3a9afec
--- /dev/null
+++ b/net/p5-XML-Compile-SOAP/pkg-plist
@@ -0,0 +1,55 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Compile/SOAP/.packlist
+%%SITE_PERL%%/XML/Compile/SOAP.pm
+%%SITE_PERL%%/XML/Compile/SOAP.pod
+%%SITE_PERL%%/XML/Compile/SOAP/Client.pm
+%%SITE_PERL%%/XML/Compile/SOAP/Client.pod
+%%SITE_PERL%%/XML/Compile/SOAP/Encoding.pm
+%%SITE_PERL%%/XML/Compile/SOAP/Encoding.pod
+%%SITE_PERL%%/XML/Compile/SOAP/Server.pm
+%%SITE_PERL%%/XML/Compile/SOAP/Server.pod
+%%SITE_PERL%%/XML/Compile/SOAP/Tester.pm
+%%SITE_PERL%%/XML/Compile/SOAP/Tester.pod
+%%SITE_PERL%%/XML/Compile/SOAP/Util.pm
+%%SITE_PERL%%/XML/Compile/SOAP/Util.pod
+%%SITE_PERL%%/XML/Compile/SOAP11.pm
+%%SITE_PERL%%/XML/Compile/SOAP11.pod
+%%SITE_PERL%%/XML/Compile/SOAP11/Client.pm
+%%SITE_PERL%%/XML/Compile/SOAP11/Client.pod
+%%SITE_PERL%%/XML/Compile/SOAP11/Server.pm
+%%SITE_PERL%%/XML/Compile/SOAP11/Server.pod
+%%SITE_PERL%%/XML/Compile/SOAP11/xsd/soap-encoding.xsd
+%%SITE_PERL%%/XML/Compile/SOAP11/xsd/soap-envelope.xsd
+%%SITE_PERL%%/XML/Compile/SOAP12.pm
+%%SITE_PERL%%/XML/Compile/SOAP12.pod
+%%SITE_PERL%%/XML/Compile/SOAP12/Client.pm
+%%SITE_PERL%%/XML/Compile/SOAP12/Client.pod
+%%SITE_PERL%%/XML/Compile/SOAP12/Server.pm
+%%SITE_PERL%%/XML/Compile/SOAP12/Server.pod
+%%SITE_PERL%%/XML/Compile/SOAP12/xsd/2003-soap-encoding.xsd
+%%SITE_PERL%%/XML/Compile/SOAP12/xsd/2003-soap-envelope.xsd
+%%SITE_PERL%%/XML/Compile/SOAP12/xsd/2003-soap-rpc.xsd
+%%SITE_PERL%%/XML/Compile/Transport.pm
+%%SITE_PERL%%/XML/Compile/Transport.pod
+%%SITE_PERL%%/XML/Compile/Transport/SOAPHTTP.pm
+%%SITE_PERL%%/XML/Compile/Transport/SOAPHTTP.pod
+%%SITE_PERL%%/XML/Compile/WSDL11.pm
+%%SITE_PERL%%/XML/Compile/WSDL11.pod
+%%SITE_PERL%%/XML/Compile/WSDL11/Operation.pm
+%%SITE_PERL%%/XML/Compile/WSDL11/Operation.pod
+%%SITE_PERL%%/XML/Compile/WSDL11/xsd/wsdl-http.xsd
+%%SITE_PERL%%/XML/Compile/WSDL11/xsd/wsdl-mime.xsd
+%%SITE_PERL%%/XML/Compile/WSDL11/xsd/wsdl-soap.xsd
+%%SITE_PERL%%/XML/Compile/WSDL11/xsd/wsdl-soap12.xsd
+%%SITE_PERL%%/XML/Compile/WSDL11/xsd/wsdl.xsd
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Compile/SOAP
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Compile
+@dirrmtry %%SITE_PERL%%/XML/Compile/WSDL11/xsd
+@dirrmtry %%SITE_PERL%%/XML/Compile/WSDL11
+@dirrmtry %%SITE_PERL%%/XML/Compile/Transport
+@dirrmtry %%SITE_PERL%%/XML/Compile/SOAP12/xsd
+@dirrmtry %%SITE_PERL%%/XML/Compile/SOAP12
+@dirrmtry %%SITE_PERL%%/XML/Compile/SOAP11/xsd
+@dirrmtry %%SITE_PERL%%/XML/Compile/SOAP11
+@dirrmtry %%SITE_PERL%%/XML/Compile/SOAP
+@dirrmtry %%SITE_PERL%%/XML/Compile