aboutsummaryrefslogtreecommitdiff
path: root/net/pacemaker2
diff options
context:
space:
mode:
authorVinícius Zavam <egypcio@FreeBSD.org>2020-06-26 16:33:27 +0000
committerVinícius Zavam <egypcio@FreeBSD.org>2020-06-26 16:33:27 +0000
commit9733b1c46b00e28a3f6a6386e9084a6bfc5e2c75 (patch)
tree0deebd8da5cd7cbc4c396c9b87479a9d4edcf310 /net/pacemaker2
parent5145671645320d613be1a121b06f1f94620ba6f8 (diff)
downloadports-9733b1c46b00e28a3f6a6386e9084a6bfc5e2c75.tar.gz
ports-9733b1c46b00e28a3f6a6386e9084a6bfc5e2c75.zip
net/pacemaker2: update 2.0.3 to 2.0.4
CHANGELOG: github.com/ClusterLabs/pacemaker/releases/tag/Pacemaker-2.0.4
Notes
Notes: svn path=/head/; revision=540530
Diffstat (limited to 'net/pacemaker2')
-rw-r--r--net/pacemaker2/Makefile3
-rw-r--r--net/pacemaker2/distinfo6
-rw-r--r--net/pacemaker2/files/patch-tools_cibsecret.in48
-rw-r--r--net/pacemaker2/pkg-plist57
4 files changed, 73 insertions, 41 deletions
diff --git a/net/pacemaker2/Makefile b/net/pacemaker2/Makefile
index e6880dba3767..f52f571fa9c4 100644
--- a/net/pacemaker2/Makefile
+++ b/net/pacemaker2/Makefile
@@ -1,8 +1,7 @@
# Created by: David Shane Holden <dpejesh@yahoo.com>
# $FreeBSD$
-PORTVERSION= 2.0.3
-PORTREVISION= 2
+PORTVERSION= 2.0.4
PKGNAMESUFFIX= 2
.include "${.CURDIR}/../pacemaker1/Makefile.common"
diff --git a/net/pacemaker2/distinfo b/net/pacemaker2/distinfo
index a483a7a98aee..b62cb8a1b8da 100644
--- a/net/pacemaker2/distinfo
+++ b/net/pacemaker2/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1575901526
-SHA256 (ClusterLabs-pacemaker-Pacemaker-2.0.3_GH0.tar.gz) = ca228f7f9745c7bc1e31bebe30e51475e95a82d9010d281f1701f2e3310bd3fe
-SIZE (ClusterLabs-pacemaker-Pacemaker-2.0.3_GH0.tar.gz) = 5662096
+TIMESTAMP = 1592858530
+SHA256 (ClusterLabs-pacemaker-Pacemaker-2.0.4_GH0.tar.gz) = dccc37190230e1ee645966d279f90ea989f44f4c619274684bef4ccb6de6f371
+SIZE (ClusterLabs-pacemaker-Pacemaker-2.0.4_GH0.tar.gz) = 5134516
diff --git a/net/pacemaker2/files/patch-tools_cibsecret.in b/net/pacemaker2/files/patch-tools_cibsecret.in
index c301a16a3df5..ed9cb171834e 100644
--- a/net/pacemaker2/files/patch-tools_cibsecret.in
+++ b/net/pacemaker2/files/patch-tools_cibsecret.in
@@ -1,29 +1,29 @@
---- tools/cibsecret.in.orig 2020-02-07 13:13:01 UTC
+--- tools/cibsecret.in.orig 2020-06-22 21:03:03 UTC
+++ tools/cibsecret.in
-@@ -100,7 +100,7 @@ info() {
+@@ -138,7 +138,7 @@ info() {
}
check_env() {
-- which md5sum >/dev/null 2>&1 ||
-+ which md5 >/dev/null 2>&1 ||
- fatal "please install md5sum to run $PROG"
- if which pssh >/dev/null 2>&1; then
- rsh=pssh_fun
-@@ -251,7 +251,7 @@ localfiles() {
- ;;
- "set")
- local md5sum
-- md5sum=`printf $value | md5sum` ||
-+ md5sum=`printf $value | md5` ||
- fatal "md5sum failed to produce hash for resource $rsc parameter $param"
- md5sum=`echo $md5sum | awk '{print $1}'`
- mkdir -p `dirname $local_file` &&
-@@ -307,7 +307,7 @@ cibsecret_check() {
- local_md5sum=`localfiles getsum $rsc $param`
- [ "$local_md5sum" ] ||
- fatal "no MD5 hash for resource $rsc parameter $param"
-- md5sum=`printf "$current_local" | md5sum | awk '{print $1}'`
-+ md5sum=`printf "$current_local" | md5 | awk '{print $1}'`
- [ "$md5sum" = "$local_md5sum" ] ||
- fatal "MD5 hash mismatch for resource $rsc parameter $param"
+- which md5sum >/dev/null 2>&1 ||
++ which md5 >/dev/null 2>&1 ||
+ fatal "please install md5sum to run $PROG"
+ if which pssh >/dev/null 2>&1; then
+ rsh=pssh_fun
+@@ -300,7 +300,7 @@ localfiles() {
+ ;;
+
+ set)
+- LF_SUM="$(printf %s "$LF_VALUE" | md5sum)" ||
++ LF_SUM="$(printf %s "$LF_VALUE" | md5)" ||
+ fatal "md5sum failed to produce hash for resource $LF_RSC parameter $LF_PARAM"
+ LF_SUM="$(echo "$LF_SUM" | awk '{print $1}')"
+ mkdir -p "$(dirname "$LF_FILE")" &&
+@@ -338,7 +338,7 @@ cibsecret_check() {
+ [ "$CSC_LOCAL_SUM" ] ||
+ fatal "no MD5 hash for resource $rsc parameter $param"
+ CSC_LOCAL_VALUE="$(localfiles get "$rsc" "$param")"
+- CSC_CALC_SUM="$(printf "%s" "$CSC_LOCAL_VALUE" | md5sum | awk '{print $1}')"
++ CSC_CALC_SUM="$(printf "%s" "$CSC_LOCAL_VALUE" | md5 | awk '{print $1}')"
+ [ "$CSC_CALC_SUM" = "$CSC_LOCAL_SUM" ] ||
+ fatal "MD5 hash mismatch for resource $rsc parameter $param"
}
diff --git a/net/pacemaker2/pkg-plist b/net/pacemaker2/pkg-plist
index 5bf2945485ac..c3ef989b407b 100644
--- a/net/pacemaker2/pkg-plist
+++ b/net/pacemaker2/pkg-plist
@@ -1,9 +1,9 @@
etc/logrotate.d/pacemaker
-include/pacemaker/crm/attrd.h
include/pacemaker/crm/cib.h
include/pacemaker/crm/cib/cib_types.h
include/pacemaker/crm/cib/util.h
include/pacemaker/crm/cluster.h
+include/pacemaker/crm/common/acl.h
include/pacemaker/crm/common/ipc.h
include/pacemaker/crm/common/iso8601.h
include/pacemaker/crm/common/logging.h
@@ -27,39 +27,39 @@ include/pacemaker/crm_config.h
lib/libcib.a
lib/libcib.so
lib/libcib.so.27
-lib/libcib.so.27.1.0
+lib/libcib.so.27.1.1
lib/libcrmcluster.a
lib/libcrmcluster.so
lib/libcrmcluster.so.29
-lib/libcrmcluster.so.29.0.3
+lib/libcrmcluster.so.29.0.4
lib/libcrmcommon.a
lib/libcrmcommon.so
lib/libcrmcommon.so.34
-lib/libcrmcommon.so.34.3.0
+lib/libcrmcommon.so.34.4.0
lib/libcrmservice.a
lib/libcrmservice.so
lib/libcrmservice.so.28
-lib/libcrmservice.so.28.2.0
+lib/libcrmservice.so.28.2.1
lib/liblrmd.a
lib/liblrmd.so
lib/liblrmd.so.28
-lib/liblrmd.so.28.0.3
+lib/liblrmd.so.28.1.0
lib/libpacemaker.a
lib/libpacemaker.so
lib/libpacemaker.so.1
-lib/libpacemaker.so.1.1.0
+lib/libpacemaker.so.1.1.1
lib/libpe_rules.a
lib/libpe_rules.so
lib/libpe_rules.so.26
-lib/libpe_rules.so.26.1.0
+lib/libpe_rules.so.26.1.1
lib/libpe_status.a
lib/libpe_status.so
lib/libpe_status.so.28
-lib/libpe_status.so.28.1.0
+lib/libpe_status.so.28.2.0
lib/libstonithd.a
lib/libstonithd.so
lib/libstonithd.so.26
-lib/libstonithd.so.26.3.0
+lib/libstonithd.so.26.4.0
lib/ocf/resource.d/pacemaker/ClusterMon
lib/ocf/resource.d/pacemaker/Dummy
lib/ocf/resource.d/pacemaker/HealthCPU
@@ -214,8 +214,6 @@ sbin/pacemakerd
sbin/stonith_admin
%%PORTDOCS%%%%DOCSDIR%%/COPYING
%%PORTDOCS%%%%DOCSDIR%%/README.markdown
-%%PORTDOCS%%%%DOCSDIR%%/acls.html
-%%PORTDOCS%%%%DOCSDIR%%/acls.txt
%%PORTDOCS%%%%DOCSDIR%%/crm_fencing.html
%%PORTDOCS%%%%DOCSDIR%%/crm_fencing.txt
%%PORTDOCS%%%%DOCSDIR%%/licenses/CC-BY-SA-4.0
@@ -233,16 +231,21 @@ sbin/stonith_admin
%%DATADIR%%/api/api-result-1.0.rng
%%DATADIR%%/api/api-result-1.1.rng
%%DATADIR%%/api/api-result-2.0.rng
+%%DATADIR%%/api/api-result-2.1.rng
+%%DATADIR%%/api/api-result-2.2.rng
%%DATADIR%%/api/api-result-next.rng
%%DATADIR%%/api/api-result.rng
%%DATADIR%%/api/command-output-1.0.rng
%%DATADIR%%/api/crm_mon-2.0.rng
+%%DATADIR%%/api/crm_mon-2.1.rng
+%%DATADIR%%/api/crm_mon-2.2.rng
%%DATADIR%%/api/fence-event-2.0.rng
%%DATADIR%%/api/item-1.1.rng
%%DATADIR%%/api/status-2.0.rng
%%DATADIR%%/api/stonith_admin-1.0.rng
%%DATADIR%%/api/stonith_admin-1.1.rng
%%DATADIR%%/api/stonith_admin-2.0.rng
+%%DATADIR%%/api/stonith_admin-2.1.rng
%%DATADIR%%/api/version-2.0.rng
%%DATADIR%%/cib-1.0.rng
%%DATADIR%%/cib-1.2.rng
@@ -286,6 +289,7 @@ sbin/stonith_admin
%%DATADIR%%/pacemaker-3.0.rng
%%DATADIR%%/pacemaker-3.1.rng
%%DATADIR%%/pacemaker-3.2.rng
+%%DATADIR%%/pacemaker-3.3.rng
%%DATADIR%%/pacemaker-next.rng
%%DATADIR%%/pacemaker.rng
%%DATADIR%%/report.collector
@@ -305,10 +309,14 @@ sbin/stonith_admin
%%DATADIR%%/score.rng
%%DATADIR%%/status-1.0.rng
%%DATADIR%%/tags-1.3.rng
+%%DATADIR%%/tags-3.3.rng
%%DATADIR%%/tests/README.md
%%DATADIR%%/tests/cli/crm_diff_new.xml
%%DATADIR%%/tests/cli/crm_diff_old.xml
+%%DATADIR%%/tests/cli/crm_mon-partial.xml
+%%DATADIR%%/tests/cli/crm_mon.xml
%%DATADIR%%/tests/cli/regression.acls.exp
+%%DATADIR%%/tests/cli/regression.crm_mon.exp
%%DATADIR%%/tests/cli/regression.dates.exp
%%DATADIR%%/tests/cli/regression.rules.exp
%%DATADIR%%/tests/cli/regression.tools.exp
@@ -1236,6 +1244,16 @@ sbin/stonith_admin
%%DATADIR%%/tests/scheduler/coloc-clone-stays-active.scores
%%DATADIR%%/tests/scheduler/coloc-clone-stays-active.summary
%%DATADIR%%/tests/scheduler/coloc-clone-stays-active.xml
+%%DATADIR%%/tests/scheduler/coloc-dependee-should-move.dot
+%%DATADIR%%/tests/scheduler/coloc-dependee-should-move.exp
+%%DATADIR%%/tests/scheduler/coloc-dependee-should-move.scores
+%%DATADIR%%/tests/scheduler/coloc-dependee-should-move.summary
+%%DATADIR%%/tests/scheduler/coloc-dependee-should-move.xml
+%%DATADIR%%/tests/scheduler/coloc-dependee-should-stay.dot
+%%DATADIR%%/tests/scheduler/coloc-dependee-should-stay.exp
+%%DATADIR%%/tests/scheduler/coloc-dependee-should-stay.scores
+%%DATADIR%%/tests/scheduler/coloc-dependee-should-stay.summary
+%%DATADIR%%/tests/scheduler/coloc-dependee-should-stay.xml
%%DATADIR%%/tests/scheduler/coloc-group.dot
%%DATADIR%%/tests/scheduler/coloc-group.exp
%%DATADIR%%/tests/scheduler/coloc-group.scores
@@ -2482,6 +2500,11 @@ sbin/stonith_admin
%%DATADIR%%/tests/scheduler/placement-stickiness.scores
%%DATADIR%%/tests/scheduler/placement-stickiness.summary
%%DATADIR%%/tests/scheduler/placement-stickiness.xml
+%%DATADIR%%/tests/scheduler/priority-fencing-delay.dot
+%%DATADIR%%/tests/scheduler/priority-fencing-delay.exp
+%%DATADIR%%/tests/scheduler/priority-fencing-delay.scores
+%%DATADIR%%/tests/scheduler/priority-fencing-delay.summary
+%%DATADIR%%/tests/scheduler/priority-fencing-delay.xml
%%DATADIR%%/tests/scheduler/probe-0.dot
%%DATADIR%%/tests/scheduler/probe-0.exp
%%DATADIR%%/tests/scheduler/probe-0.scores
@@ -2902,6 +2925,16 @@ sbin/stonith_admin
%%DATADIR%%/tests/scheduler/rsc_dep8.scores
%%DATADIR%%/tests/scheduler/rsc_dep8.summary
%%DATADIR%%/tests/scheduler/rsc_dep8.xml
+%%DATADIR%%/tests/scheduler/shutdown-lock-expiration.dot
+%%DATADIR%%/tests/scheduler/shutdown-lock-expiration.exp
+%%DATADIR%%/tests/scheduler/shutdown-lock-expiration.scores
+%%DATADIR%%/tests/scheduler/shutdown-lock-expiration.summary
+%%DATADIR%%/tests/scheduler/shutdown-lock-expiration.xml
+%%DATADIR%%/tests/scheduler/shutdown-lock.dot
+%%DATADIR%%/tests/scheduler/shutdown-lock.exp
+%%DATADIR%%/tests/scheduler/shutdown-lock.scores
+%%DATADIR%%/tests/scheduler/shutdown-lock.summary
+%%DATADIR%%/tests/scheduler/shutdown-lock.xml
%%DATADIR%%/tests/scheduler/shutdown-maintenance-node.dot
%%DATADIR%%/tests/scheduler/shutdown-maintenance-node.exp
%%DATADIR%%/tests/scheduler/shutdown-maintenance-node.scores