aboutsummaryrefslogtreecommitdiff
path: root/net/panoptis
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-11-30 09:51:44 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-11-30 09:51:44 +0000
commitb0baa71d2d3dabb4ec077517df4d6a0e5c4d1e57 (patch)
tree35ae721eda45da996a072476002931a5fe879ab2 /net/panoptis
parent45df9374d15995341607c07811e3eb482561ad5b (diff)
downloadports-b0baa71d2d3dabb4ec077517df4d6a0e5c4d1e57.tar.gz
ports-b0baa71d2d3dabb4ec077517df4d6a0e5c4d1e57.zip
Panoptis is a project started some time ago,
with the aim to stop the Denial of Service and Distributed Denial of Service attacks that have been torturing the Internet for the last few years. It is based on real-time processing of Cisco (R) NetFlow (TM) data, since this seems to be the most efficient approach as it is router-centric, allowing for automated central response without intervention from the affected organizations' network administrators. WWW: http://panoptis.sourceforge.net/ Submitted by: Babak Farrokhi <farrokhi at FreeBSD.org>
Notes
Notes: svn path=/head/; revision=178312
Diffstat (limited to 'net/panoptis')
-rw-r--r--net/panoptis/Makefile37
-rw-r--r--net/panoptis/distinfo3
-rw-r--r--net/panoptis/files/patch-panoptis-pview.py8
-rw-r--r--net/panoptis/files/patch-panoptis-timeslot.cpp11
-rw-r--r--net/panoptis/pkg-descr13
5 files changed, 72 insertions, 0 deletions
diff --git a/net/panoptis/Makefile b/net/panoptis/Makefile
new file mode 100644
index 000000000000..5affd2611847
--- /dev/null
+++ b/net/panoptis/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: panoptis
+# Date created: 2006-11-28
+# Whom: Babak Farrokhi <farrokhi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= panoptis
+PORTVERSION= 0.1.4
+CATEGORIES= net security
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= farrokhi@FreeBSD.org
+COMMENT= Detect and block DoS/DDoS attacks
+
+LIB_DEPENDS= ccgnu2-1.5.0:${PORTSDIR}/devel/commoncpp
+
+GNU_CONFIGURE= yes
+USE_PYTHON= yes
+CONFIGURE_ENV= CPPFLAGS='${CPPFLAGS}' LDFLAGS='${LDFLAGS}'
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+PLIST_FILES= bin/panoptis bin/mail.py bin/pview.py bin/speed.py
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= Does not compile on 4.x
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/panoptis/panoptis ${PREFIX}/bin/panoptis
+ ${INSTALL_SCRIPT} ${WRKSRC}/panoptis/mail.py ${PREFIX}/bin/mail.py
+ ${INSTALL_SCRIPT} ${WRKSRC}/panoptis/pview.py ${PREFIX}/bin/pview.py
+ ${INSTALL_SCRIPT} ${WRKSRC}/panoptis/speed.py ${PREFIX}/bin/speed.py
+
+.include <bsd.port.post.mk>
diff --git a/net/panoptis/distinfo b/net/panoptis/distinfo
new file mode 100644
index 000000000000..0cf8786afc05
--- /dev/null
+++ b/net/panoptis/distinfo
@@ -0,0 +1,3 @@
+MD5 (panoptis-0.1.4.tar.gz) = 742b11b7401e8df8c6083fb4c6a0823e
+SHA256 (panoptis-0.1.4.tar.gz) = bc63090f9749c5ff7f7ebdd83274596c1452cb82a0449adbe299f77da45affe1
+SIZE (panoptis-0.1.4.tar.gz) = 418829
diff --git a/net/panoptis/files/patch-panoptis-pview.py b/net/panoptis/files/patch-panoptis-pview.py
new file mode 100644
index 000000000000..624c5ed53015
--- /dev/null
+++ b/net/panoptis/files/patch-panoptis-pview.py
@@ -0,0 +1,8 @@
+--- panoptis/pview.py.orig Tue Nov 28 14:57:01 2006
++++ panoptis/pview.py Tue Nov 28 14:57:10 2006
+@@ -1,4 +1,4 @@
+-#!/usr/bin/python
++#!/usr/bin/env python
+
+ # This CGI script connects to Panoptis' web port, makes a request,
+ # accepts data and formats it to show it to the user.
diff --git a/net/panoptis/files/patch-panoptis-timeslot.cpp b/net/panoptis/files/patch-panoptis-timeslot.cpp
new file mode 100644
index 000000000000..b10fd8c8e997
--- /dev/null
+++ b/net/panoptis/files/patch-panoptis-timeslot.cpp
@@ -0,0 +1,11 @@
+--- panoptis/timeslot.cpp.orig Tue Nov 28 13:58:22 2006
++++ panoptis/timeslot.cpp Tue Nov 28 13:58:33 2006
+@@ -109,7 +109,7 @@
+ continue;
+
+ // Create a new Distribution object
+- IfPair *ifpair = new IfPair((uint16_t)input, (uint16_t)output);
++ IfPair *ifpair = new IfPair((uint16_t&)input, (uint16_t&)output);
+ if (!ifpair){
+ perror("new");
+ exit(errno);
diff --git a/net/panoptis/pkg-descr b/net/panoptis/pkg-descr
new file mode 100644
index 000000000000..449b63e708b2
--- /dev/null
+++ b/net/panoptis/pkg-descr
@@ -0,0 +1,13 @@
+Panoptis is a project started some time ago,
+with the aim to stop the Denial of Service
+and Distributed Denial of Service attacks that
+have been torturing the Internet for the last
+few years.
+It is based on real-time processing of Cisco (R)
+NetFlow (TM) data, since this seems to be the
+most efficient approach as it is router-centric,
+allowing for automated central response without
+intervention from the affected organizations'
+network administrators.
+
+WWW: http://panoptis.sourceforge.net/