aboutsummaryrefslogtreecommitdiff
path: root/net/parpd
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-01-25 08:22:47 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-01-25 08:22:47 +0000
commit39f155332bd8a3d6cac3224851fb3f5898708209 (patch)
tree0f357bcb3541e146f346300f1bbd77837a84d6b2 /net/parpd
parentceee4fbf67ba71a14df540b8968c27f2886bec7d (diff)
downloadports-39f155332bd8a3d6cac3224851fb3f5898708209.tar.gz
ports-39f155332bd8a3d6cac3224851fb3f5898708209.zip
Notes
Diffstat (limited to 'net/parpd')
-rw-r--r--net/parpd/Makefile24
-rw-r--r--net/parpd/distinfo3
-rw-r--r--net/parpd/files/parpd.in47
-rw-r--r--net/parpd/pkg-descr5
4 files changed, 79 insertions, 0 deletions
diff --git a/net/parpd/Makefile b/net/parpd/Makefile
new file mode 100644
index 000000000000..b631cc62b3bd
--- /dev/null
+++ b/net/parpd/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= parpd
+DISTVERSION= 1.1
+CATEGORIES= net
+MASTER_SITES= ftp://ftp.iks-jena.de/pub/mitarb/lutz/parpd/
+
+MAINTAINER= lutz@donnerhacke.de
+COMMENT= Proxy-ARP daemon
+
+LICENSE= ART20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= tar:tgz
+USE_RC_SUBR= parpd
+NO_TEST= yes
+
+PLIST_FILES= sbin/parpd man/man8/parpd.8.gz
+
+do-install:
+ ${INSTALL_PROGRAM} ${INSTALL_WRKSRC}/parpd ${STAGEDIR}${PREFIX}/sbin
+ ${INSTALL_MAN} ${INSTALL_WRKSRC}/parpd.8 ${STAGEDIR}${MAN8PREFIX}/man/man8
+
+.include <bsd.port.mk>
diff --git a/net/parpd/distinfo b/net/parpd/distinfo
new file mode 100644
index 000000000000..e3614356bc02
--- /dev/null
+++ b/net/parpd/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1510322377
+SHA256 (parpd-1.1.tgz) = 95318905767c1123eab87efa4fa664a57e5ed8f697802c6b7d5d0799ad8ea6e6
+SIZE (parpd-1.1.tgz) = 17197
diff --git a/net/parpd/files/parpd.in b/net/parpd/files/parpd.in
new file mode 100644
index 000000000000..aad054add9c6
--- /dev/null
+++ b/net/parpd/files/parpd.in
@@ -0,0 +1,47 @@
+#!/bin/sh
+
+# $FreeBSD$
+#
+# PROVIDE: parpd
+# REQUIRE: DAEMON
+# KEYWORD: shutdown
+#
+# Add these lines to /etc/rc.conf.local or /etc/rc.conf
+# to enable this service:
+# parpd_enable = yes (default: no)
+# parpd_flags = full_path_of_the_configuration_file
+# (default: %%PREFIX%%/etc/parpd.conf)
+#
+# If multiple daemons (with different configs) needs to be running:
+# - copy this file to a different name (i.e. parpdXX)
+# - change the "name" and "rcvar" values to the new name
+# - set the approbriate rc.conf variables (i.e.
+# parpdXX_enable = yes (default: no)
+# parpdXX_flags = %%PREFIX%%/etc/parpdXX.conf
+# )
+
+. /etc/rc.subr
+
+name=parpd
+rcvar=parpd_enable
+
+load_rc_config $name
+
+command=%%PREFIX%%/sbin/parpd
+extra_commands="reload"
+eval ": \${${name}_enable:='NO'}"
+eval ": \${${name}_flags:=%%PREFIX%%/etc/${name}.conf}"
+eval "config_file=\$${name}_flags"
+
+[ -s "$config_file" ] || err 1 "Missing configuration file '$config_file'"
+
+if get_pidfile_from_conf pidfile "$config_file"; then
+ pidfile="$_pidfile_from_conf"
+else
+ err 1 "$config_file does not specify an pidfile"
+fi
+
+eval "unset ${name}_flags"
+command_args="$config_file"
+
+run_rc_command "$1"
diff --git a/net/parpd/pkg-descr b/net/parpd/pkg-descr
new file mode 100644
index 000000000000..788c691ee07d
--- /dev/null
+++ b/net/parpd/pkg-descr
@@ -0,0 +1,5 @@
+The parpd daemon provide the missing ARP packets in non-broadcast
+multiple-access networks with overly strict first-hop security
+filters.
+
+WWW: https://lutz.donnerhacke.de/Projekte/parpd