aboutsummaryrefslogtreecommitdiff
path: root/net/pear-File_Bittorrent2
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-08-28 09:40:17 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-08-28 09:40:17 +0000
commit22077772efa382fe69a35ce18fcba4f29b5dcc37 (patch)
tree6647ad89929b5e269b20d8ec0ec5d836fe09db2a /net/pear-File_Bittorrent2
parent493779bf8b0e3b5fb6a5335eba44f016489f6e96 (diff)
downloadports-22077772efa382fe69a35ce18fcba4f29b5dcc37.tar.gz
ports-22077772efa382fe69a35ce18fcba4f29b5dcc37.zip
This package consists of three classes which handles the encoding
and decoding of data in Bittorrent format. You can also extract useful informations from .torrent files, create .torrent files and query the torrent's scrape page to get its statistics. PHP5 only. WWW: http://pear.php.net/package/File_Bittorrent2/ PR: ports/115891 Submitted by: Zhen REN <bg1tpt at gmail.com>
Notes
Notes: svn path=/head/; revision=198426
Diffstat (limited to 'net/pear-File_Bittorrent2')
-rw-r--r--net/pear-File_Bittorrent2/Makefile35
-rw-r--r--net/pear-File_Bittorrent2/distinfo3
-rw-r--r--net/pear-File_Bittorrent2/pkg-descr7
3 files changed, 45 insertions, 0 deletions
diff --git a/net/pear-File_Bittorrent2/Makefile b/net/pear-File_Bittorrent2/Makefile
new file mode 100644
index 000000000000..40a91d5cd736
--- /dev/null
+++ b/net/pear-File_Bittorrent2/Makefile
@@ -0,0 +1,35 @@
+# Ports collection makefile for: pear-File_Bittorrent2
+# Date created: 28 Aug 2007
+# Whom: Zhen REN <bg1tpt@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= File_Bittorrent2
+DISTVERSION= 1.0.0RC1
+CATEGORIES= net pear
+
+MAINTAINER= bg1tpt@gmail.com
+COMMENT= Decode and Encode data in Bittorrent format
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+
+CATEGORY= File
+FILES= Bittorrent2/Decode.php Bittorrent2/Encode.php \
+ Bittorrent2/Exception.php Bittorrent2/MakeTorrent.php
+
+_EXAMPLESDIR= .
+EXAMPLES= example.php example_mktorrent.php \
+ install-x86-universal-2005.0.iso.torrent \
+ scrape.php torrentinfo.php
+
+_TESTSDIR= Tests
+TESTS= AllTests.php Bug7406.php Bug8085.php FileBittorrent2.php
+
+post-extract:
+ @ cd ${WRKSRC}/File; ${MV} Bittorrent2 ${WRKSRC}
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
+.include <bsd.port.post.mk>
diff --git a/net/pear-File_Bittorrent2/distinfo b/net/pear-File_Bittorrent2/distinfo
new file mode 100644
index 000000000000..fe95008ea195
--- /dev/null
+++ b/net/pear-File_Bittorrent2/distinfo
@@ -0,0 +1,3 @@
+MD5 (PEAR/File_Bittorrent2-1.0.0RC1.tgz) = 615b467a202c91b7b151d316d7a73349
+SHA256 (PEAR/File_Bittorrent2-1.0.0RC1.tgz) = 9e5d7325f0a7094e763074bc9d7e5eec19204219042727cc6eb944eb8dda7035
+SIZE (PEAR/File_Bittorrent2-1.0.0RC1.tgz) = 69940
diff --git a/net/pear-File_Bittorrent2/pkg-descr b/net/pear-File_Bittorrent2/pkg-descr
new file mode 100644
index 000000000000..1da08223e01d
--- /dev/null
+++ b/net/pear-File_Bittorrent2/pkg-descr
@@ -0,0 +1,7 @@
+This package consists of three classes which handles the encoding
+and decoding of data in Bittorrent format. You can also extract
+useful informations from .torrent files, create .torrent files
+and query the torrent's scrape page to get its statistics.
+PHP5 only.
+
+WWW: http://pear.php.net/package/File_Bittorrent2/