aboutsummaryrefslogtreecommitdiff
path: root/net/pecl-radius
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-03-11 16:20:51 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-03-11 16:20:51 +0000
commit2868360a5dc1f3923675b26e254f5d6693fc7dd7 (patch)
tree7bb491cfbdcb205eda428a1a8abe8880246edff8 /net/pecl-radius
parente2415806bfe56fcee6459f888a3d0443a0c8311e (diff)
downloadports-2868360a5dc1f3923675b26e254f5d6693fc7dd7.tar.gz
ports-2868360a5dc1f3923675b26e254f5d6693fc7dd7.zip
New port: security/pecl-radius Radius client library
This package is based on the libradius of FreeBSD, with some modifications and extensions. This PECL provides full support for RADIUS authentication (RFC 2865) and RADIUS accounting (RFC 2866), works on Unix and on Windows. Its an easy way to authenticate your users against the user-database of your OS (for example against Windows Active-Directory via IAS). PR: ports/78638 Submitted by: Antonio Carlos Venancio Junior <antonio@php.net>
Notes
Notes: svn path=/head/; revision=130901
Diffstat (limited to 'net/pecl-radius')
-rw-r--r--net/pecl-radius/Makefile30
-rw-r--r--net/pecl-radius/distinfo2
-rw-r--r--net/pecl-radius/pkg-descr9
-rw-r--r--net/pecl-radius/pkg-plist6
4 files changed, 47 insertions, 0 deletions
diff --git a/net/pecl-radius/Makefile b/net/pecl-radius/Makefile
new file mode 100644
index 000000000000..fc1b4973668b
--- /dev/null
+++ b/net/pecl-radius/Makefile
@@ -0,0 +1,30 @@
+# Ports collection makefile for: pecl-radius
+# Date created: 09 March 2005
+# Whom: Antonio Carlos Venancio Junior (<antonio@inf.ufsc.br>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= radius
+PORTVERSION= 1.2.4
+CATEGORIES= net security pear
+MASTER_SITES= http://pecl.php.net/get/
+PKGNAMEPREFIX= pecl-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PECL
+
+MAINTAINER= antonio@php.net
+COMMENT= Radius client library for PHP
+
+USE_PHP= yes
+USE_PHPEXT= yes
+
+CONFIGURE_ARGS= --enable-radius
+
+.if !defined(NOPORTDOCS)
+post-install:
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/pecl-radius/distinfo b/net/pecl-radius/distinfo
new file mode 100644
index 000000000000..3b3a193e33ba
--- /dev/null
+++ b/net/pecl-radius/distinfo
@@ -0,0 +1,2 @@
+MD5 (PECL/radius-1.2.4.tgz) = 3d48ccb9486b9e8839d814d7ff318091
+SIZE (PECL/radius-1.2.4.tgz) = 29599
diff --git a/net/pecl-radius/pkg-descr b/net/pecl-radius/pkg-descr
new file mode 100644
index 000000000000..eb8f79ad997b
--- /dev/null
+++ b/net/pecl-radius/pkg-descr
@@ -0,0 +1,9 @@
+This package is based on the libradius of FreeBSD, with some modifications and
+extensions.
+
+This PECL provides full support for RADIUS authentication (RFC 2865) and
+RADIUS accounting (RFC 2866), works on Unix and on Windows. Its an easy way to
+authenticate your users against the user-database of your OS (for example
+against Windows Active-Directory via IAS).
+
+WWW: http://pecl.php.net/package/radius/
diff --git a/net/pecl-radius/pkg-plist b/net/pecl-radius/pkg-plist
new file mode 100644
index 000000000000..19d3396fde6c
--- /dev/null
+++ b/net/pecl-radius/pkg-plist
@@ -0,0 +1,6 @@
+%%PORTDOCS%%%%EXAMPLESDIR%%/radius-auth.php
+%%PORTDOCS%%%%EXAMPLESDIR%%/radius-acct.php
+%%PORTDOCS%%%%EXAMPLESDIR%%/des.php
+%%PORTDOCS%%%%EXAMPLESDIR%%/mschap.php
+%%PORTDOCS%%%%EXAMPLESDIR%%/mschaptest.php
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%