aboutsummaryrefslogtreecommitdiff
path: root/net/php74-xmlrpc
diff options
context:
space:
mode:
authorTorsten Zuehlsdorff <tz@FreeBSD.org>2019-09-20 12:21:11 +0000
committerTorsten Zuehlsdorff <tz@FreeBSD.org>2019-09-20 12:21:11 +0000
commit7aca2531e2d785929c4477143e265a8d9b0b516b (patch)
tree5eb143508ff1769e64395b54d8a3b09e1576fba0 /net/php74-xmlrpc
parent2a5ef470852066fb4e7c665bc1bb5be0b206d82b (diff)
downloadports-7aca2531e2d785929c4477143e265a8d9b0b516b.tar.gz
ports-7aca2531e2d785929c4477143e265a8d9b0b516b.zip
Notes
Diffstat (limited to 'net/php74-xmlrpc')
-rw-r--r--net/php74-xmlrpc/Makefile11
-rw-r--r--net/php74-xmlrpc/files/patch-config.m423
2 files changed, 34 insertions, 0 deletions
diff --git a/net/php74-xmlrpc/Makefile b/net/php74-xmlrpc/Makefile
new file mode 100644
index 000000000000..a17770b31523
--- /dev/null
+++ b/net/php74-xmlrpc/Makefile
@@ -0,0 +1,11 @@
+# $FreeBSD$
+
+CATEGORIES= net
+
+MASTERDIR= ${.CURDIR}/../../lang/php74
+
+PKGNAMESUFFIX= -xmlrpc
+
+TEST_TARGET= test
+
+.include "${MASTERDIR}/Makefile"
diff --git a/net/php74-xmlrpc/files/patch-config.m4 b/net/php74-xmlrpc/files/patch-config.m4
new file mode 100644
index 000000000000..d2dc85f26a48
--- /dev/null
+++ b/net/php74-xmlrpc/files/patch-config.m4
@@ -0,0 +1,23 @@
+--- config.m4.orig 2014-04-29 08:04:30.000000000 +0000
++++ config.m4 2014-05-15 08:04:00.883004682 +0000
+@@ -61,11 +61,9 @@ if test "$PHP_XMLRPC" != "no"; then
+ fi
+ fi
+
+- dnl if iconv is shared or missing then we should build iconv ourselves
+- if test "$PHP_ICONV_SHARED" = "yes" || test "$PHP_ICONV" = "no"; then
+-
+ if test "$PHP_ICONV_DIR" != "no"; then
+ PHP_ICONV=$PHP_ICONV_DIR
++ PHP_ADD_INCLUDE($PHP_ICONV_DIR/include)
+ fi
+
+ if test -z "$PHP_ICONV" || test "$PHP_ICONV" = "no"; then
+@@ -75,7 +73,6 @@ if test "$PHP_XMLRPC" != "no"; then
+ PHP_SETUP_ICONV(XMLRPC_SHARED_LIBADD, [], [
+ AC_MSG_ERROR([iconv not found, in order to build xmlrpc you need the iconv library])
+ ])
+- fi
+ fi
+
+ if test "$PHP_XMLRPC" = "yes"; then