aboutsummaryrefslogtreecommitdiff
path: root/net/phpldapadmin
diff options
context:
space:
mode:
authorMatthew Seaman <matthew@FreeBSD.org>2013-09-27 13:39:05 +0000
committerMatthew Seaman <matthew@FreeBSD.org>2013-09-27 13:39:05 +0000
commitab69f540b97b8680464b2585f1434f6a42aeb1e4 (patch)
tree2b1831facb8ddfcedd8b58423aba539483ecb2e4 /net/phpldapadmin
parent06168313aa0990a89cc13affee9fb5f7c594508a (diff)
downloadports-ab69f540b97b8680464b2585f1434f6a42aeb1e4.tar.gz
ports-ab69f540b97b8680464b2585f1434f6a42aeb1e4.zip
- stageify
Notes
Notes: svn path=/head/; revision=328467
Diffstat (limited to 'net/phpldapadmin')
-rw-r--r--net/phpldapadmin/Makefile11
1 files changed, 2 insertions, 9 deletions
diff --git a/net/phpldapadmin/Makefile b/net/phpldapadmin/Makefile
index 73650dd4e6ee..633273bd7d63 100644
--- a/net/phpldapadmin/Makefile
+++ b/net/phpldapadmin/Makefile
@@ -20,7 +20,6 @@ DEFAULT_PHP_VER= 5
OPTIONS_DEFINE= SUPHP
SUPHP_DESCR= suPHP support
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MSUPHP}
@@ -75,7 +74,7 @@ install-app:
cd ${WRKSRC} ; \
for src in $$( ${FIND} . ! -name .cvsignore \
! -name .gitignore ) ; do \
- dst=${WWWDIR}$${src#.} ; \
+ dst=${STAGEDIR}${WWWDIR}$${src#.} ; \
if ${TEST} -d $$src ; then \
${MKDIR} $$dst ; \
else \
@@ -84,17 +83,11 @@ install-app:
done
install-conf:
- cd ${WWWDIR}/${CFGDIR} ; \
+ cd ${STAGEDIR}${WWWDIR}/${CFGDIR} ; \
${CHMOD} 0640 ${CFGFILE}.example ; \
${CHGRP} ${GROUPS} ${CFGFILE}.example ; \
if ${TEST} ! -f ${CFGFILE} ; then \
${CP} -p ${CFGFILE}.example ${CFGFILE} ; \
fi
-post-install:
-.if ${PORT_OPTIONS:MSUPHP}
- ${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-.endif
- ${CAT} ${PKGMESSAGE}
-
.include <bsd.port.mk>